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Schematic Editor 

 

Function 

The Schematic Editor allows you to create, edit, check and print the schematic sheets that make up a design project. All the 
tools and utilities needed to perform checks for electrical and drafting violations, generate reports and create presentation 
quality schematic drawings are available in the editor. 

Editor Environment 

When the Schematic Editor is active i.e. a schematic document (*.SchDoc is open and active) the main application window will 
contain: 

• a main design window in which to capture the design 

Summary  
This comprehensive reference provides information on the Schematic Editor and the various objects that can be used in 
order to capture your design. 
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• editor-specific menus and toolbars 

• workspace panels - both global and editor-specific. 

Object placement, wiring and graphical editing are carried out on one or more schematic sheets, each of which appears, when 
opened, as a tabbed document view in the editor's main design window. 

 

The use of the main design window in terms of actual design (placement, editing, compilation, etc) is outside the scope of this 
topic and information for such should be sought in the relevant documentation. The following sections, however, offer useful 
hints and tips with respect to working on schematic documents in the main design window in general. 

The Editor View and Compiled Documents View 
The Schematic Editor has a main design window where all of your designs are drawn and viewed. You will notice each 
Schematic Document in your project has an Editor tab. The design constructed in the Editor tab is the source for compilation 
which produces Compiled Documents that can be viewed using Compiled Document tabs. Editor and Compiled Document 
tabs are located along the bottom of the Schematic Document in the design window.  
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For a multi-channel design, there is one Compiled Document per Channel. If there are no channels in your design, there is only 
one Compiled Document per Schematic Document.  

Compiled Document tabs are named using the Room Name which is based on the Sheet Symbol Designator. The top sheet in a 
hierarchical design does not have a Sheet Symbol Designator so the Compiled Document tab Name is the same as the 
filename. For example, Mixer.SchDoc, has the Compiled Document tab, Mixer. You can customize your Compiled tab Names 
further in your Project Options dialog (Project » Options » Multi-Channel) by changing your Room Naming Style. 

Compiled Documents View 
The Editor tab is the only tab visible in the Schematic Editor before the project is compiled. When Schematic Documents are 
edited, the Editor tab becomes the active tab. After you have compiled your project, Compiled Documents can be viewed by 
clicking on the Compiled Document tabs. If you attempt to make any changes to your design in a Compiled Document, editing 
mode is activated and the Editor tab becomes active. 

Compiled Document tabs are distinguished from the Editor tab by both their naming convention and the font properties of the 
tab names. The Editor tab name is black and bold whereas the Compiled Document tab names are not bold and are gray. 

 
Note: The Editor tab is the only tab you will see when you first open a project. You have to compile your project to view 
Compiled Documents.  

Compiled Document Preferences – Gray Scale 
Compiled Documents are displayed with a different color scheme from the source document in the Editor tab. They are grayed 
out by default which helps to identify when you are viewing Compiled Documents which are read only. 
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By default, expanded names for 
Designators have the option, Display 
superscript if necessary selected. 
This means that expanded names are 
only displayed for Designators in the 
Compiled Documents if they are 
different from the source in the Editor 
view and vice versa. 

 
You can customize the Gray Scale of your design in the Compiled Documents by: 
• Selecting the DXP » Preferences command which brings up the Preferences dialog 

• Navigating to the Compiler tab under the Schematic folder 

• In the Compiled Names Expansion section of the dialog, use the Full Color to Gray Scale slider bar to specify the extent 
of color in your Compiled Documents. 

Compiled Document Preferences – Compiled Names Expansion 
Compiled Documents display the compiled data with the corresponding source data displayed in brackets using superscript. 

 

Upon compilation, the corresponding compiled data of your objects is also displayed in brackets using superscript in the Editor 
tab. If there are multiple compiled names for an object, the first name is displayed followed by 3 ellipses (…). You can view the 
list of Compiled Names by hovering your mouse over the object. 

By default, the Compiled 
Documents View is set at 70% 
Gray Scale. 

Editor View 

Compiled Document View 

Compiled Document View 

Editor View 
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You can customize how the source data is displayed in your Compiled and Source Documents by: 
• Selecting the DXP » Preferences command which brings up the Preferences dialog 

• Navigating to the Compiler tab under the Schematic folder 

In the Compiled Names Expansion section of the dialog, choose which names you would like to be displayed in superscript. 
These options are applicable to both the Editor tab and your Compiled Document tabs. 

There are three options to choose from for each object: 
• Never display superscript – expanded names are never displayed 

• Always display superscript – expanded names are always displayed 

• Display superscript if necessary – expanded names are only displayed if they are different from the source 

 

Searching for Compiled Names 
You can use the Edit » Find Text command to search for Compiled Names in your project. 
For example, using the circuitry above, R1 is the designator in the Editor View and R10, R20 and R30 are the compiled names. 
You can search for R10, R20 and R30 providing you have compiled your project. You do not have to have the compiled 
document active to search for compiled names.  

Editor View with Compiled Data in Superscript 
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Printing Compiled Documents 
Compiled Documents cannot be printed from the Schematic Editor. If you attempt to print Compiled Documents, the source 
document in the Editor tab will be printed. 

To print Compiled Documents, create or use an existing Output Job and either: 

• Select the data source: [Project Physical Documents] for your Schematic Prints outputs, indicating that you want to print 
Compiled Documents, then right-click and select Print from the pop-up menu that appears or use the File » Print command 

• Use the Publish to PDF feature to create custom PDF documents which can include both the logical design in the Editor tab 
and the physical design in your Compiled Documents for all or some of your Schematic Documents. 

For more detailed information on the OutputJob Editor, refer to the OutputJob Editor Reference document.  

Specifying Document Options 
Options specific to the active schematic document are defined in the Document Options dialog, which can be accessed by 
choosing Design » Document Options from the main menus. 

This dialog provides controls for defining the look and feel of the schematic sheet, enabling and sizing grids, specifying the units 
of measurement to be used and any relevant document parameters. Use the dialog's 'What's This Help' feature to obtain 
detailed information about each of the options available. Click on the question mark button at the top right of the dialog and then 
click over a field or option to pop-up information specific to that field or option. 

 

Specifying Workspace Preferences 
General workspace preferences - applicable to all schematic documents - are defined on the relevant pages contained within 
the Schematic section of the Preferences dialog. Choosing Tools » Schematic Preferences from the main menus will take 
you to the Schematic - General page of this dialog. Again, use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available across the various pages. 
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Right-Click Menus 
Right-clicking in the main design window will pop-up a menu providing commands to 
access commonly used features such as document options and workspace preferences, 
as well as commands that are in context with the object currently under the cursor, (such 
as Properties and Find Similar Objects). 

Panning 
Panning in the workspace can be carried out in the following ways: 

• using the horizontal and vertical toolbars 
• using the keyboard arrow keys (holding Shift key for faster movement) 

• using the mouse wheel (Roll Up - pan up; Roll Down - pan down; Shift+Roll Up - 
pan left; Shift+Roll Down - pan right) 

• right-click and hold to access the panning hand. 

Zooming 
Zooming in the workspace can be achieved in the following ways: 
• using the Page Up (zoom in) and Page Down (zoom out) keyboard shortcuts. 

• using the mouse wheel (Ctrl+Roll Up - zoom in; Ctrl+Roll Down - zoom out). 

• using the mouse wheel (push the wheel button down and move mouse up to zoom in, move mouse down to zoom out). 

Moving a group of selected objects 
You can move selected objects using a combination of the ctrl key and arrow keys (vertically or horizontally) or the ctrl and shift 
keys and arrow keys on the schematic document. 
The movement of selected objects are set according to the current Snap Grid setting in the Document Options dialog 
(Document » Options or short cut D,O). Use this dialog to change the Snap Grid Value. This Grid value also appears on the 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 8 

Status bar of Altium Designer. The Schematic – Grids page of the Preferences dialog (Tools » Schematic Preferences or 
shortcut T, P) can also be used to set Imperial and Metric grid presets. Use the G shortcut to cycle through different snap grid 
setting values. You can also use the View » Grids submenu or the Grids right-click menu. 

• Selected objects can be 'nudged' by small amounts (according to the current snap grid value) by pressing the arrow keys 
while holding down the ctrl key. 

• Selected objects can also be 'nudged' by large amounts (snap grid value by a factor of 10) by pressing the arrow keys while 
holding down the ctrl and shift keys together. 

Jumping to Harness Definition Files 

Click the  button at the bottom right of the main design window to jump to the Harness Definition File for the active 
Schematic Document. Notice that this icon flashes red when you make any changes to your Signal Harness, indicating that 
processing is occurring and your Harness Definition Files are being updated. 

For information on the harness objects and their harness definition files, please refer to the article Using Signal Harnesses. 

Highlighting Pens 
Click on the  button at the bottom right of the main design window to access the highlighting 
pen feature. This feature allows you to highlight connections and/or entire nets within the design. 
Pressing the Spacebar while the feature is active will change the color of the pen. The following 
colors are available: 

Blue Light Green Cyan Red 

Magenta  Yellow Dark Green   

Pressing Ctrl and clicking on a port or sheet entry while the feature is active will highlight the connection/net on the target 
schematic sheet. 
To clear all highlighting on the active sheet, click on the Clear button at the bottom right of the main design window. 

Selection Memory 
Click on the  button at the bottom right of the main design window to access the Selection Memory dialog, from where you 
can control all aspects of the selection memory feature. 

 
For information on the dialog's use, press F1 when the cursor is over the dialog. 

Mask Level Controls 
Click on the  button at the bottom right of the design window to access a pop-up 
containing controls for adjusting the masking level when the mask highlight method is employed 
as part of temporary or permanent filtering. 
The Filter slider bar controls the 'dimming' when masking is applied using a permanent filter - 
e.g. when applying a query from the SCH Filter panel. 

The Dim slider bar controls the 'dimming' when masking is applied using a temporary filter - 
e.g. when browsing design objects on a schematic sheet using the Navigator panel or 
Interactive Navigation feature. 

In both cases, moving a slider downwards will result in a greater level of masking - with all 
design objects not falling under the scope of the applied filter becoming more dimmed in the 
workspace. 
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Clear Filtering 
Click on the  button at the bottom right of the main design window in order to clear any existing filtering applied to the 
current schematic document. If the filtering is temporary in nature, you can click anywhere inside the main design window in 
order to clear the filtering. If the applied filtering is permanent in nature, you must use this button, or one of its counterparts 
which can be found in the respective dialog(s) from which the original filtering was initiated. Using this button will also remove 
any highlighting applied using the Highlighting Pen feature. 

Associated Panels 

The following workspace panels are specific to the Schematic Editor: 
• SCH Filter panel 

• SCH Inspector panel 

• SCH List panel 

• Sheet panel 

Certain workspace panels, although not specific to the Schematic Editor, will be used frequently when capturing your design. 
These include the Projects panel, Navigator panel and Messages panel. 

For more information on a specific panel, press F1 when the cursor is over that panel. For a complete listing of all workspace 
panels, refer to the Altium Designer Panels Reference. 

Associated Design Objects 

The following is a list of the various objects available for capturing your design. Pressing F1 over a design object in the main 
design window will access information for that object directly. 

Arc Bezier Bus Bus Entry 

C Code Entry C Code Symbol Comment Compile Mask  

Compiler Generated 
Junction 

Designator  Device Sheet Symbol Ellipse 

Elliptical Arc Graphic  Harness Connector Harness Entry 

IEEE Symbols Instrument Probe Line Manual Junction 

Net Label No ERC Note Off Sheet Connector 

Parameter Parameter Set Part Pie Chart 

Pin Polygon Port Power Port 

Probe Rectangle Round Rectangle Sheet Entry 

Sheet Symbol Sheet Symbol Designator Sheet Symbol Filename Signal Harness 

Text Frame Text String Wire  

Re-entrant Editing 
The Schematic Editor includes a powerful feature which allows you to perform a second operation without having to quit from 
the operation you are currently carrying out. This facility is known as re-entrant editing. 

Re-entrant editing allows you to work more flexibly and intuitively. For example, you start placing a wire then remember that it 
needs to be connected to a port. There is no need to drop out of Place Wire mode, press the Place Port shortcut keys (P, R), 
place the port, press Esc to drop out of the Place Port process and then connect the wire to the port. 

The second operation can only be accessed by using its shortcut keys. 

A large number of processes can be completed within another process. The number of times another process can be launched 
before the current process is complete depends on the demands each of these incomplete processes is placing on the software. 
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Access to Shortcuts 
While capturing a design, knowledge of the various shortcuts to commonly used commands can be priceless from a productivity 
perspective. By keeping the Shortcuts panel visible, you can quickly peruse the shortcuts available to you, depending on what 
you are working on. For example, having a schematic document open will show the various Schematic Editor shortcuts. 

 

When an interactive command is running, for example placing a wire, you can access an additional pop-up menu listing all valid 
shortcuts for that stage of the interactive command. To do this, press the tilde key (~). 

 

Use the menu to refresh your memory about the shortcuts available, or use it in the traditional menu sense, to select the 
required option with the mouse. 

Arrangement of panels and toolbars is totally configurable and, once you have set up the working environment to your liking, 
can be saved using the View » Desktop Layouts » Save Layout command. 

Notes 

The Schematic Editor can generate single sheet, multiple sheet and fully hierarchical designs of virtually any size, limited only 
by the available memory and storage capacity of your PC. The editor also supports true multi-channel design - often a key 
feature in designs destined to live in an FPGA device. 

 

Sheet sizes include standard A-E, Orcad A-E, metric sizes A4-A0, Letter, Legal and Tabloid. You can also create your own 
custom sheet sizes, sheet borders and title blocks, which can be saved as templates for re-use. 
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A major feature of the Schematic Editor is its use of connectivity. This is the ability of the Software to recognize the physical 
links between objects inside the sheet and the ability to associate the logical connections that exist between various sheets in a 
multi-sheet design. Upon compilation of the source documents in a design project, the connective model of the design is used 
as the foundation for navigation using the Navigator panel. 

 

The naming of your Compiled Document tabs is dependent on the Room Naming Style specified Project Options dialog 
(Project » Options » Multi-Channel). Note that if you perform a Board Level Annotation on your project, any Room Naming 
Styles specified here will take precedence over your Project Options and the Compiled Document tabs will be renamed 
accordingly. For more information about Board Level Annotation, refer to the Application Note, Understanding Design 
Annotation. 
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Arc 

 

Description 
An arc is a non-electrical drawing primitive. It is essentially a curved line segment which can be used when, for example, 
creating graphical symbols, custom sheet borders and title blocks. 

Availability 
Arcs are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
Choose Place » Drawing Tools » Arc [P, D, A] from the Schematic Editor main menus. 

Schematic Library Editor 
Choose Place » Arc [P, A] from the Schematic Library Editor main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter arc placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press Enter to anchor the center point of the arc 

• move the cursor to adjust the radius of the arc, then click or press Enter to set it 

• move the cursor to adjust the start point for the arc, then click or press Enter to anchor it. 

• move the cursor to change the position of the arc's end point, then click or press Enter to anchor it and complete placement 
of the arc. 

Continue placing further arcs, or right-click or press Esc to exit placement mode. 

The arc object can be rotated or flipped while in placement mode and before the center point of the arc is anchored: 
• Press the Spacebar to rotate the arc. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the arc along the X-axis or Y-axis respectively. 

Editing 
The properties of an arc object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an arc object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Arc dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the arc object, which 
will be applied when placing subsequent arcs. 
During placement, the Arc dialog can be accessed by pressing the Tab key. 

After placement, the Arc dialog can be accessed in one of the following ways: 

• double-clicking on the placed arc object 
• selecting the arc object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed arc object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed arc object directly in the workspace and change its size, shape or location, 
graphically. 

When an arc object is selected, the following editing handles are available: 

 

Click and drag A to adjust the radius. 

Click and drag B to adjust the end points. 
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Click anywhere on the arc - away from editing handles - and drag to reposition it. The arc can be rotated or flipped while 
dragging. 
If you attempt to graphically modify an arc object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit. 
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Bezier 

 

Description 
A Bezier curve is a non-electrical drawing primitive. It is a free-form curved line that can be placed on a schematic sheet. The 
curve is defined by a series of vertex points that 'pull' the line into a curved shape. 

Availability 
Beziers are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Bezier [P, D, B] from the Schematic Editor main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Bezier [P, B] from the Schematic Library Editor main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter Bezier placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the curve 

• move the cursor and click or press Enter to place a series of vertex points to define the curve. As you move the cursor the 
curve will be continually redrawn to indicate how it would look if you placed a vertex at the cursor position 

• after placing the final vertex point, right-click or press Esc to complete placement of the curve. 

Continue placing further Bezier curves, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a Bezier object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a Bezier object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Bezier dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the Bezier object, 
which will be applied when placing subsequent Bezier curves. 
During placement, the Bezier dialog can be accessed by pressing the Tab key. 

After placement, the Bezier dialog can be accessed in one of the following ways: 

• double-clicking on the placed Bezier curve 
• selecting the Bezier curve and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed Bezier curve. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed Bezier curve object directly in the workspace and change its size and/or 
shape, graphically. 

When a Bezier curve object is selected, the following editing handles are available: 

 

Click and drag an editing handle to "bend" the curve. 
If you attempt to graphically modify a bezier object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
A Bezier must have at least four vertices to form a curve. 

The maximum number of vertices supported by a single Bezier object is 50. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
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enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Bus 

 

Description 
A bus is an electrical design primitive. It is a polyline object that represents a multi-wire connection. 

Availability 
Buses are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Bus [P, B] from the Schematic Editor main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter bus placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the bus 

• position the cursor and click or press Enter to anchor a series of vertex points that define the shape of the bus 

• after placing the final vertex point, right-click or press Esc to complete placement of the bus. 

Continue placing further bus objects, or right-click or press Esc to exit placement mode. 

Use the Backspace or Delete keys to remove the last bus segment placed. If you do remove segments in this way, you must 
click to place a final segment, otherwise right-clicking will place the bus as it was, with all deleted segments reinstated. 

Guided wiring 
Schematics have a definable electrical grid that makes it easy to define electrical connections between objects. As you are 
placing a bus, when the bus falls within the electrical grid range of another electrical object the cursor will snap to the fixed 
object and a Hot Spot (red cross) will appear. 

 

The Hot Spot guides you to where a valid connection can be made and automatically snaps the cursor to electrical connection 
points. 
The electrical grid can be defined on the Sheet Options tab of the Document Options dialog (Design » Document Options). It 
is recommended that you set the electrical grid to be slightly smaller than the current snap grid, or it becomes difficult to position 
electrical objects one snap grid apart. 

Auto-junctioning 
The schematic auto-junctioning feature places an electrical junction (compiler generated junction) when two buses are 
connected in a T-type fashion, or when a bus connects orthogonally to a pin or bus power port. 
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This feature allows you to easily create electrical connections at junction points without the need to manually define the 
connection (through placement of a manual junction). Buses that cross away from their end points do not have a junction 
automatically inserted. 
Display of auto-junctions on the schematic sheet, with respect to buses, can be controlled from the Schematic - Compiler page 
of the Preferences dialog (Tools » Schematic Preferences). Additional options provide control over junction size and color. 

Editing 
The properties of a bus object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a bus object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the individual options available. Click on 
the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that 
field or option. 

Editing Vertices 
The Bus dialog provides a Vertices tab, from where you can edit the individual vertices of the currently selected bus object as 
required.  

 
The main region of the tab lists all of the vertex points currently defined for the bus. You can add new vertices to the bus, edit 
the coordinates of existing vertices, or remove selected vertices altogether. 
Click the Menu button or right-click within the main list region to access a pop-up menu containing the following commands: 

• Edit - right click on a coordinate cell (X or Y) for a vertex and use this command to edit the value in that cell. Alternatively, 
click directly on the cell 
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• Add - use this command to add a new vertex point. The new vertex will be added below the currently focused vertex entry 
(as distinguished by a dotted outline around a cell in its row) and will initially have the same coordinates as the focused entry 

• Remove - use this command to remove the currently selected vertex entries in the list. This command will be unavailable if 
there are only two vertices present for the bus 

• Copy - use this command to copy the content of the selected cells in the list to the clipboard (alternatively use Ctrl+C) 

• Paste - use this command to paste the content of the clipboard into the list, starting at the selected cell (alternatively use 
Ctrl+V) 

• Select All - use this command to quickly select the entire grid contents of the list 

• Select Column - use this command to quickly select the entire column in which the currently focused cell resides 

• Move Up - use this command to move the selected vertex upward in the list 

• Move Down - use this command to move the selected vertex downward in the list 

• Move Bus By XY - use this command to move the entire bus object. The Move Bus By dialog will appear, from where you 
can enter the increment value to be applied to each vertex point's X and Y coordinates. 

Dialog access 
The Bus dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the bus object, 
which will be applied when placing subsequent buses. 
During placement, the Bus dialog can be accessed by pressing the Tab key. 

After placement, the Bus dialog can be accessed in one of the following ways: 

• double-clicking on the placed bus object 
• selecting the bus object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed bus object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed bus object directly in the workspace and change its size and/or shape, 
graphically. 

When a bus object is selected, the following editing handles are available: 

 

Click and drag A to reposition the end points of the bus. 

Click and drag B to move a bus vertex. The end points will remain anchored. 

Click and drag near the center of a bus segment to "grab" that segment and reposition it. The end points and other vertices will 
remain anchored. 
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Right-click on a vertex point and choose the Edit Bus Vertex n command to access the Vertices tab of the Bus dialog, with the 
entry for the nth vertex selected ready for editing. 

With the bus selected, click on a vertex or segment to individually select that vertex or segment. This bus 'sub-selection' is 
distinguished by the associated editing handles becoming red in color. 

 Individual vertex sub-selection. 

 Individual segment sub-selection. 

The associated vertex (or vertices for a segment) can then be edited directly using the SCH Inspector or SCH List panels, with 
any changes appearing immediately on the schematic. 
If you attempt to graphically modify a bus object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
When placing a bus, various placement modes are available: 90 Degree, 45 Degree, Any Angle and Auto Wire. The mode 
specifies how corners are created when placing buses and the angles at which buses can be placed. The 90 Degree and 45 
Degree modes (true orthogonal modes) both have Start and End sub-modes. 
If you attempt to graphically modify a bus object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  

 

The Auto Wire mode is a special mode that allows you to automatically connect between two points on the schematic. The 
Autowirer will automatically route the bus around obstacles. When in this mode, press the Tab key to set the Autowirer options 
in the subsequent Point to Point Router Options dialog: 

 

 

When placing a bus, press Shift+Spacebar to cycle through the bus placement modes. Press Spacebar to toggle between the 
Start and End sub-modes (when in 90 Degree or 45 Degree modes), or between Any Angle and Auto Wire modes (when either 
of these modes is active). 
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The current placement mode is displayed in the status bar. You can change modes at any time during bus placement. 

 

In all modes other than Any Angle, the line segment attached to the cursor is a "look ahead" segment. The segment you are 
actually placing precedes this look ahead segment. 

 

Use a Bus Entry object to connect to, or branch from, a bus. 

 

Buses can be attached to ports or sheet symbols for connection to other schematic sheets. 

 

Assign a bus to multiple nets using a Net Label of the form D[0..7] or D[7..0], indicating that the individual (and distinct) nets D0 
to D7 are carried by the bus. Whichever form you use, the ordering must be consistent between connected bus objects. 
Assigning a net label with this syntax (bus syntax) to a bus changes the bus object from being purely graphical to logical. 

Remember that net identifiers of different types do not automatically connect to one another, even if they share the same name. 
This holds true for net identifiers with bus syntax; a net label D[0..7] will not automatically connect to a port with the same name. 
The bus is required to connect them together. 

 

It is recommended that you define the net label in bus syntax to contain alpha characters only. For example, if you named the 
bus D2[0..7], it would be expanded to D20, D21..D27 which can cause net name conflicts. 

 

In FPGA designs, define a constant value for a bus by specifying the 
required value in the net label for the bus. The constant can be declared 
in either decimal, binary or hexadecimal format. For example, consider 
an FPGA_STARTUP16 device, with a required DELAY input of 342 
(decimal). The following entries for the bus net label could be used to 
define the constant: 
• Decimal: DELAY[15..0] <= 342 

• Binary: DELAY[15..0] <= b101010110 

• Hexadecimal: DELAY[15..0] <= $156 

In a binary definition, the leading zeroes need not be declared. You can of course declare all bits and, for added readability, 
separate nibbles by a space or a hyphen. Therefore the decimal value 342 could be defined in binary as: 
0000 0001 0101 0110 or 

0000-0001-0101-0110 

Leading zeroes need not be declared for a hexadecimal value either. Also, you can use $ or 0x prefixes to denote the value as 
being hexadecimal. 

 

Using Bus Joiners 
In FPGA designs, to manage the mapping of nets in buses there is a special class of component, known as a bus joiner. Bus 
joiners can be placed from the FPGA Generic integrated library (FPGA Generic.IntLib file from the \Library\Fpga\ 
folder of the Altium Designer installation.). By using bus joiner components, you can split, merge and reorder buses in a design 
with relative ease and efficiency. 

Splitting/Merging Buses 
Bus joiners separate/merge the bits (or bus slice) from least significant bit (or slice) down to most significant bit (or slice). Bus 
joiners are available in a range of sizes, catering for bus to pin, pin to bus and bus to bus splitting and merging. The following 
examples demonstrate this splitting and merging behavior, respectively. 
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- this particular bus joiner component splits the incoming 8-bit bus on pin I[7..0] into two 4-
bit bus slices, OA[3..0] and OB[3..0]. Obeying the least to most mapping at the slice 
level, the lower four bits of the input bus map to OA[3..0] and the upper four bits map to 
OB[3..0]. Following this through to the bit level, I0 will connect to OA0, and I7 will connect 
to OB3 

 

- this particular bus joiner component merges the two incoming 4-bit bus slices on pins 
IA[3..0] and IB[3..0] into a single 8-bit bus O[7..0]. Obeying the least to most 
mapping at the slice level, IA[3..0] maps to the lower four bits of the output and 
IB[3..0]maps to the upper four bits of the output. Following this through to the bit level, 
IA0 will connect to O0, and IB3 will connect to O7 

 

- this particular bus joiner component splits the incoming 8-bit bus on pin I[7..0] into eight 
single pin outputs, O0 to O7. Obeying the least to most mapping at the bit level, I0 will 
connect to O0, and I7 will connect to O7 

 

- this particular bus joiner component merges the eight single pin inputs on pins I0 to I7 into a 
single 8-bit bus O[7..0]. Obeying the least to most mapping at the bit level, I0 will connect 
to O0, and I7 will connect to O7 

In addition, bus joiners are available that allow you to split/merge bidirectional signals. The image below shows a bus joiner that 
joins an 8-bit IO bus on the left to two 4-bit IO buses on the right. 

 

Note that apart from the JB-type joiner, all bus joiner pins have an IO direction – use the correct joiner to maintain the IO flow. 
Pin IO can be displayed on sheet by enabling the Pin Direction option on the Schematic – General page of the Preferences 
dialog. 

Matching Buses of Different Widths 
The JB-type bus joiner allows you to match nets in buses of different widths. It does this via 2 component parameters, IndexA 
and IndexB that map from one bus through to the other bus. These indices must be defined when you use a JB-type bus joiner. 

 

Note that there is no IO direction for a JB-type bus joiner. 

Read the flow of nets through a JB-type bus joiner by matching from the nets in the first bus net label (on the left), to the first 
index on the bus joiner, to the second index on the bus joiner, to the nets defined in the second bus net label (on the right). 
Using the image above, the mapping can be summarized as: 
Left Bus ↔ IndexA ↔ IndexB ↔ Right Bus 

The following sections provide examples of using a JB-type bus joiner in a design and the rules used for matching nets. 
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Sub-set Mapping 

 

If both bus ranges are descending, match by same bus index (one range must lie within the other for valid connections). 
Mapping is as follows: 
ADDR9 ↔ IndexA9 ↔ IndexB9 ↔ ROMADDR9 thru to 

ADDR0 ↔ IndexA0 ↔ IndexB0 ↔ ROMADDR0 

(In this example ROMADDR10 thru ROMADDR13 will be unconnected). 

Offset Mapping 

 

In this example, mapping is as follows: 
INPUTS15 ↔ IndexA15 ↔ IndexB31 ↔ PORTB31 thru to 

INPUTS0  ↔ IndexA0  ↔ IndexB0  ↔ PORTB16 

Range Inversion 
If one bus range is descending and another is ascending, the indices are matched from left to right. 

 

In the image above the range of the left-hand bus is ascending, while that of the right-hand bus is descending. The mapping is 
as follows: 
INPUTS0  ↔ IndexA15 ↔ IndexB31 ↔ PORTB31 thru to 

INPUTS15 ↔ IndexA0  ↔ IndexB16 ↔ PORTB16 

 

In the image above the range of the left-hand bus is descending, while that of the right-hand bus is ascending. The mapping is 
as follows: 
INPUTS15 ↔ IndexA15 ↔ IndexB31 ↔ PORTB0 thru to 

INPUTS0  ↔ IndexA0  ↔ IndexB16  ↔ PORTB15 

For an example of using bus joiners, refer to the example \Examples\FPGA Design Tips\Bus 
Interconnect\Interconnect.PrjFpg in the Altium Designer installation. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Bus Entry 

 

Description 
A bus entry is an electrical design primitive. It is a special wire at an angle of 45 degrees that is used to connect a wire to a bus 
line. A bus entry allows you to connect two different nets to the same point on a bus. If this was done using wires the two nets 
would short. 

Availability 
Bus entries are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Bus Entry [P, U] from the Schematic Editor main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter bus entry placement mode. Click or press 
Enter to place a bus entry at the cursor position. 

Continue placing bus entries or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the bus entry. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the bus entry along the X-axis or Y-axis respectively. 

Editing 
The properties of a bus entry object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties 
of a bus entry object. 

Use the dialog's 'What's This Help' feature to obtain detailed information 
about each of the options available. Click on the question mark button at 
the top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. 

The Bus Entry dialog can be accessed prior to entering placement mode, 
from the Schematic - Default Primitives page of the Preferences dialog 
(Tools » Schematic Preferences). This allows you to change the default 
properties for the bus entry object, which will be applied when placing 
subsequent bus entries. 
During placement, the Bus Entry dialog can be accessed by pressing the Tab key. 

After placement, the Bus Entry dialog can be accessed in one of the following ways: 

• double-clicking on the placed bus entry object 
• selecting the bus entry object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed bus entry object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 
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Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed bus entry object directly in the workspace and change its location 
graphically. 

When a bus entry object is selected, the following editing handles are available: 

 

Click and drag A to move the bus connection point. 

Click and drag B to move the entire bus entry object. 

In either case, the bus entry can be rotated or flipped while dragging. 
If you attempt to graphically modify a bus entry object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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C Code Entry 

 

Description 
A C Code Entry is an electrical design primitive that belongs within a C Code Symbol. A C Code Symbol represents one top-
level exported C function, resident in a referenced C source file. The C Code Entries provide the means by which to access the 
parameters of the exported function. The entries themselves can be wired to other areas of the circuit design, allowing for 
transfer of data. 

Availability 
There are two types of C Code Entry – Parameter and Control. Parameter-type C Code Entries correspond to the parameters of 
the exported C function. This type of entry can be placed by the user. Control-type C Code Entries (START, DONE, CLOCK, 
RESET, RESET_DONE) are not part of the exported C function, but are automatically added to the C Code Symbol when the 
Multi-cycle interface mode for that symbol is chosen. 

Parameter-type C Code Entries are available for placement in the Schematic Editor only. They can be placed within C Code 
Symbols that in turn reside on schematic sheets that are part of either an FPGA project (*.PrjFpg), or a Core project 
(*.PrjCor). Use one of the following methods to access the placement command: 

• Choose Place » Add C Code Entry [P, Y] from the main menus 

• Click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter C Code Entry placement mode. 
Placement is made by performing the following sequence of actions: 

• The C Code Symbol is implicitly chosen by the position of the new C Code Entry floating on the cursor. The entry will change 
from being grayed-out to colored when it passes within the borders of a C Code Symbol. 

• Move the cursor to adjust the position of the C Code Entry in relation to any edge of the C Code Symbol, then click or press 
Enter to anchor the entry and complete placement. 

Continue placing further C Code Entries, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a Parameter-type C Code Entry object can be modified before, during and after placement. Editing itself falls 
into two categories - graphical and non-graphical. 
Note: As a Control-type C Code Entry can not be placed manually, it can only be edited after its automatic placement within the 
parent C Code Symbol. Only the graphical properties of a Control-type C Code Entry can be viewed and modified. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialogs to modify the properties of a Parameter-type C Code Entry object (left), or a 
Control-type C Code Entry object (right), respectively. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 

Data Type 
It is worth taking a closer look at the data types that can be specified for a Parameter-type C Code Entry, and how these map to 
data types used in the C source code. A C Code Entry can be classed as one of the following data types: 

• Boolean 

• Floating Point 

• Unsigned Integer 

• Signed Integer. 

The Boolean data type corresponds to the bool data type in C, as defined in stdbool.h. 
For the Floating Point data type, the associated Precision property can be set to Single or Double. These correspond to 32-
bit float and 64-bit double C data types respectively. 
For integer data types, the associated Integer Width property can be defined in the range 1 to 64. You are not limited to the 
widths of C data types. The following table shows the mapping of variable integer widths (defined for the C Code Entry) to C 
data types. 

Integer Width range specified for a C 
Code Entry with an integer data type 

is mapped to the following C 
unsigned integer types 

is mapped to the following C 
signed integer types 

1-8 unsigned char, uint8_t char, int8_t 

9-16 unsigned short, uint16_t short, int16_t 

17-32 unsigned int, unsigned long, 
uint32_t 

int, long, int32_t 

33-64 unsigned long long, uint64_t long long, int64_t 

This mapping becomes especially relevant during synchronization of C Code Entries with corresponding parameters in the 
exported C function. 

Dialog Access 
The C Code Entry (Parameter) dialog can be accessed prior to entering placement mode, from the Schematic - Default 
Primitives page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties 
for the C Code Entry object, which will be applied when placing subsequent C Code Entries. 
During placement, the C Code Entry (Parameter) dialog can be accessed by pressing the Tab key. 

After placement, the C Code Entry (Parameter) dialog (or C Code Entry (Control) dialog) can be accessed in one of the 
following ways: 
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• Double-clicking on the placed C Code Entry object 
• Selecting the C Code Entry object and choosing Properties from the right-click pop-up menu 

• Choosing the Change command from the Edit menu and then clicking once over the placed C Code Entry object.  

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed C Code Entry object directly in the workspace and change its location 
graphically. 

C Code Entries can only be adjusted with respect to their size by changing the size of the font used (accessed through the 
respective properties dialog). As such, editing handles are not available when the C Code Entry object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the C Code Entry within the C Code Symbol as required. The C 
Code Symbol will be resized automatically if you attempt to move the C Code Entry beyond the current extents of the symbol. 
If the Enable In-Place Editing option is enabled on the Schematic – General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the Parameter Name for the C Code Entry (Parameter-type only) directly in 
the workspace. Select the C Code Entry object and then click once to invoke the feature. Type the new name as required and 
then click away from the C Code Entry object or press Enter to effect the change. 

Sheet Entry Actions 
Right-clicking over a placed C Code Entry will pop-up a context-sensitive menu, from which a variety of commands are available 
that act on that C Code Entry (or on all selected C Code Entries where applicable). The following sections detail each of these 
commands. 
Note: Many of the following commands are also available from the Schematic Editor's main menus. Commands on the main 
menus apply to the selected C Code Entry(ies) or allow you to choose the C Code Entry on which the command will act, rather 
than just the C Code Entry under the cursor. Where such commands exist, reference to their access is made. 

Jumping to the Corresponding Parameter (Parameter-type only) 
This command is used to jump to the chosen C Code Entry's corresponding parameter in the exported function, in the C source 
file referenced by that entry's parent C Code Symbol. The command is accessed by right-clicking over the required C Code 
Entry and choosing Code Entry Actions » Jump to Parameter [ParameterName] from the menu that appears. 

Toggling C Code Entry I/O Type (Parameter-type only) 
This command is used to toggle the I/O Type for a C Code Entry. 

The command can be accessed by right -clicking over the required C Code Entry (or one C Code Entry in a selection of C Code 
Entries) and choosing Code Entry Actions » Toggle Parameter IO Type from the menu that appears. 

After launching the command, the I/O Type defined for each C Code Entry will be toggled. 
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Swapping C Code Entry Side 
This command is used to relocate a C Code Entry to the side of its parent C Code Symbol that is directly opposite to its current 
position. The C Code Entry's I/O Type is not changed by the swap. 

The command can be accessed by right-clicking over the required C Code Entry (or one C Code Entry in a selection of C Code 
Entries) and choosing Code Entry Actions » Swap Code Entry Side from the menu that appears. 

After launching the command, each C Code Entry will be swapped to the opposite side of its C Code Symbol. 

 

Reversing C Code Entry Order 
This command allows you to reverse the order that selected C Code Entries appear along a side of a parent C Code Symbol. 
The I/O Type of a C Code Entry is not changed by the reordering. 
The command can be accessed by choosing Edit » Move » Reverse Selected Sheet Entries Order from the Schematic 
Editor's main menus. 

Ensure that all C Code Entries that you wish to reorder are selected prior to launching the command. Two or more C Code 
Entries must be selected for a particular side of a C Code Symbol in order for the command to have effect. You can 
simultaneously reorder C Code Entries along different sides of the same parent C Code Symbol and across different C Code 
Symbols on the active schematic sheet. 

After launching the command, the reordering will take place. The reordering is achieved by mirroring the positions of the 
selected C Code Entries - along a particular C Code Symbol side - about an imaginary line at the mid point of the distance 
between the extents of the two most-outer selected C Code Entries. 

The following image shows reordering for two selected C Code Entries, whereby they exchange positions. 
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Notes 
The C language allows parameters of a function to have the same name, if they differ in case. However, it is illegal for C Code 
Entries in the the same C Code Symbol to have the same name, even if those names differ in case. 

 

The Parameter Name for a C Code Entry and the corresponding name for the parameter in the exported C function must be the 
same and be the same case. 

 

The parameters for the exported C function can also be defined directly on the Signature tab of the C Code Symbol's properties 
dialog. Corresponding C Code Entries for any parameters defined here will be added to the C Code Symbol accordingly, and 
automatically. 

 

If the exported C function provides a return value, such a value would appear as a special C Code Entry, with an IO Type of 
Output and a Parameter Name of retval. 

 

C functions allow only one return value, but it is possible to have more outputs by using pointer parameters. Output C Code 
Entries correspond to pointer parameters in the C function. Note that values must be assigned to output pointer parameters 
(and don't forget to dereference the pointer when assigning a value to it). 

 

Control-type C Code Entries START, DONE and CLOCK are added to the C Code Symbol when the interface mode for the symbol 
is set to Multi-cycle. If the Enable reset logic option is enabled, two additional Control-type C Code Entries will be added to 
the symbol – RESET and RESET_DONE. 

 

Should you need to negate (include a bar over the top of) a C Code Entry name, this can be done in one of two ways: 
• Include a backslash character after each character in the name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the name (e.g. \ENABLE). 

 

Changes made to object properties during placement will cause the default properties for the object to be updated, unless the 
Permanent option - on the Schematic – Default Primitives page of the Preferences dialog - is enabled. With this option 
enabled, changes will affect only the object being placed and subsequent objects placed during the same placement session. 

 

If you attempt to graphically modify a C Code Entry object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  Additionally, if the Protect Locked Objects option is enabled on the Schematic - 
Graphical Editing page of the Preferences dialog, then the object cannot be selected or graphically edited in any way. In this 
case, either disable the object's Locked property, or disable the Protect Locked Objects option. 
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C Code Symbol 

 

Description 
A C Code Symbol is an electrical design primitive. Similar in nature to a standard Sheet Symbol, it is used to reference an 
underlying C source file. More specifically, it represents a single, top-level exported function within that file. Access to 
parameters in the exported function is made using C Code Entry primitives – placed on the C Code Symbol and functionally 
similar to Sheet Entries placed on a standard Sheet Symbol. 

The exported C function is subsequently translated into a hardware function using Altium Designer's C-to-Hardware Compilation 
(CHC) technology. The end result is an independent module of FPGA logic which connects, through defined IO ports, to other 
areas of the circuit design. 

Availability 
C Code Symbols are available for placement in the Schematic Editor only. They can be placed on schematic sheets that are 
part of either an FPGA project (*.PrjFpg), or a Core project (*.PrjCor). Use one of the following methods to access the 
placement command: 
• Choose Place » C Code Symbol [P, M] from the main menus 

• Click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter C Code Symbol placement mode. 
Placement is made by performing the following sequence of actions: 
• Click or press Enter to anchor the top-left corner of the C Code Symbol. 

• Move the cursor to adjust the size of the C Code Symbol, then click or press Enter to anchor the diagonally-opposite corner 
and thereby complete placement. 

• Continue to place other C Code Symbols, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a C Code Symbol object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a C Code Symbol object: 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 

Signature Tab 
It is worth taking a closer look at the Signature tab of the C Code Symbol dialog, as it is here that the interface between the C 
Code Symbol and the exported function in the referenced C source file is defined. 

 

The required C function is 'hooked-up' to the C Code Symbol using the Function Name field. 

The Parameters region lists the parameters (and their properties) of the exported function. The entries here are made available 
on the C Code Symbol as C Code Entries – allowing for data transfer to/from other logic in the design. 

The C-to-Hardware Compiler can generate two types of circuit from the C source code for an exported function – 
Combinatorial and Multi-cycle. This is specified using the Interface field, which is set to Combinatorial by default. It 
is worth looking more closely at the difference between the two: 
• Combinatorial – this type of circuit consists of logic gates whose outputs at any time are 

determined only by the values of the inputs. In this interface mode, only the parameters of 
the exported function appear as C Code Entries on the C Code Symbol, commonly 
referred to as 'Parameter' entries. 

Combinatorial circuits can be generated for simple C functions which do not depend on 
stored state (memory, previous executions, etc). The C-to-Hardware Compiler will attempt 
to create a combinatorial circuit if requested but if this is not possible, an error will be 
issued during compilation and the interface mode must be changed to Multi-cycle. Note 

C Code Symbol with Combinatorial 
interface. 
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that if a function accesses global variables, this implies stored state and therefore a combinatorial circuit cannot be 
generated. 

• Multi-cycle – this type of circuit requires more than one clock cycle to complete. When 
this interface mode is selected, additional START, DONE and CLOCK C Code Entries will 
automatically be added to the C Code Symbol, commonly referred to as 'Control' entries. 
These entries are not part of the exported C function. 
The circuit begins operating when the START signal is High and is clocked at the 
frequency arriving at the CLOCK line. The inputs are assumed to be valid. When the circuit 
finishes operating, the DONE signal will be driven High and the outputs will be valid for one 
clock cycle. Due to the short availability of the outputs, external latching of the outputs is 
common practice. 

Additional Variables 
Three additional options are available in the lower region of the Signature tab – entitled Variables: 

• Enable reset logic – If this option is enabled, reset logic will be built into the C Code Symbol. Two additional Control-type C 
Code Entries will be added to the symbol – RESET and RESET_DONE. The RESET signal will typically be the same system 
reset used to reset other processor and peripheral devices within the design. When the RESET signal is asserted (active 
High), all initialized global and static variables (initialized when the FPGA device is programmed) will be reinitialized – set 
back to their initial values. 

• When all variables have finished being reset, the RESET_DONE signal will be taken High. 

• Clear uninitialized global/static variables upon reset – This option is only available provided the Enable reset logic option 
is enabled. When enabled, uninitialized global and static variables will be set to zero during a reset. This option essentially 
lets you skip the resetting of variables which do not need to be initialized to a predefined value (e.g. an array which is used 
as a buffer). 

• Resrve memory for address zero – In C, address zero is reserved for null pointers. With this option disabled, address zero 
in memories will not be reserved, allowing optimization of memory usage. 

Dialog Access 
The C Code Symbol dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page 
of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the C Code 
Symbol object, which will be applied when placing subsequent C Code Symbols.  
During placement, the C Code Symbol dialog can be accessed by pressing the Tab key. 

After placement, the C Code Symbol dialog can be accessed 
in one of the following ways: 

• Double-clicking on the placed C Code Symbol object. 

• Selecting the C Code Symbol object and choosing 
Properties from the right-click pop-up menu. 

• Choosing the Change command from the Edit menu and 
then clicking once over the placed C Code Symbol object. 

The Designator and Filename text fields associated with a 
C Code Symbol can be formatted independently of the C 
Code Symbol itself. The corresponding properties dialogs for 
each - the Sheet Symbol Designator and Sheet Symbol File 
Name dialogs respectively - can be accessed using the three 
methods described above (replacing C Code Symbol with the 
relevant object whose properties you wish to view/modify). 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

C Code Symbol with Multi-cycle 
interface. 
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Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed C Code Symbol object directly in the workspace and change its size, shape 
or location, graphically. 

When a C Code Symbol object is selected, the following editing handles are available: 

 

Click and drag A to resize the C Code Symbol in the vertical and horizontal directions separately. 

Click and drag B to resize the C Code Symbol in the vertical and horizontal directions simultaneously. 

Resizing the C Code Symbol will not affect the absolute positions of any defined C Code Entries within. 

Click anywhere on the C Code Symbol - away from editing handles - and drag to reposition it. 

The C Code Symbol's Designator and Filename text fields can only be adjusted with respect to their size by changing the size of 
the font used (accessed through the Sheet Symbol Designator and Sheet Symbol File Name dialogs, respectively). The same is 
true for any parameters that have been defined for the symbol, and which are visibly displayed in the workspace. In this case, 
the font size can be changed in the associated Parameter Properties dialog. 

Editing handles are not available when any of these text objects are selected, as illustrated for Designator and Filename objects 
below: 

 

Click anywhere inside the dashed box and drag to reposition the text object as required. 

The C Code Symbol and any of its associated text objects can be rotated or flipped while dragging: 
• Press the Spacebar to rotate. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for an associated text object directly in the workspace. Select the 
text object and then click once to invoke the feature. Type the new name as required and then click away from the text object or 
press Enter to effect the change. 

C Code Symbol Actions 
Right-clicking over a placed C Code Symbol will pop-up a context-sensitive menu, from which a variety of commands are 
available that act on that C Code Symbol (or on all selected C Code Symbols where applicable). The following sections detail 
each of these commands. 
Note: Many of the following commands are also available from the Schematic Editor's main menus. Commands on the main 
menus apply to the selected C Code Symbol(s) or allow you to choose the C Code Symbol on which the command will act, 
rather than just the C Code Symbol under the cursor. Where such commands exist, reference to their access is made. 

Opening a Selected C Code Symbol's Source File 
This command applies only to the C Code Symbol under the cursor and is accessed by right-clicking and choosing Code 
Symbol Actions » Open Source File "FileName.c" from the menu that appears. 
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The child C source file for the symbol will be opened (if not already) and made the active document in the main design window. 

Creating a C Source File directly from a C Code Symbol 
This command is used to create a new C source code document from a C Code Symbol. A shell function is created using the 
information specified on the Signature tab of the C Code Symbol dialog. In this way, you can define how you want an 
independent module of FPGA logic to 'plug-in' to the rest of your design, prior to writing the C-based functionality of that logic. 

The command can be accessed either by: 
• Choosing Design » Create C File From Code Symbol from the main menus. You will be prompted to choose a C Code 

Symbol. 
• Right-clicking over the required C Code Symbol and choosing Code Symbol Actions » Create C File From Code Symbol 

from the menu that appears. 

After launching the command (and choosing the C Code Symbol if applicable), the C source document will be created and 
opened as the active document. The file will contain a shell function, named using the entry in the Function Name field, on the 
Signature tab of the C Code Symbol dialog. Parameters for the function are taken from the Parameters region of the 
Signature tab, which are synchronized to the corresponding C Code Entries on the symbol. 

The C source document that is created is named using the entry in the C Code Symbol's Filename field. You can either enter 
the intended name for the document in this field before launching the command, complete with extension (i.e. 
DocumentName.c), or leave the name blank and enter the name when saving the generated document at a later stage. 

Care should be taken when creating a C source file from a C Code Symbol and a file with that filename already exists. A new C 
source file with the same filename will be created. The duplication can be resolved when saving, by either saving the new file 
with a different name, or overwriting the existing file if required. 

Renaming a C Code Symbol's Source File 
This command provides a quick and efficient facility for renaming the underlying C source file referenced by a selected C Code 
Symbol. 
The command can be accessed by right-clicking over the required C Code Symbol and choosing Code Symbol Actions » 
Rename Source File from the menu that appears. 

After launching the command, the Rename Child Sheet dialog will appear. 
Initially, the New child sheet file name field will contain 
the current name for the document. Type the new name for 
the document as required - ensuring that the .c extension 
remains. 
The Rename Mode region of the dialog allows you to 
determine how the renaming should proceed. The first two 
options, as their names suggest, rename the source file. 
The options differ in the scope of the update with respect to 
the C Code Symbols that point to this sheet - either in the 
active project or across all projects in the active design 
workspace. In each case, the Filename field for the C 
Code Symbol will be updated to reflect the newly named 
source file. 

The third option takes a copy of the source file before 
renaming the original. Only the current C Code Symbol is updated using this option. This is useful when the current source file is 
referenced by multiple C Code Symbols, and one C Code Symbol needs to reference a modified version of a function contained 
in that file. You still want to keep the original source file - you are creating a renamed copy of this file with which to point to from 
a single C Code Symbol. You can then modify the content of the file as required. 
Enabling the Compile project(s) after rename option will ensure that the newly named source file is correctly inserted into the 
design hierarchy, which will be reflected on the Projects panel. 

Synchronizing C Code Entries and Parameters 
The Schematic Editor provides a facility for maintaining synchronization between the C Code Entries on a C Code Symbol and 
the corresponding parameters of the exported function, in the referenced C source file below. Two commands are used to 
implement this facility, differing only in their scope. 
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Synchronization for Current C Code Symbol 
Allows you to synchronize the C Code Entries and sub-file function parameters for the C Code Symbol currently under the 
cursor. The command can be accessed by right-clicking over the required C Code Symbol and choosing Code Symbol Actions 
» Synchronize Code Entries and Parameters from the menu that appears. 

After launching the command, the Synchronize Ports To Sheet Entries On [CCodeSymbolDesignator] dialog will appear, as 
shown in the image on the following page. This incarnation of the Synchronize dialog includes a single tab for the C Code 
Symbol under the cursor. 

 

Synchronization for all C Code Symbols 
Allows you to synchronize the C Code Entries and sub-file parameters for each C Code Symbol in the active design project. The 
command can be accessed by choosing Design » Synchronize Sheet Entries And Ports from the main menus. 

After launching the command, the Synchronize Ports To Sheet Entries In [ActiveProjectName] dialog will appear: 

 

This incarnation of the Synchronize dialog includes a separate tab for each C Code Symbol found in the project. 

Using the Dialog 
The aim, when using the Synchronize dialog, is to ensure that all C Code Entries on a C Code Symbol are matched to 
parameters of the referenced function in the underlying C source file, both in terms of name and I/O Type. 
Note: Control-type C Code Entries (START, DONE, CLOCK, RESET, RESET_DONE) are always synchronized by default, when 
used. You cannot manipulate the entries for these within the Synchronize dialog. 

The left-hand side of the dialog provides two regions: 

• One listing all currently unmatched C Code Entries (Parameter-type) associated to the chosen C Code Symbol. The 
Designator of the C Code Symbol appears as the header for the region. Each C Code Entry in this region is listed in terms of 
its Parameter Name and I/O Type. The Parameter Name will have additional information appended (in brackets), reflecting 
the data type and width of the C Code Entry. 

• One listing all currently unmatched parameters of the exported function in the C source file referenced by the C Code 
Symbol. The document name appears as the header for the region. Each parameter entry in this region is listed in terms of 
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its Name and I/O Type. The Name will have additional information appended (in brackets), reflecting the data type of the 
parameter. If the parameter has I/O Type of Output, it will be a pointer parameter (denoted by an asterisk (*) after its data 
type). 

The right-hand side of the dialog lists all currently linked (or matched) C Code Entry-parameter pairings. Each entry shows the 
common name used by both the C Code Entry as its Parameter Name and the parameter as its Name (again, information on 
the source function parameter's data type, width and direction is included in brackets). The IO column shows the current I/O 
Type set for each pairing. 
Note: The Parameter Name of a C Code Entry and the the name of the corresponding parameter in the C source function, must 
have the same case. 

The simplest way to explain the workings of the dialog, in terms of matching C Code Entries with parameters, is to use an 
example. Consider the C Code Symbol and corresponding exported function parameters in the following image. 

 

The two Parameter-type C Code Entries (GO_I and GO_PULSE_O) in the symbol correspond, both in name and I/O Type, to a 
parameters in the exported function in the referenced C source file. Accessing the Synchronize dialog for this C Code Symbol, 
there are no unmatched entries (Remember that Control-type C Code Entries are automatically synchronized by default). 

 

Now consider the same C Code Symbol, but with a few intentional changes made within the design, as listed below and 
summarized in the following image: 
• Parameter Name for the C Code Entry GO_I changed to GO 

• Name of parameter in C source function changed from GO_PULSE_O to PULSE_OUT 

• Extra C Code Entry added, with Parameter Name PULSE_COUNT, Data Type set to Unsigned Integer, Integer Width 
set to 8 and I/O Type set to Output 

 

This time when the Synchronize dialog is accessed, the changes introduced cause links between C Code Entries and 
parameters to be broken and the unmatched lists become populated. 
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The two unmatched regions must now be used to resolve the current unsynchronized state that exists between the C Code 
Entries of the symbol and the parameters of the function in the underlying C source file. Below each region are two buttons, the 
use of which will involve making one or more of the following matching decisions: 
• If there are C Code Entries that you no longer require, select each (use Ctrl+click, Shift+click or click-and-drag for multi-

select) and click the Delete Sheet Entries button. Each C Code Entry in the selection will be removed from the C Code 
Symbol. 

• If there are parameters in the exported function that you no longer require, select each and click the Delete Ports button. 
Each parameter in the selection will be removed from the C source function. 

• If there are existing C Code Entries that you need to keep but no corresponding parameters exist for these entries, you can 
automatically create parameters with the same names and I/O Types (and applicable data types/widths) by selecting each C 
Code Entry and clicking the Add Ports button. The required parameter(s) will be added to the C functions parameter list. 
The Synchronize dialog will automatically update, with an entry for each C Code Entry-parameter pairing automatically 
entered into the Links region of the dialog. 

• If there are existing parameters that you need to keep but no corresponding C Code Entries for these parameters, you can 
automatically create C Code Entries with the same names and I/O Types (and applicable data types/widths) by selecting 
each parameter and clicking the Add Sheet Entries button. You will be taken to the C Code Symbol, with the C Code 
Entry(ies) floating on the cursor ready for initial placement. Click or press Enter to place the C Code Entry(ies). The 
Synchronize dialog will reappear, with an entry for each C Code Entry-parameter pairing automatically entered into the 
Links region of the dialog. 

All other residual unmatched entries will either be due to name or I/O Type mismatching. For these, manual matching can be 
carried out. This is done by selecting a C Code Entry in one region and a parameter in the other and then using one of the 
following two buttons to determine which name and I/O Type attributes are used when linking: 

 - Use this button to link the selected C Code Entry with the selected parameter, using the name and I/O Type 
defined for the C Code Entry. The parameter will be renamed and/or its I/O type changed, and the applicable data 
type/width set also. 

 - Use this button to link the selected C Code Entry with the selected parameter, using the name and I/O Type 
defined for the parameter. The C Code Entry will be renamed and/or its I/O type changed, and the applicable data 
type/width set also. 

If you want to break up a linked entry, select it in the Links region of the dialog and click on the  button. 

The actual process of matching will vary from C Code Symbol to C Code Symbol, depending on the discrepancies involved and 
your preferred matching techniques. Considering the point reached with the underlying example: 

 

the C Code Entries and parameters could be quite easily matched and re-synchronized back to their original states by 
performing the following actions: 
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• Selecting the entry for C Code Entry PULSE_COUNT and clicking the Delete Sheet Entries button 

• Selecting the entries for C Code Entry GO and parameter GO_I and clicking the  button 

• Selecting the entries for C Code Entry GO_PULSE_O and parameter PULSE_OUT and clicking the  button. 

The approach to matching is not set in stone - the tools are provided to allow you to match as quickly and as efficiently as 
possible. 

Flipping C Code Symbols along the X-Axis 
This command allows you to flip C Code Symbols along the X-axis. 

The command can be accessed by right-clicking over the required C Code Symbol (or a symbol in a selected group of symbols) 
and choosing Code Symbol Actions » Flip Code Symbol Along X from the menu that appears. 

After launching the command the C Code Symbol(s) will be flipped. The C Code Entries associated with a symbol will 
essentially be swapped to the opposite side of the symbol (in the horizontal plane) - those on the left will be repositioned on the 
right and vice-versa. 

 

Note: When flipping multiple selected C Code Symbols, the symbols will be flipped about an imaginary vertical line which is 
located mid-way between the bounding extents of the symbols in the selection. 

Flipping C Code Symbols along the Y-Axis 
This command allows you to flip C Code Symbols along the Y-axis. 

The command can be accessed by right-clicking over the required C Code Symbol (or a symbol in a selected group of symbols) 
and choosing Code Symbol Actions » Flip Code Symbol Along Y from the menu that appears. 

After launching the command the C Code Symbol(s) will be flipped. The C Code Entries associated with a symbol will 
essentially be swapped to the opposite side of the symbol (in the vertical plane) - those at the top will be repositioned at the 
bottom and vice-versa. 

 

Note: When flipping multiple selected C Code Symbols, the symbols will be flipped about an imaginary horizontal line which is 
located mid-way between the bounding extents of the symbols in the selection. 

Toggling C Code Entry IO Type in a C Code Symbol 
This command allows you to toggle the I/O Type for C Code Entries in one or more C Code Symbols, simultaneously. 
Note: This command only applies to Parameter-type C Code Entries, corresponding to actual parameters in the exported C 
function. The I/O type of Control-type C Code Entries will remain unchanged. 

The command can be accessed by right-clicking over the required C Code Symbol (or a symbol in a selected group of symbols) 
and choosing Code Symbol Actions » Toggle All Parameters IO Type In Code Symbol from the menu that appears. 

After launching the command, the I/O Type defined for each C Code Entry will be toggled. 
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Notes 
The Filename property of the C Code Symbol, set on the Properties tab of the C Code Symbol dialog, must be set to the file 
name of the C source code file that the symbol represents. 

 

Each C Code Symbol is associated with one top-level exported function in a C source file. However, this exported function may 
call other functions, which themselves may be distributed among several source files. 

 

All required C source files and header files need to be added to the FPGA project. This allows Altium Designer's C-to-Hardware 
Compiler to find all source files needed to generate the FPGA logic. 

 

The C language allows parameters of a function to have the same name, if they differ in case. However, it is illegal for C Code 
Entries in the the same C Code Symbol to have the same name, even if those names differ in case. 

 

The exported C function can not be called main. 

 

The C Code Symbol must specify an exported function – using the Function Name field, on the Signature tab of the C Code 
Symbol dialog. This property cannot be left blank. The name entered must be identical (in case also) to the name of the function 
in the referenced C source file. If the specified function does not exist in the source file, a violation will occur. 

 

The C-to-Hardware Compiler can generate VHDL or Verilog from the C code. By default, VHDL will be generated. Change this 
as required using the corresponding options available in the Compiler Netlist region, on the FPGA – General page of the 
Preferences dialog (DXP » Preferences). 

 

Unlike code in an embedded software project, it is not possible to debug C code that is added to an FPGA or Core project 
through use of a C Code Symbol and C-to-Hardware Compilation technology. This is because the C code in the exported 
function is transformed into a hardware circuit, not a series of instructions to be carried out by a host processor. The only 
available avenue for test is use of a LAX configurable logic analyzer virtual instrument. 

 

If a group of C Code Entries is pasted into a selected C Code Symbol and those entries fall outside the current bounds of the 
symbol, it will automatically be resized to accommodate them. 

 

Changes made to object properties during placement will cause the default properties for the object to be updated, unless the 
Permanent option - on the Schematic – Default Primitives page of the Preferences dialog - is enabled. With this option 
enabled, changes will affect only the object being placed and subsequent objects placed during the same placement session. 

 

If you attempt to graphically modify a C Code Symbol object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit.  Additionally, if the Protect Locked Objects option is enabled on the Schematic - 
Graphical Editing page of the Preferences dialog, then the object cannot be selected or graphically edited in any way. In this 
case, either disable the object's Locked property, or disable the Protect Locked Objects option. 
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Comment 

 

Description 
The comment text field is a non-electrical child object of an electrical design primitive. It is used to provide a description of a 
placed part, such as the value (220nF) or device type (74HC32). 

Availability and Placement 
The comment is automatically placed when the parent part object is placed. As such, it is not a design object that can be 
accessed and placed by the user. 

Editing 
The properties of a comment object can be modified before and after placement of the parent part. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a comment object, independently of the parent part 
object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Parameter Properties dialog can be accessed prior to entering part placement mode, from the Schematic - Default 
Primitives page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties 
for the comment object, which will be applied when placing subsequent parts. 

After placement, the Parameter Properties dialog can be accessed in one of the following ways: 

• double-clicking on the comment field of the placed part object 
• selecting the comment field of the part object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the comment field of the placed part object. 
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Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a comment object directly in the workspace and change its location graphically. 
Comments can only be adjusted with respect to their size by changing the size of the font used (accessed through the 
Parameter Properties dialog). As such, editing handles are not available when the comment object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the comment object as required. The object can be rotated or 
flipped while dragging: 
• Press the Spacebar to rotate the comment. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the comment along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the value for the comment directly in the workspace. Select the comment and 
then click once to invoke the feature. Type the new value as required and then click away from the comment field or press Enter 
to effect the change. 

Notes 
Any changes made to the Comment field during part placement (either in the Place Part dialog or the Component Properties 
dialog) will cause the default properties for the comment object to be updated, unless the Permanent option - on the Schematic 
- Default Primitives page of the Preferences dialog - is enabled. When this option is enabled, changes made will affect only the 
comment of the part being placed and subsequent parts placed during the same placement session. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 44 

Compile Mask 

 

Description 
A compile mask is a design directive. It is used to effectively hide the area of the design it contains from the Compiler, allowing 
you to manually prevent error checking for circuitry that may not yet be complete and you know will generated compile errors. 
This can prove very useful if you need to compile the active document or project to check the integrity of the design in other 
specific areas, but do not want the clutter of compiler-generated messages associated with unfinished portions of the design. 

Availability 
Compile masks are available for placement in the Schematic Editor only, by choosing Place » Directives » Compile Mask [P, 
V, K] from the Schematic Editor main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter compile mask placement mode. 
Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the first corner of the mask 

• move the cursor to adjust the size of the mask, such that it completely encapsulates the area of the design that you want 
hidden from the Compiler, then click or press Enter to anchor the diagonally-opposite corner and thereby complete 
placement of the mask. Design objects falling completely within the bounds of the mask will become grayed-out, as 
illustrated in the image below: 

 

Continue placing further compile masks, or right-click or press Esc to exit placement mode. 

The compile mask object can be rotated or flipped while in placement mode and before the first corner of the mask is anchored: 
• Press the Spacebar to rotate the compile mask. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the compile mask along the X-axis or Y-axis respectively. 

Editing 
The properties of a compile mask object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a compile mask object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Compile Mask dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the compile 
mask object, which will be applied when placing subsequent compile masks. 
During placement, the Compile Mask dialog can be accessed by pressing the Tab key. 

After placement, the Compile Mask dialog can be accessed in one of the following ways: 

• double-clicking on the placed compile mask object 
• selecting the compile mask object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed compile mask object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed compile mask object directly in the workspace and change its size, shape 
or location, graphically. 

A compile mask can be displayed in either expanded (full frame) or collapsed (small triangle) modes. These modes correspond 
to the mask being enabled and disabled respectively. Toggle the display mode either by using the Collapsed and Disabled 
option in the Compile Mask dialog, or by clicking on the top left corner of a placed compile mask. 

 

When a fully expanded compile mask object is selected, the following editing handles are available: 
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Click and drag A to resize the compile mask in the vertical and horizontal directions simultaneously. 

Click and drag B to resize the compile mask in the vertical and horizontal directions separately. 

Click anywhere on the compile mask - away from editing handles - and drag to reposition it. The compile mask can be rotated or 
flipped while dragging. 

The size and shape of a compile mask cannot be changed graphically when the mask is in collapsed mode, only its 
location/orientation. As such, editing handles are not available when a collapsed compile mask object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the collapsed compile mask as required. The collapsed compile 
mask can be rotated or flipped while dragging. 
If you attempt to graphically modify a compiler mask object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
While compile masks can be rotated or flipped along the X or Y axis, this has no effect on the orientation of the design circuitry 
within. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Compiler Generated Junction 

 

Description 
A junction is an electrical design primitive. It is a small circular object used to logically join intersecting wires or buses on a 
schematic sheet. A Compiler generated junction is a junction that is automatically placed by the Auto-junctioning feature when 
two wires/buses are connected in a T-type fashion, or when a wire/bus connects orthogonally to a pin or power port/bus power 
port. This allows you to create electrical connections at junction points without the need to manually define the connections 
(through placement of manual junctions). 

Availability 
This type of junction is placed automatically by the Auto-junctioning feature. As such, it is not a design object that can be 
accessed and placed by the user. 

Placement 
Compiler generated junctions are placed automatically when: 

• placing a wire that starts or terminates anywhere along the length of another wire (T-junction), or when the wire connects 
orthogonally to a pin or power port. 

 

• placing a bus that starts or terminates anywhere along the length of another bus (T-junction), or when the bus connects 
orthogonally to a pin or bus power port. 

 

Wires or buses that cross away from their end points do not have a junction automatically inserted. 

Editing 
A Compiler generated junction object cannot be edited with respect to properties in the usual manner - it cannot be selected in 
the workspace, has no corresponding properties dialog and cannot be edited graphically. 
Display of auto-junctions on the schematic sheet, with respect to wires and buses can be controlled from the Schematic - 
Compiler page of the Preferences dialog (Tools » Schematic Preferences). Additional options provide control over junction 
size and color. 

 

Notes 
When a wire crosses other wires (or a bus crosses other buses), no junction is inserted. If you want to create a connection 
between crossed wires or buses, place a manual junction at the crossing point. 
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Designator 

 

Description 
The designator text field is a non-electrical child object of an electrical design primitive. It is used to uniquely identify a placed 
part, thereby distinguishing it from other parts placed not only on the same schematic sheet, but placed across all source 
schematic sheets in the active project. 

Availability and Placement 
The designator is automatically placed when the parent part object is placed. As such, it is not a design object that can be 
accessed and placed by the user. 

Editing 
The properties of a designator object can be modified before and after placement of the parent part. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a designator object, independently of the parent part 
object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Parameter Properties dialog can be accessed prior to entering part placement mode, from the Schematic - Default 
Primitives page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties 
for the designator object, which will be applied when placing subsequent parts. 

After placement, the Parameter Properties dialog can be accessed in one of the following ways: 

• double-clicking on the designator field of the placed part object 
• selecting the designator field of the part object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the designator field of the placed part 
object. 
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Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a designator object directly in the workspace and change its location graphically. 
Designators can only be adjusted with respect to their size by changing the size of the font used (accessed through the 
Parameter Properties dialog). As such, editing handles are not available when the designator object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the designator object as required. The object can be rotated or 
flipped while dragging: 
• Press the Spacebar to rotate the designator. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the designator along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the value for the designator directly in the workspace. Select the designator 
and then click once to invoke the feature. Type the new value as required and then click away from the designator field or press 
Enter to effect the change. 

Notes 
When placing multiple instances of the same part, it is advisable to set the designator of the first part before placing it (press the 
Tab key during placement to edit the part's properties). By doing this, the designator will automatically increment as each 
subsequent part is placed. If you do not enter a designator before you place a part its designator will be the pre-assigned 
default, such as R?, C? or U?. 

 

When placing multi-part components, a part suffix will automatically be assigned, for example U3A, U3B, and so on. The suffix 
will automatically increment if the designator is assigned before the first part is placed. 

 

Any changes made to the Designator field during part placement (either in the Place Part dialog or the Component Properties 
dialog) will cause the default properties for the designator object to be updated, unless the Permanent option - on the 
Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is enabled, changes made will 
affect only the designator of the part being placed and subsequent parts placed during the same placement session. 
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Device Sheet Symbol 

 

Description 
A Device Sheet Symbol is an electrical design primitive. It is used to represent a Device Sheet and usually contain predefined 
circuits. A Device Sheet Symbol references a Device Sheet and can be re-used within and across design projects. Device Sheet 
Symbols include Sheet Entry Symbols, which provide a connection point for signals between the parent and child sheets, 
similarly to sheet symbols. 

Availability 
Device Sheet symbols are available for placement in the Schematic Editor only. Use one of the following methods to access the 
placement command: 
• choose Place » Device Sheet Symbol [P, I] from the main menus 

• right click on your Schematic Document and choose Place » Device Sheet Symbol from the pop-up menu that appears 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the Select Device Sheet dialog appears with all of your declared Device Sheet Folders. Choose a 
Device Sheet to place and then click OK. The cursor will change to a cross-hair and you will enter Device Sheet Symbol 
placement mode. Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the top-left corner of the Device Sheet Symbol 

• move the cursor to adjust the size of the Device Sheet Symbol, then click or press Enter to anchor the diagonally-opposite 
corner and thereby complete placement of the Device Sheet Symbol. 

Editing 
The properties of a Device Sheet Symbol object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a Device Sheet Symbol object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option.  
During placement, the Device Sheet Symbol dialog can be accessed by pressing the Tab key. 

After placement, the Device Sheet Symbol dialog can be accessed in one of the following ways: 

• double-clicking on the placed Device Sheet Symbol object 

• selecting the Device Sheet Symbol object and 
choosing Properties from the right-click pop-up 
menu 

• choosing the Change command from the Edit menu 
and then clicking once over the placed Device Sheet 
Symbol object. 

The Device Sheet Symbol Designator and Filename 
text fields can be formatted independently of the Device 
Sheet Symbol itself. The corresponding properties 
dialogs for each - the Sheet Symbol Designator and 
Sheet Symbol File Name dialogs respectively - can be 
accessed using the three methods described above 
(replacing Device Sheet Symbol with the relevant object 
whose properties you wish to view/modify). 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a placed Device Sheet Symbol object directly in the workspace and change its size, 
shape or location, graphically. 

When a Device Sheet Symbol object is selected, the following editing handles are available: 

 

Click and drag A to resize the Device Sheet Symbol in vertical and horizontal directions separately. 

Click and drag B to resize the Device Sheet Symbol in vertical and horizontal directions simultaneously. 

Resizing the Device Sheet Symbol will not affect the absolute positions of any Sheet Entries within it. 

Click anywhere on the Device Sheet Symbol - away from editing handles - and drag to reposition it. 

The Device Sheet Symbol's Designator and Filename text fields can only be adjusted with respect to their size by changing the 
size of the font used (accessed through the Sheet Symbol Designator and Sheet Symbol File Name dialogs, respectively. 
Editing handles are not available when either of these objects are selected: 

 

Click anywhere inside the dashed box and drag to reposition the text object as required. The object can be rotated or flipped 
while dragging: 
• Press the Spacebar to rotate the text. Rotation is anti-clockwise and in steps of 90° 

• Press the X or Y keys to flip the text along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the Designator or File Name directly in the workspace. Select the 
text object and then click once to invoke the feature. Type the new name as required and then click away from the text object or 
press Enter to effect the change. 

For more detailed information on using the Device Sheets, refer to the Using Device Sheets document.  

Notes 
The Filename property of the Device Sheet Symbol, set on the Properties tab of the Sheet Symbol dialog, must be set to the 
file name of the Schematic Sheet that the symbol represents. The *.SchDoc extension is not used in the Filename for Device 
Sheets. 

 

If you attempt to graphically modify a Device Sheet Symbol object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Ellipse 

 

Description 
An ellipse is a non-electrical drawing primitive that can be placed on a schematic sheet. It can be filled or unfilled. 

Availability 
Ellipses are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Ellipse [P, D, E] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Ellipse [P, E] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter ellipse placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the center of the ellipse 

• move the cursor to adjust the horizontal radius of the ellipse, then click or press Enter to set it 

• move the cursor to adjust the vertical radius of the ellipse, then click or press Enter to set it and complete placement. 

Continue placing further ellipses or right-click or press Esc to exit placement mode. 

The ellipse object can be rotated or flipped while in placement mode and before the center of the ellipse is anchored: 
• Press the Spacebar to rotate the ellipse. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the ellipse along the X-axis or Y-axis respectively. 

Editing 
The properties of an ellipse object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an ellipse object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Ellipse dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the ellipse object, 
which will be applied when placing subsequent ellipses. 
During placement, the Ellipse dialog can be accessed by pressing the Tab key. 

After placement, the Ellipse dialog can be accessed in one of the following ways: 

• double-clicking on the placed ellipse object 
• selecting the ellipse object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed ellipse object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed ellipse object directly in the workspace and change its size, shape or 
location, graphically. 

When an ellipse object is selected, the following editing handles are available: 

 

Click and drag A to change the horizontal radius. 

Click and drag B to change the vertical radius. 

Click anywhere on the ellipse - away from editing handles - and drag to reposition it. The ellipse can be rotated or flipped while 
dragging. 
If you attempt to graphically modify an ellipse object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Elliptical Arc 

 

Description 
An elliptical arc is a non-electrical drawing primitive. It is essentially an open circular or elliptical curve that can be placed on a 
schematic sheet. 

Availability 
Elliptical arcs are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Elliptical Arc [P, D, I] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Elliptical Arc [P, I] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter elliptical arc placement mode. Placement 
is made by performing the following sequence of actions: 
• click or press Enter to anchor the center point of the arc 

• move the cursor to adjust the X radius of the arc, then click or press Enter to set it 

• move the cursor to adjust the Y radius of the arc, then click or press Enter to set it 

• move the cursor to adjust the first end point of the arc, then click or press Enter to anchor it. 

• move the cursor to change the position of the arc's other end point, then click or press Enter to anchor it and complete 
placement of the arc. 

Continue placing further elliptical arcs, or right-click or press Esc to exit placement mode. 

The elliptical arc object can be rotated or flipped while in placement mode and before the center point of the arc is anchored: 
• Press the Spacebar to rotate the elliptical arc. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the elliptical along the X-axis or Y-axis respectively. 

Editing 
The properties of an elliptical arc object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an elliptical arc object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Elliptical Arc dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the elliptical arc 
object, which will be applied when placing subsequent elliptical arcs. 
During placement, the Elliptical Arc dialog can be accessed by pressing the Tab key. 

After placement, the Elliptical Arc dialog can be accessed in one of the following ways: 

• double-clicking on the placed elliptical arc object 
• selecting the elliptical arc object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed elliptical arc object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed elliptical arc object directly in the workspace and change its size, shape or 
location, graphically. 

When an elliptical arc object is selected, the following editing handles are available: 

 

Click and drag A to change the vertical radius. 

Click and drag B to change the horizontal radius. 

Click and drag C to adjust the end points. 
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Click anywhere on the elliptical arc - away from editing handles - and drag to reposition it. The elliptical arc can be rotated or 
flipped while dragging. 
If you attempt to graphically modify an elliptical arc object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Graphic 

 

Description 
A graphic object is a non-electrical drawing primitive. It is essentially a container for an image file that can be imported and 
placed onto a schematic sheet. The image associated with a graphic object can either be linked or embedded. 

Availability 
Graphic objects are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Graphic [P, D, G] from the Schematic Editor main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Graphic [P, G] from the Schematic Library Editor main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter graphic placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press Enter to anchor the first corner of the graphic frame, in which the image itself will 

reside 
• move the cursor to adjust the size of the frame and click or press Enter to complete frame placement 

• the Open dialog will appear, from where you can browse to and select the required image. Select the file you wish to insert 
and press the Open button to complete graphic placement. 

Continue placing further graphic objects, or right-click or press Esc to exit placement mode. 

The graphic object can be rotated or flipped while in placement mode and before the first corner of the graphic frame is 
anchored: 
• Press the Spacebar to rotate the graphic. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the graphic along the X-axis or Y-axis respectively. 

Editing 
The properties of a graphic object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a graphic object. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 59 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Graphic dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the graphic object, 
which will be applied when placing subsequent graphic objects. 
During placement, the Graphic dialog can be accessed by pressing the Tab key. 

After placement, the Graphic dialog can be accessed in one of the following ways: 

• double-clicking on the placed graphic object 
• selecting the graphic object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed graphic object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed graphic object directly in the workspace and change its size, shape or 
location, graphically. 

When a graphic object is selected, the following editing handles are available: 
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Click and drag A to resize the graphic frame in the vertical and horizontal directions simultaneously. 

Click and drag B to resize the graphic frame in the vertical and horizontal directions separately (provided the X:Y Ratio 1:1 
option in the Graphic dialog is disabled). 

Click anywhere on the graphic - away from editing handles - and drag to reposition it. The graphic can be rotated or flipped 
while dragging. 
If you attempt to graphically modify an image object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
The following image formats are supported: .bmp, .dcx, .dib, .jpg, .pcx, .rle, .tif, .tga, .wmf. 

 

To retain the graphic image's original aspect ratio, ensure that the X:Y Ratio 1:1 option is enabled in the Graphic dialog. When 
this option is enabled, the graphic will be scaled to fit optimally into the frame size specified while maintaining the original aspect 
ratio of the image. If the option is disabled, the image is stretched to fit exactly into the drawn frame size. 

 

A copy of a placed image will only be stored inside the schematic sheet if the corresponding Embedded option is enabled in the 
Graphic dialog. If this option is disabled, only a link to the image file will be stored. Care should be taken when using linked 
images - if the location of the image changes, you will need to update the link accordingly, using the FileName field in the 
Graphic dialog. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Harness Connector 

 

Description 
A Harness Connector object is an electrical drawing primitive. It is essentially a container to group various signals together to 
form a Signal Harness including buses and wires. A Harness Connector is defined by the Harness Type. 

Availability 
Harness Connector objects are available for placement in the Schematic editor only: 

Schematic Editor 
• Choose Place » Harness » Harness Connector [P, H, C] from the Schematic Editor main menus 

• Click the  button on the Wiring toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter Harness Connector placement mode. 
Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the tip of the Harness Connector 

• move the cursor to adjust the size of the Harness Connector, then click or press Enter to anchor the corner and thereby 
complete placement of the Harness Connector 

Continue to place other Harness Connectors or right-click or press Esc to exit placement mode. 

• Press the Spacebar to rotate the Harness Connector. Rotation is anti-clockwise and in steps of 90° 

• Press the X or Y keys to flip the Harness Connector along the X-axis or Y-axis respectively. 

Editing 
The properties of a Harness Connector object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a Harness Connector object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Harness Connector dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives 
page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the 
Harness Connector object, which will be applied when placing subsequent Harness Connector objects. 
During placement, the Harness Connector dialog can be accessed by pressing the Tab key. 

After placement, the Harness Connector dialog can be accessed in one of the following ways: 

• double-clicking on the placed Harness Connector object 
• selecting the graphic object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed harness connector object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed Harness Connector object directly in the workspace and change its size, 
shape or location, graphically. 

When a Harness Connector object is selected, the following editing handles are available: 

 

Click and drag A to resize the Harness Connector in the vertical and horizontal directions simultaneously. 

Click and drag B to resize the Harness Connector in the vertical and horizontal directions separately  

Click anywhere on the Harness Connector - away from editing handles - and drag to reposition it. The Harness Connector can 
be rotated or flipped while dragging. 
If you attempt to graphically modify a Harness Connector object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

For more detailed information on using the Harness objects, refer to the Using Signal Harnesses document.  
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Notes 
The Harness Type option in the Harness Connector dialog defines the type of the Harness Connector. When a Harness Type is 
used within your project, the corresponding Harness Definition for this Harness Type is referenced. When you place a Harness 
Connector, you can specify the Harness Type by double clicking on the Harness Connector object and populating the Harness 
Type field in the dialog or clicking directly on the Harness Connector Type field. By default, newly placed Harness Connectors 
are given the Harness Type Harness. 

The Harness Type can be hidden from view or moved to save space in your design. Enable the Hide Harness Type option in 
the Harness Connector dialog or select the Harness Connector, open the SCH List and enable the Hide Harness Type option 
or double click on the Harness Type object and enable the Hide option. 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Harness Entry 

 

Description 
A Harness Entry is an electrical design primitive that is placed within a Harness Connector. A Harness Entry is the connection 
point through which actual nets, buses and Signal Harnesses are combined to form a higher level Signal Harness. 

Availability 
Harness Entries are available for placement in the Schematic Editor only. Use one of the following methods to access the 
placement command: 
• choose Place » Harness » Harness Entry [P, H, E] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter Harness Entry placement mode. 
Placement is made by performing the following sequence of actions: 

• the Harness Connector is implicitly chosen by the position for the new Harness Entry by the mouse on the schematic sheet 
(this sheet needs to have at least one Harness Connector). 

• move the cursor to adjust the position of the Harness Entry in relation to any edge of the Harness Connector, then click or 
press Enter to anchor the Harness Entry and complete placement. 

Continue placing further Harness Entries, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a Harness Entry object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a Harness Entry object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Harness Entry dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the Harness 
Entry object, which will be applied when placing subsequent Harness Entries. 
During placement, the Harness Entry dialog can be accessed by pressing the Tab key. 

After placement, the Harness Entry dialog can be accessed in one of the following ways: 

• double-clicking on the placed Harness Entry object 
• selecting the Harness Entry object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed Harness Entry object.  

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed Harness Entry object directly in the workspace and change its location 
graphically. The Harness Connector itself gets resized automatically when you attempt to move the existing Harness Entry 
beyond the current extends of the Harness Connector.  

 

Click anywhere inside the dashed box and drag to reposition the Harness Entry within the Harness Connector as required. You 
can move a Harness Entry object outside of the Harness Connector and into another Harness Connector by holding down the 
Ctrl key while dragging the object. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the Harness Entry directly in the workspace. Select the Harness 
Entry object and then click once to invoke the feature. Type the new name as required and then click away from the Harness 
Entry object or press Enter to effect the change. 

For more detailed information on using the Harness objects, refer to the Using Signal Harnesses document.  

Notes 
A Harness Entry can be connected directly to a wire, a bus or a Signal Harness. The Harness Type field in the Harness Entry 
dialog is used in special cases. 

 

Should you need to negate (include a bar over the top of) a Harness Entry name, this can be done in one of two ways: 
• Include a backslash character after each character in the name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the name (e.g. \ENABLE). 
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Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 

 

If you attempt to graphically modify a Harness Entry object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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IEEE Symbols 

 

Description 
IEEE symbols are non-electrical drawing primitives. They are used for representing logic functions or devices. These symbols 
enable users to understand the logic characteristics of these functions or devices without requiring specific knowledge of their 
internal characteristics. 

Availability 
IEEE Symbol objects are available for placement in the Schematic Library Editor only. A total of 33 symbols are available, the 
associated placement commands for which are located: 
• on the Place » IEEE Symbols [P, S] sub-menu (accessed from the Schematic Library Editor main menus) 

• on the IEEE Symbols drop-down of the Utilities toolbar. 

IEEE Symbol listing 
The following table lists each of the 33 IEEE symbol objects available for placement within a Schematic Library document. 

Symbol Description  Symbol Description 

 
Active Low Input  

 
Group Line 

 
Active Low Output  

 
High Current 

 Analog Signal In  
 

HiZ 

 
AND Gate  

 
Invertor 

 Bidirectional Signal Flow  
 

Left To Right Signal Flow 

 
Clock  

 
Less Than Or Equal To 

 Delay  
 

Not Logic Connection 

 Digital Signal In  
 

Open Collector 

 Dot  
 

Greater Than Or Equal To 

 
Group Binary  

 
Postponed Output 

 
Open Collector Pull-up   Pulse 

 
Open Emitter  

 
Right To Left Signal Flow 

 
Open Emitter Pull-up  

 
Schmitt 

 
Open Output   Shift Left 

 

OR Gate   Shift Right 
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 Pi Symbol  
 

Sigma 

 

XOR Gate    

Placement 
After launching a command, the cursor will change to a cross-hair and you will enter IEEE symbol placement mode. The chosen 
IEEE symbol will appear floating on the cursor. Position the cursor as required and click or press Enter to place the symbol. 

Continue placing further symbols or right-click or press Esc to exit placement 
mode. 
Press the Spacebar while in placement mode to rotate the symbol. Rotation is 
anti-clockwise and in steps of 90°. 
Press the X or Y keys while in placement mode to flip the symbol along the X-axis 
or Y-axis respectively. 
Press the + and - keys (on the numeric keypad) to enlarge or shrink the symbol as 
you place it. 

Editing 
The properties of an IEEE symbol object can be modified before, during and after 
placement. Editing itself falls into two categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an 
IEEE symbol object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right of the dialog and then click over a field or option 
to pop-up information specific to that field or option. 
The IEEE Symbol dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the IEEE symbol 
object, which will be applied when placing subsequent IEEE symbols. 
During placement, the IEEE Symbol dialog can be accessed by pressing the Tab key. 

After placement, the IEEE Symbol dialog can be accessed in one of the following ways: 

• double-clicking on the placed IEEE symbol object 
• choosing the Change command from the Edit menu and then clicking once over the placed IEEE symbol object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed IEEE symbol object directly in the workspace and change its location or 
orientation, graphically. IEEE symbols are fixed with respect to their shape and can be resized only through use of the relevant 
keyboard shortcuts. As such, editing handles are not available when the IEEE symbol object is selected: 
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Click anywhere inside the dashed box and drag to reposition the IEEE symbol as required. The IEEE symbol can be rotated, 
flipped or resized while dragging. 
If you attempt to graphically modify an IEEE symbol object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Instrument Probe 

 

Description 
An instrument probe is a design directive. It instructs the system to connect the net to which it is attached directly to the 
monitoring instrument (e.g. a logic analyzer) without having to explicitly wire that net up through the design hierarchy to the 
sheet with the instrument on it. 

Availability 
Probes are available for placement in the Schematic Editor only, by choosing Place » Directives » Instrument Probe [P, V, I] 
from the main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter instrument probe placement mode. 
Position the cursor over a wire or other net object and click or press Enter to effect placement. 

Continue placing further instrument probe directives or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the instrument probe directive. Rotation is anti-clockwise and in steps of 
90°. 
Press the X or Y keys while in placement mode to flip the instrument probe directive along the X-axis or Y-axis respectively. 

Connecting to the Instrument 
After placing an instrument probe directive at the 
point of interest, you need to define a value for its 
InstrumentProbe parameter. Enter a 
meaningful name for the probe point, for example 
the name of the associated net or the particular 
signal being monitored. Then, connect a wire to 
the required input of the monitoring instrument 
and attach a net label to the wire, the name of 
which is the same name you have defined for the 
InstrumentProbe parameter. 

Editing 
The properties of an instrument probe directive 
can be modified before, during and after 
placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an instrument probe directive. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Probe dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the instrument 
probe directive, which will be applied when placing subsequent instrument probe directives. 
During placement, the Probe dialog can be accessed by pressing the Tab key. 

After placement, the Probe dialog can be accessed in one of the following ways: 

• double-clicking on the placed instrument probe directive 
• selecting the instrument probe directive and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed instrument probe directive. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed instrument probe directive directly in the workspace and change its location 
graphically. Instrument probe directives are fixed with respect to their size and shape. As such, editing handles are not available 
when the instrument probe directive is selected: 
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Click anywhere inside the dashed box and drag to reposition the instrument probe directive as required. The instrument probe 
directive can be rotated or flipped while dragging. 
If you attempt to graphically modify an instrument object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
The instrument probe directive is essentially the same as the probe directive, but with the additional InstrumentProbe 
parameter. It is this parameter that turns it from being a simple probe into a means of monitoring any point in a design – 
connecting that point directly to the input line of a monitoring instrument. 

 

If the instrument probe directive is placed on a net that connects to an FPGA pin, it can be used to monitor the status of that pin 
directly on the schematic sheet, as well as being used as an input source to a 
monitoring instrument. The former is achieved using the directive’s 
ProbeValueDisplay parameter. 

Note: For this feature to function, the source FPGA design must be downloaded to 
the physical FPGA device and the associated JTAG Viewer panel for that device 
must be open and remain open. 
The JTAG Viewer panel for a physical device is accessed by clicking the JTAG 
Viewer Panel button on the associated instrument panel for that device. The latter 
is loaded into the Instrument Rack – Hard Devices panel upon double-clicking the 
entry for the device, in the Hard Devices chain of the Devices view. 

 

When an instrument probe is attached to a bus, the entire bus is taken up to the top-level sheet, irrespective of the name you 
assign to the InstrumentProbe parameter. When you add a net label to the input for the monitoring instrument, you must 
define the bus width required. For example, you may have attached an instrument probe to a bus with identifier 
Port1_Out[7..0] on a lower level sheet. The value for the InstrumentProbe parameter could be set to Port1_Out. The 
entire bus will be connected up to the sheet with the monitoring device (e.g. a LAX). Should you wish to wire up the entire bus 
as an input signal to the device, you would place a bus to the required input and add a net label of Port1_Out[7..0]. If you 
only wanted a particular signal or range of signals from the bus, you can define the width required in the attached net label. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Line 

 

Description 
A line is a non-electrical drawing primitive. Lines are used for adding reference information to a document, such as building 
graphical symbols, custom sheet borders and title blocks. 

Availability 
Line objects are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Line [P, D, L] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Line [P, L] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter line placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the line 

• position the cursor and click or press Enter to anchor a series of vertex points that define the shape of the line 

• after placing the final vertex point, right-click or press Esc to complete placement of the line. 

Continue placing further line objects, or right-click or press Esc to exit placement mode. 

Use the Backspace or Delete keys to remove the last line segment placed. If you do remove segments in this way, you must 
click to place a final segment, otherwise right-clicking will place the line as it was, with all deleted segments reinstated. 

Editing 
The properties of a line object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a line object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 

Adding a Touch of Style 
The Polyline dialog provides several options with which to change the style of a 
line. For example use the Line Style option to change between a solid, dotted or 
dashed line. By using the Start Line Shape and Stop Line Shape options, you 
can further style the line by adding various arrow head and tail shapes. 

Editing Vertices 
The PolyLine dialog provides a Vertices tab, from where you can edit the 
individual vertices of the currently selected line object as required. 

 

The main region of the tab lists all of the vertex points currently defined for the line. You can add new vertices to the line, edit 
the coordinates of existing vertices, or remove selected vertices altogether. 
Click the Menu button or right-click within the main list region to access a pop-up menu containing the following commands: 

• Edit - right click on a coordinate cell (X or Y) for a vertex and use this command to edit the value in that cell. Alternatively, 
click directly on the cell 

• Add - use this command to add a new vertex point. The new vertex will be added below the currently focused vertex entry 
(as distinguished by a dotted outline around a cell in its row) and will initially have the same coordinates as the focused entry 

• Remove - use this command to remove the currently selected vertex entries in the list. This command will be unavailable if 
there are only two vertices present for the line 

• Copy - use this command to copy the content of the selected cells in the list to the clipboard (alternatively use Ctrl+C) 

• Paste - use this command to paste the content of the clipboard into the list, starting at the selected cell (alternatively use 
Ctrl+V) 

• Select All - use this command to quickly select the entire grid contents of the list 

• Select Column - use this command to quickly select the entire column in which the currently focused cell resides 
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• Move Up - use this command to move the selected vertex upward in the list 

• Move Down - use this command to move the selected vertex downward in the list 

• Move Line By XY - use this command to move the entire line object. The Move Line By dialog will appear, from where you 
can enter the increment value to be applied to each vertex point's X and Y coordinates. 

Dialog access 
The PolyLine dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the line object, 
which will be applied when placing subsequent lines. 
During placement, the PolyLine dialog can be accessed by pressing the Tab key. 

After placement, the PolyLine dialog can be accessed in one of the following ways: 

• double-clicking on the placed line object 
• selecting the line object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed line object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed line object directly in the workspace and change its size and/or shape, 
graphically. 

When a line object is selected, the following editing handles are available: 

 

Click and drag A to adjust the end points. 

Click and drag B to move the vertex point of a line. 

Click and drag near the center of a line segment to "grab" that segment and reposition it. The end points and other vertices will 
remain anchored. 
Right-click on a vertex point and choose the Edit Line Vertex n command to access the Vertices tab of the PolyLine dialog, 
with the entry for the nth vertex selected ready for editing. 

With the line selected, click on a vertex or segment to individually select that vertex or segment. This line 'sub-selection' is 
distinguished by the associated editing handles becoming red in color. 
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 Individual vertex sub-selection. 

 Individual segment sub-selection. 

The associated vertex (or vertices for a segment) can then be edited directly using the SCH Inspector or SCH List panels, with 
any changes appearing immediately on the schematic. 
If you attempt to graphically modify a line object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
A line is purely a drawing object. To make an electrical connection between points in your schematic, use the wire object. 

 

When placing a line, various line placement modes are available: Any Angle, 90 Degree Start, 90 Degree End, 45 Degree Start 
and 45 Degree End. The mode specifies how corners are created when placing lines and the angles at which lines can be 
placed. 

 

When placing a line, press the Spacebar to cycle through the various placement modes. You can change modes at any time 
during line placement. 

 

In all modes other than Any Angle, the line segment attached to the cursor is a "look ahead" segment. The segment you are 
actually placing precedes this look ahead segment. 

 

When launching the command to place a line, the initial placement mode is dependant on the placement mode last used when 
previously placing lines or wires. Therefore, if the last wire you placed used 90 Degree Start, then the next wire or line you place 
will have 90 Degree Start as the initial placement mode. If you last placed a wire using Auto Wire mode, placement of a 
subsequent line will be confined to Any Angle mode only. You will need to place a wire in any mode other than Auto Wire in 
order for line placement to have all placement modes fully restored and functional. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Manual Junction 

 

Description 
A junction is an electrical design primitive. It is a small circular object used to logically join intersecting wires or buses on a 
schematic sheet. A manual junction allows you to create a connection between crossed wires or buses, by placing the junction 
at the crossing point. This is different from a Compiler generated junction, which is automatically inserted when two wires/buses 
are connected in a T-type fashion, or when a wire/bus connects orthogonally to a pin or power port/bus power port. 

Availability 
Manual junctions are available for placement in the Schematic Editor only, by choosing Place » Manual Junction [P, J] from 
the Schematic Editor main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter junction placement mode. Click or press 
Enter to place a junction at the cursor position. 

Continue placing junctions or right-click or press Esc to exit placement mode. 

Editing 
The properties of a manual junction object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a manual junction object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Junction dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the manual junction 
object, which will be applied when placing subsequent manual junctions. 
During placement, the Junction dialog can be accessed by pressing the Tab key. 

After placement, the Junction dialog can be accessed in one of the following ways: 

• double-clicking on the placed manual junction object 
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• selecting the manual junction object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed manual junction object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed manual junction object directly in the workspace and change its location 
graphically. Manual junctions can only be adjusted with respect to their size through the Junction dialog. As such, editing 
handles are not available when the manual junction object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the manual junction as required. 
If you attempt to graphically modify a junction object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Display of manual junctions on the schematic sheet can be controlled from the Schematic - Compiler page of the Preferences 
dialog (Tools » Schematic Preferences). Additional options provide control over junction size and color: 

 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Net Label 

 

Description 
A wire is an electrical design primitive. Wires that join electrical objects (such as component pins and ports) create what is called 
a Net. These nets will be assigned system-allocated name unless there is a net label placed on the wire, overriding the system-
allocated name with the user-specified Net name. As well as being used to name a net, Net labels allow you to connect points 
on a schematic without actually physically wiring them together. 

Availability 
Net labels are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Net Label [P, N] from the Schematic Editor main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter net label placement mode. The label will 
appear floating on the cursor. Position the label so that its bottom-left corner touches the object to which you want to assign it 
and click or press Enter to place the label. 

Continue placing further net labels, or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the net label. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the net label along the X-axis or Y-axis respectively. 

Editing 
The properties of a net label object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a net label object. 

 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Net Label dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the net label object, 
which will be applied when placing subsequent net labels. 
During placement, the Net Label dialog can be accessed by pressing the Tab key. 

After placement, the Net Label dialog can be accessed in one of the following ways: 

• double-clicking on the placed net label object 
• selecting the net label object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed net label object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed net label object directly in the workspace and change its location 
graphically. Net labels can only be adjusted with respect to their size by changing the size of the font used (accessed through 
the Annotation dialog). As such, editing handles are not available when the net label object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the net label as required. The net label can be rotated or flipped 
while dragging. 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the net label directly in the workspace. Select the net label and 
then click once to invoke the feature. Type the new name as required and then click away from the net label or press Enter to 
effect the change. 
If you attempt to graphically modify a netlabel object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be moved. This 
locked object is not part of the selected group of objects (only those objects that are unlocked can be selected and moved as a 
group). You will have to click on this locked object directly and accept the confirmation before moving this object. 

Notes 
A newly placed net label will initially have a default name of the form NetLabeln. Edit the properties of the net label to change 
the name to that required. 

 

Should you need to negate (include a bar over the top of) a net label, this can be done in one of two ways: 
• Include a backslash character after each character in the net name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the net name (e.g. \ENABLE). 
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If you are creating a design using multiple schematic sheets, the type of hierarchy model you choose to employ will affect the 
way net names on different sheets are interpreted. If you set the Net Identifier Scope on the Options tab of the Options for 
Project dialog (Project » Project Options) to Global, any net labels you have assigned will be interpreted globally and all net 
labels with the same name will be treated as if they are connected, regardless of which sheets they are on. With other types of 
hierarchy, net labels are local to the current sheet and do not connect to nets of the same name on other sheets. 

 

Assign a bus to multiple nets using a Net Label of the form D[0..7] or D[7..0], indicating that the individual (and distinct) nets D0 
to D7 are carried by the bus. Whichever form you use, the ordering must be consistent between connected bus objects. 
Assigning a net label with this syntax (bus syntax) to a bus changes the bus object from being purely graphical to logical. 

Remember that net identifiers of different types do not automatically connect to one another, even if they share the same name. 
This holds true for net identifiers with bus syntax; a net label D[0..7] will not automatically connect to a port with the same name. 
The bus is required to connect them together. 

 

It is recommended that you define the net label in bus syntax to contain alpha characters only. For example, if you named the 
bus D2[0..7], it would be expanded to D20, D21..D27 which can cause net name conflicts. 

 

In FPGA designs, define a constant value for a bus by specifying the 
required value in the net label for the bus. The constant can be 
declared in either decimal, binary or hexadecimal format. For 
example, consider an FPGA_STARTUP16 device, with a required 
DELAY input of 342 (decimal). The following entries for the bus net 
label could be used to define the constant: 
• Decimal: DELAY[15..0] <= 342 

• Binary: DELAY[15..0] <= b101010110 

• Hexadecimal: DELAY[15..0] <= $156 

In a binary definition, the leading zeroes need not be declared. You can of course declare all bits and, for added readability, 
separate nibbles by a space or a hyphen. Therefore the decimal value 342 could be defined in binary as: 
0000 0001 0101 0110 or 

0000-0001-0101-0110 

Leading zeroes need not be declared for a hexadecimal value either. Also, you can use $ or 0x prefixes to denote the value as 
being hexadecimal. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 82 

No ERC 

 

Description 
The No ERC object is a design directive. Placing this directive on a node in the circuit suppresses any report warnings and 
errors that may be generated when compiling the schematic. 

Use this directive to deliberately prevent error checking of certain parts of a circuit that you know will generate a warning (such 
as unfinished connections) while checking the rest of the circuit. 

Availability 
No ERC design directives are available for placement in the Schematic Editor only. Use one of the following methods to access 
the placement command: 
• choose Place » Directives » No ERC [P, V, N] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter No ERC placement mode. Position the 
cursor over a wire or other net object and click or press Enter to place the directive. 

Continue placing further No ERC directives or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the No ERC directive. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the No ERC directive along the X-axis or Y-axis respectively. 

Editing 
The properties of a No ERC directive can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the 
properties of a No ERC directive. 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over 
a field or option to pop-up information specific to that field or option. 

The No ERC dialog can be accessed prior to entering placement 
mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows 
you to change the default properties for the No ERC directive, which will be applied when placing subsequent No ERC 
directives. 
During placement, the No ERC dialog can be accessed by pressing the Tab key. 

After placement, the No ERC dialog can be accessed in one of the following ways: 

• double-clicking on the placed No ERC directive 
• selecting the No ERC directive and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed No ERC directive. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 
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For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed No ERC directive directly in the workspace and change its location 
graphically. No ERC directives are fixed with respect to their size and shape. As such, editing handles are not available when 
the No ERC directive is selected: 

 

Click anywhere inside the dashed box and drag to reposition the No ERC directive as required. The No ERC directive can be 
rotated or flipped while dragging. 
If you attempt to graphically modify a NoERC object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Note 

 

Description 
A note is a non-electrical drawing primitive. It is used to add informational or instructional text to a specific area within a 
schematic, in a similar vain to that of commenting a program's source code. The note is a resizable rectangular area that can 
contain multiple lines of text and can automatically wrap and clip text to keep it within the bounds of the note. 

Availability 
Notes are available for placement in the Schematic Editor only, by choosing Place » Notes » Note [P, E, O] from the Schematic 
Editor main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter note placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the first corner of the note 

• move the cursor to adjust the size of the note, then click or press Enter to anchor the diagonally-opposite corner and thereby 
complete placement of the note. 

Continue placing further notes, or right-click or press Esc to exit placement mode. 

The note object can be rotated or flipped while in placement mode and before the first corner of the note is anchored: 
• Press the Spacebar to rotate the note. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the note along the X-axis or Y-axis respectively. 

Editing 
The properties of a note object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a note object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Note dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the note object, 
which will be applied when placing subsequent notes. 
During placement, the Note dialog can be accessed by pressing the Tab key. 

After placement, the Note dialog can be accessed in one of the following ways: 

• double-clicking on the placed note object 
• selecting the note object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed note object. 

The actual text of the note can be entered/edited via the Note dialog. Press the Change button associated with the note's Text 
property to access the Note Text dialog. 

 
In addition to providing a Word Wrap option, the main Note dialog provides a Clip to Area option. With this option enabled, text 
will be kept within the bounds of the note's frame. When disabled, text will spill out of the frame onto the schematic sheet. 
For example, consider the note in the previous image. Both Word Wrap and Clip to Area options were enabled. If word 
wrapping is disabled, leaving only the clipping option enabled, only text that fits within the frame of the note will remain 
displayed: 
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However, if the option to clip the text is disabled, the text is free to be displayed beyond the constraints of the frame's boundary: 

 

In-Place Editing 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the textual content of the note directly in the workspace. Select the note (in its 
expanded state) and then click once to invoke the feature. 

 
Make changes to the text as required. The available right-click menu provides standard editing commands such as cut, copy, 
paste and delete. 

To effect a change either click away from the note or press the green tick button. If you decide the change made is not needed, 
press the red cross button to discard the change. 
If the Word Wrap option is disabled in the Note dialog, a horizontal scroll bar will also be available when editing the text in-situ. 

 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed note object directly in the workspace and change its size, shape or location, 
graphically. 
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A note can be displayed in either expanded (full frame) or collapsed (small triangle) modes. Toggle the display mode either by 
using the Collapsed option in the Note dialog, or by clicking on the top left corner of a placed note. 

 

When a fully expanded note object is selected, the following editing handles are available: 

 

Click and drag A to resize the note in the vertical and horizontal directions simultaneously. 

Click and drag B to resize the note in the vertical and horizontal directions separately. 

Click anywhere on the note - away from editing handles - and drag to reposition it. The note can be rotated or flipped while 
dragging. 

The size and shape of a note cannot be changed graphically when the note is in collapsed mode, only its location/orientation. 
As such, editing handles are not available when a collapsed note object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the note as required. The note can be rotated or flipped while 
dragging. 

When a note is in collapsed mode, hovering the cursor over it will display a pop-
up containing the name of the note's author and the actual text content of the 
note. 
If you attempt to graphically modify a note object that has its Locked property 
enabled, a dialog will appear asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
While notes can be rotated or flipped along the X or Y axis, this has no effect on the orientation of the text within. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Off Sheet Connector 

 

Description 
An off sheet connector is an electrical design primitive. Off sheet connectors are used to connect nets across multiple schematic 
sheets that are descended from the same parent sheet symbol. 

Availability 
Off sheet connectors are available for placement in the Schematic Editor only, by choosing Place » Off Sheet Connector [P, C] 
from the Schematic Editor main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter off sheet connector placement mode. 
Position the cursor on the sheet and click or press Enter to effect placement of the off sheet connector. 

Continue placing further off sheet connectors, or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the off sheet connector. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the off sheet connector along the X-axis or Y-axis respectively. 

Editing 
The properties of an off sheet connector object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of an off sheet connector object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Off Sheet Connector dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives 
page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the off 
sheet connector object, which will be applied when placing subsequent off sheet connectors. 
During placement, the Off Sheet Connector dialog can be accessed by pressing the Tab key. 

After placement, the Off Sheet Connector dialog can be accessed in one of the following ways: 

• double-clicking on the placed off sheet connector object 
• selecting the off sheet connector object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed off sheet connector object. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 89 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed off sheet connector object directly in the workspace and change its location 
graphically. Off sheet connectors are fixed with respect to their size and shape. As such, editing handles are not available when 
the off sheet connector object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the off sheet connector as required. The off sheet connector can 
be rotated or flipped while dragging. 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the assigned net for the off sheet connector directly in the workspace. Select 
the off sheet connector and then click once to invoke the feature. Type the name of the assigned net as required and then click 
away from the off sheet connector or press Enter to effect the change. 

If you attempt to graphically modify a off sheet connector object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Multiple schematic sub-sheets can be referenced by a single sheet symbol by separating each filename by a semi-colon, in the 
Filename field. 

 

 

Off sheet connectors can only be used to connect nets across the descendant child schematic sheets of the same parent sheet 
symbol. To successfully connect a particular net across two or more sheets, the off sheet connectors on each sheet must be 
assigned to the same net. 
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Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Parameter 

 

Description 
A parameter is a non-electrical child object of an electrical design primitive or design directive. It is a user-definable object that 
allows you to add additional information to a design object supporting the use of parameters (e.g. a part). Such an object can 
have multiple parameters defined, each of which can be displayed with respect to its name and/or value. 

Availability and Placement 
Parameters may be added to any of the following design objects: 
• Part - from the Parameters region of the Component Properties dialog (or Library Component Properties dialog if added 

when defining a component in the Schematic Library Editor) 
• Pin - from the Parameters tab of the Pin Properties dialog 

• Port - from the Parameters tab of the Port Properties dialog 

• Sheet Symbol - from the Parameters tab of the Sheet Symbol dialog 

• Parameter Set - from the associated Parameters dialog 

• PCB Layout directive - from the associated Parameters dialog 

• Probe directive - from the Probe dialog 

• Stimulus directive - from the associated Parameters dialog 

• Test Vector Index directive - from the associated Parameters dialog 

• Net Class directive - from the associated Parameters dialog 

• Differential Pair directive - from the associated Parameters dialog. 

In addition, you can add parameters at the document level (from the Parameters tab of the Document Options dialog (Design » 
Document Options)) and the project level (from the Parameters tab of the Options For Project dialog (Project » Project 
Options)). 

In each case the controls for defining new parameters, or editing/removing existing ones, are the same. Click the Add button to 
create a new parameter - the Parameter Properties dialog will appear. 
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Use this dialog to define a name and value for the parameter and to setup graphical properties that will determine how the 
parameter information appears in the workspace.  

Each defined parameter will appear in the corresponding parameters list, showing its name, value and type. You can control the 
visibility of each parameter as required, using the corresponding option in the Visible column. 

Adding a Parameter as a Rule 
Use the Add as Rule button to specifically add a design rule directive into the schematic. This feature allows you to define 
constraints for the design prior to PCB layout. The Parameter Properties dialog will appear, with the Name and Type fields set 
to Rule and STRING respectively and inactive. 

 

Clicking the Edit Rule Values button will open the Choose Design Rule Type dialog. This dialog lists each of the rule categories 
and rule types that are available in the PCB document. Double-click on a rule type to open its corresponding Edit Rule Type 
dialog, from where you can define the constraints for the rule. 

Editing 
The properties of a parameter object can be modified before and after placement of the parent design object. Editing itself falls 
into two categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a parameter object, independently of the parent 
design object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Parameter Properties dialog can be accessed prior to adding a new parameter to a design object, from the Schematic - 
Default Primitives page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default 
properties for the parameter object, which will be applied when adding subsequent new parameters to design objects. 

After placement of the parent design object, the Parameter Properties dialog can be accessed in one of the following ways: 

• double-clicking on the required parameter field of the placed design object 
• selecting the required parameter field of the design object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the required parameter field of the placed 
design object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a parameter object directly in the workspace and change its location graphically. 
Parameters can only be adjusted with respect to their size by changing the size of the font used (accessed through the 
Parameter Properties dialog). As such, editing handles are not available when a parameter object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the parameter object as required. The object can be rotated or 
flipped while dragging: 
• Press the Spacebar to rotate the parameter. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the parameter along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the value for a parameter directly in the workspace. Select the parameter and 
then click once to invoke the feature. Type the new value as required and then click away from the parameter field or press 
Enter to effect the change. 
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Notes 
Parameters can be added, edited and removed from applicable design objects using the Parameters region of the SCH 
Inspector panel (with the relevant object(s) selected). 

 

There may be times where you want (need, or prefer) to access your own reference material from within a design project. To 
facilitate this, the application provides two methods for linking from a component on the schematic sheet to reference 
information. Linkage is established through the addition of specific component parameters. One approach gives F1 access to a 
referenced document. The other, which caters for multiple references, uses the right-click context menu. 

The HelpURL Parameter 
This parameter allows you to explicitly define which document will be accessed when you press F1 - either over the associated 
component on the schematic sheet, or for the selected entry for that component in the Libraries panel. 

Using this parameter, you can reference any document that can be opened by the Altium Designer environment, including PDF, 
HTML and Text documents. To use this feature, add the HelpURL parameter to the required component and set the value of 
the parameter to the document you wish to open. 

 

When specifying the value for the parameter, you can either include an absolute path or just enter the document name. The 
following examples are valid entries for the value of the parameter: 
C:\Design_Projects\Schematics\Modifications.txt 

AP0102 Linking an FPGA Project to a PCB Project.pdf 

www.opencores.com 

For a PDF document, you can also specify at which page you wish the document to be opened. Do this by adding the 
#page=xx option at the end of the document name, as illustrated below: 

CR0118 FPGA Generic Library Guide.pdf#page=364 

When F1 is pressed with the cursor hovering over the placed object, a search for the document is conducted as follows: 

• If a path to a particular location is specified, this location will be searched first 
• If the document cannot be found at this specific location, or if no path is specified, the \Help folder of the installation will be 

searched 

• If the document still cannot be found, the default help topic for the object will be used and displayed. 
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The ComponentLink Parameter Pair 
This feature enables you to define and present named links to one or more target reference documents in a part's right-click 
context menu. Multiple ComponentLink parameter pairings can be defined. To use this feature, add and configure the two 
parameters for each pairing as follows: 

First parameter - used to define the target document: 
Name = ComponentLinknURL 

Value = target document name 

Again, the parameter's value must include the full path if the document does not reside in the \Help folder of the installation. 
Specify the page number for a PDF document as required. 

Second parameter - used to define the link caption that appears in the menu: 
Name = ComponentLinknDescription 

Value = any meaningful description 

Note: For both parameters in the pairing, n is an integer value, allowing you to define multiple parameter pairings. For each 
ComponentLink pairing, ensure that n is the same for both constituent parameters. 

To access the defined link, right-click on the placed part in the workspace. The entry for the link will appear in the References 
sub-menu. 

 

The following points relate directly to the use of the HelpURL and the ComponentLink parameters: 
• The HelpURL, ComponentLinknURL and ComponentLinknDescription parameter names must each be one word, but 

are case insensitive. 

• When using either of the component-to-datasheet linking features to reference a PDF document, the document will open in 
an Acrobat Viewer window, separate to the Altium Designer Documentation Library. Once opened, calls to further PDFs will 
populate the open window and not start a new instance. 

For other document types that are referenced using these features, the resulting document will open as a tabbed document 
view in the main design window. 
• The document referenced by the HelpURL parameter for an object will take display precedence over any default topic 

written for that object. 
• Where both HelpURL and ComponentLink parameters have been defined for a component, the right-click menu will 

contain entries for both. In the case of the former, the entry will be listed first and will be given the default description Help. 
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Parameter Set 

 

Description 
A Parameter Set is a design directive. It is essentially a container for one or more parameters, which can be associated to a net 
object within a schematic design. 

Availability 
Parameter sets are available for placement in the Schematic Editor only. Both default (empty) and specific (Test Vector Index, 
Stimulus, PCB Layout, Net Class, Differential Pair) parameter set directives are available. Access the corresponding commands 
from the main Place menu as follows: 

• choose Place » Directives » Parameter Set [P, V, M] 

• choose Place » Directives » Test Vector Index [P, V, T] 

• choose Place » Directives » Stimulus [P, V, S] 

• choose Place » Directives » PCB Layout [P, V, P] 

• choose Place » Directives » Net Class [P, V, C] 

• choose Place » Directives » Differential Pair [P, V, F]. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter design directive placement mode. 
Position the cursor over a wire or other net object and click or press Enter to effect placement. 

Continue placing further directives or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the directive. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the directive along the X-axis or Y-axis respectively. 

Editing 
The properties of a parameter set directive can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a parameter set directive. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the individual options available. Click on 
the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that 
field or option. 
The Parameters dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the parameter 
set directive, which will be applied when placing subsequent parameter set directives. 
During placement, the Parameters dialog can be accessed by pressing the Tab key. 

After placement, the Parameters dialog can be accessed in one of the following ways: 

• double-clicking on the placed parameter set directive 
• selecting the parameter set directive and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed parameter set directive. 

The parameter set directive's member parameters can be added, edited or removed from within the Parameters dialog. The 
properties of a parameter are available to view/modify in the Parameter Properties dialog. 

 

When a parameter is added as a rule, the parameter name (Rule) is locked and cannot be changed. 
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The parameters of a parameter set directive can be edited independently of the parent set directive. As such, the Parameter 
Properties dialog can be accessed using the three methods described previously (replacing parameter set directive with the 
relevant parameter object whose properties you wish to view/modify). 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed parameter set directive directly in the workspace and change its location or 
orientation graphically. 

When a parameter set directive is selected in the workspace, a dashed box will appear around the directive. The box encloses 
the area occupied by the directive only. For each visibility-enabled member parameter of the set a dashed line will be visible, 
connecting the text field of the parameter to the body of the directive, thereby affirming association: 

 

Click anywhere inside the dashed box and drag to reposition the parameter set directive as required. The directive can be 
rotated or flipped while dragging. 

The parameter set directive's parameter text fields, which can be graphically edited independently of the parent directive, can 
only be adjusted with respect to their size by changing the size of the font used (accessed through the relevant Parameter 
Properties dialog). As such, editing handles are not available when any of these objects are selected: 

 

Click anywhere inside the dashed box and drag to reposition the text object as required. The object can be rotated or flipped 
while dragging: 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the value for a parameter directly in the workspace (with the exception of 
parameters that have been added as rules). Select the text object and then click once to invoke the feature. Type the new value 
as required and then click away from the text object or press Enter to effect the change. 

If you attempt to graphically modify a parameter set object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Notes 
When placing a default parameter set directive there will be no existing parameters. 

 

A PCB Layout directive allows you to assign PCB layout information to a net in the schematic. When a PCB is created from the 
schematic, the information in the PCB layout directive is used to create relevant PCB design rules. 

The information specified by a PCB Layout directive is applied only to the net to which it is connected. 

 

Net Class directives enable you to create user-defined net classes on the schematic. When a PCB is created from the 
schematic, the information in a Net Class directive is used to create the corresponding Net Class on the PCB. To make a net a 
member of a net class, attach a Net Class directive to the relevant wire or bus and set the directive's ClassName parameter to 
the name of the desired class. 
The Generate Net Classes option (for User-Defined Classes) must be enabled, on the Class Generation tab of the Options for 
Project dialog, to make use of this feature. 

 

A Differential Pair directive allows you to define a differential pair object on the schematic. Attach a directive of this type to both 
the positive and negative nets of the intended pair. The nets themselves must be named with the suffixes of _P and _N 
respectively. Both parameter set objects will contain a single parameter entry, with Name: DifferentialPair and Value: 
True. 

 

Each pair of directives (one for the positive net, one for the negative) of this type will yield a differential pair object when 
transferred to the PCB during the synchronization process. Each of these differential pair objects will be added to the default 
Differential Pair class: All Differential Pairs. 

The name of a generated differential pair object will be the root name for the net pair on the schematic. For example directives 
added to RX0_N and RX0_P on the schematic will generate a differential pair object on the PCB with the name RX0. You can 
rename differential pair objects on the PCB side only. 

 

A Stimulus directive is used to identify a node or net to be stimulated when a digital simulation is run. This directive is only used 
during netlist generation. It holds no significance for any schematic processes. 

 

Test vector directives are used to identify a node with a simulation test vector. The test vectors are referred to by a column 
number, which indicates the column of the test vector file to use when the simulation is run. This directive is only used during 
netlist generation. It holds no significance for any schematic processes. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 100 

Part 

 

Description 
A part is an electrical design primitive. It is a schematic symbol that represents an electronic device, such as a resistor, switch, 
operational amplifier, IC, etc. Parts are stored within components in schematic component libraries (*.SchLib) for example. A 
component within a library represents the physical device that is placed on the actual printed circuit board. Each component can 
contain one or more parts. 

A physical component and a logical symbol are the same if they come from a standard library. But for database libraries, a 
physical component represents a record in a table of a database library. For example a physical component, 20AED15 and its 
logical symbol is a Capacitor - non polarized and comes from the Capacitor - Ceramic table in a database library. Note that a 
table within a database library is a collection of similar physical components. 

Availability 
Parts are available for placement in the Schematic Editor only. Use one of the following methods to place a part: 
• choose Place » Part [P, P] from the main menus 

• click the  button on the Wiring toolbar 

• place a specific part directly from the Libraries panel 

• place a specific part from within the Schematic Library Editor. 

Placement 
The way in which a part is placed on a schematic sheet depends on how, and from where, placement mode is invoked. 

Placement using menu or toolbar command 
After launching the command, the Place Part dialog will appear. 
Use the dialog to choose the part you wish to place. You can either type the name of the required part directly into the Physical 
Component field, or use the ... button to the right of this field to open the Browse Libraries dialog.  

 
From here, you can browse through the currently Available Libraries for the active project. The Available Libraries consist of 
project libraries, installed libraries and libraries found along search paths defined in the Search Paths tab of the Options for 
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Project dialog (Project » Project Options). Clicking the ... button in the Browse Libraries dialog will give access to the Available 
Libraries dialog, from where you can add/remove additional libraries to/from the overall list of those available to the project. 
The dialog also provides a search facility - accessed by clicking the Find button - allowing you to search for a specific 
component across the Available Libraries or in any library along an external search path. 

 

Click the History button in the Place Part dialog to access 
the Placed Parts History dialog. 

The dialog, as its name suggests, contains all parts that 
you have previously placed on schematic sheets. The 
history list is persistent across design sessions unless 
purposefully cleared using the available Clear History 
button. 

After choosing the required part, the fields of the Place 
Part dialog will be filled with information associated to the 
chosen part. The Designator will initially be of the default form C?, D?, J?, U?, etc. You can enter the specific designator you 
require here, or at a later stage. 
After clicking OK, you will return to the schematic document and an outline of the part will appear floating on the cursor. Position 
the part at the location required and click or press Enter to effect placement. 

Continue placing further instances of the same part, or right-click or press Esc to exit. The Place Part dialog will reappear. Either 
browse for a different part to place or click Cancel to exit placement mode. 

Press the Spacebar while in placement mode to rotate the part. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the part along the X-axis or Y-axis respectively. 

Placement from Libraries panel 
Parts can be placed onto the active schematic directly from the Libraries panel. Remember that parts are stored within 
components in schematic component libraries and, as such, entries in the panel are referred to as Components rather than 
Parts. 
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Parts can only be placed from the panel when the library being browsed is either a schematic component library (*.SchLib) or 
an integrated library (*.IntLib) and a schematic document is active in the main design window. If the browse mode for the 
panel is set to display additional model types (Footprint, PCB3D), then use library entries with the suffix [Component View]. 

When a selected component can be validly placed onto the active document, the Place button at the top-right of the panel will 
become available and its text will change to incorporate the name of that component. 

To place a selected component, either: 
• click on the Place button, 

• double-click on the component entry, 
• right-click and choose the Place ComponentName command, or 

• click on the component entry and drag it onto the schematic sheet. 

When placing a part on a schematic sheet using any of the first three methods of placement, the selected part will appear 
floating on the cursor. Position the part at the required location and click to effect placement. 
Continue placing further instances of the same part or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the part. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the part along the X-axis or Y-axis respectively. 

When using the click-and-drag placement method, only a single instance of the part is placed. You do not remain in placement 
mode and the part cannot be rotated or flipped. 

Placement from within Schematic Library Editor 
Parts can be placed onto a Schematic document directly from the active Schematic Library document. 
Placement is carried out from the SCH Library panel. Remember that parts are stored within components in schematic 
component libraries and, as such, entries in the panel are referred to as Components rather than Parts. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 103 

 
Select the entry for the component you wish to place and click the Place button. The schematic document upon which the 
component is placed will depend on whether or not any schematic documents are currently open: 
• If there are no schematic documents open, clicking the Place button will cause a new schematic document 

(Sheet1.SchDoc) to be created and made the active document in the main design window. The active library component 
will appear floating on the cursor, ready for placement 

• If one or more schematic documents are currently open, the last document to have been active (irrespective of the project it 
belongs to) will be made the active document in the main design window and the active library component will appear 
floating on the cursor, ready for placement. 

When in placement mode, position the part at the location required and click or press Enter to effect placement. 

Continue placing further instances of the same part, or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the part. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the part along the X-axis or Y-axis respectively. 

Editing 
The properties of a part object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a part object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the individual options available. Click on 
the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that 
field or option. 

The following sections provide an overview of each of the specific regions of the dialog: 

Properties 
This section of the dialog contains editable fields for the component comment and description, where available. The designator 
of the component can be defined here, as well as a Locked option to exclude the component from any reannotation of 
schematic designators. 
For multi-part components, an additional Locked option can be enabled to prevent reannotation of the sub-parts. 

The Unique Id for the component can either be changed by directly typing in the Unique Id field, or by pressing the Reset 
button. The latter will result in another system-assigned ID being generated. 

You can also change the part number for the selected part, when considering a multi-part component. The designator suffix and 
pin numbering will be changed to reflect the part number chosen. 
The Type field allows you to specify what type of component you are using. The following six types are supported: 

• Standard - standard electrical component loaded onto board. Always synchronized, always in BOM. 

• Mechanical - non-electrical component, e.g. heat sink or mounting bracket. Synchronized if exists on both schematic and 
PCB documents, always in BOM. 

• Graphical - non-electrical component used for company logo, title block, etc. Never synchronized and not included in BOM. 

• Net Tie (In BOM) - for shorting two (or more) nets together in the routing. Typically used if a jumper type component needs 
to be fitted and also provide shorting in the same location. Always synchronized and included in BOM. 

• Net Tie - as above but designed so you couldn't tell a component existed at the location where the shorting is to occur. 
Always synchronized but not included in BOM. When placing components of this type, use the Verify Shorting Copper option 
in the Design Rule Checker dialog (when performing a DRC in the PCB), to verify the short (i.e. that no unconnected copper 
exists in the component). 

• Standard (No BOM) - standard electrical component loaded onto board. Always synchronized, not included in BOM. 

Library Link 
This region of the dialog provides information regarding the library from which the part was placed. It also includes the Design 
Item ID for the part – as it appears in the library. Use the Choose button to access the Browse Libraries dialog, from where you 
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can choose (and therefore change) the current part to any other part in the same library, or any library available as part of the 
Available Libraries list. The component placed from a schematic or integrated library will have its Design Item ID set to the 
symbol reference (library reference). 
If the component is placed from a database library then the Library Link region will provide information on; 

• the component’s Design Item Id which represents the unique part number and represents a record within the table of a 
database. 

• the parent database library filename in the Library Name field 

• the specific database table in which the component resides in the Table Name field 

Again, the Choose button will be available to access the Browse Libraries dialog. Change the part to another one in the same 
table of the linked database, or browse to one in a different table of the same or different linked database. 

Sub-Design Links 
This region of the dialog provides non-editable information with respect to any sub-design linking for the component. There are 
two possible scenarios: 

• an FPGA sub-project linked to an FPGA component in a PCB project 

• an embedded sub-project linked to an MCU core in an FPGA project 
The Configuration field can only be populated for the first scenario, where a specific configuration has been chosen containing 
a constraint file in the FPGA project targeting the physical FPGA device on the PCB. 

Graphical 
This section of the dialog provides options that allow you to control the orientation and location of the component in the 
workspace and to set up and implement local colors used to define its fill, lines and pins. Options are also available to allow 
mirroring of the component and also to show any hidden pins. 
The Mode drop-down field displays the current graphical representation of the component. Every component has a Normal 
mode or representation. In addition, a further 255 Alternate graphical representations (modes) of the component can be created. 
If any Alternate modes have been defined for the current component, the drop-down field will become available and you may 
select which mode to use for the graphical representation of the component on the schematic document. 

Parameters List 
This section of the dialog enables you to define any parameter information for the component. Parameters are a way of defining 
and associating additional information and could include strings that identify component manufacturer, date added to the 
document and also a string for the component's value, where applicable (e.g. 100K for a resistor or 10PF for a capacitor). 

New parameters can be defined, or existing ones edited or removed. Click the Add button to create a new parameter - the 
Parameter Properties dialog will appear. Use this dialog to define a name and value for the parameter and to setup graphical 
properties that will determine how the parameter information appears in the workspace.  

Each defined parameter will appear in the Parameters list, showing its name, value and type. You can control the visibility of 
each parameter as required, using the corresponding option in the Visible column. 

Use the Add as Rule button to specifically add a design rule directive into the schematic. This feature allows you to define 
constraints for the design prior to PCB layout. The Parameter Properties dialog will appear, with the Name and Type fields set 
to Rule and STRING respectively and inactive. 

Clicking the Edit Rule Values button will open a dialog listing each of the rule categories and rule types that are available in the 
PCB document. Double-click on a rule type to open its corresponding Edit Rule Type dialog, from where you can define the 
constraints for the rule. 

Models List 
This section of the dialog is used to define links to the following model types: 

• Footprint 

• Simulation 

• PCB3D 

• Signal Integrity 

You can add any number of new model links or edit/remove existing ones. 
Click the Add button to open the Add New Model dialog, from where you can select which particular model type to add. 
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For each model link that is created, the name of the model, its associated type and any description is listed. 
Use the Name column to define which model of each available type is the currently linked model. 

To edit an underlying model definition, select the entry for the link and click the Edit button (or double-click on the entry). The 
dialog that appears will depend on the type of model you are editing. 

Dialog access 
A variant of this dialog - the Library Component Properties dialog - can be accessed prior to entering placement mode, from the 
Schematic - Default Primitives page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change 
the default properties for the part object, which will be applied when placing subsequent parts. 
During placement, the Component Properties dialog can be accessed by pressing the Tab key. 

After placement, the Component Properties dialog can be accessed in one of the following ways: 

• double-clicking on the placed part object 
• selecting the part object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed part object. 

The part's Designator and Comment fields, as well as any user-defined parameters for the part, can be formatted 
independently of the part itself. In each case the properties of a parameter are available to view/modify in the Parameter 
Properties dialog. 

 

For the Designator and Comment, the parameter name is locked and cannot be changed. 

The Parameter Properties dialog can be accessed using the three methods described previously (replacing part with the 
relevant parameter object whose properties you wish to view/modify). 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a placed part object directly in the workspace and change its location or orientation, 
graphically. Parts are fixed with respect to their size and shape - changes affecting these attributes can only be carried out on 
the source library component. 

When a part object is selected in the workspace, a dashed box will appear around the part. The box encloses the area occupied 
by the part. For each text field associated to the part (Designator, Comment, user-defined parameters) a dashed line will be 
visible, connecting the text field to the body of the part, thereby affirming association: 

 

Click anywhere inside the dashed box and drag to reposition the part as required. The part can be rotated or flipped while 
dragging. 

The part's Designator, Comment and user-defined parameter text fields, which can be graphically edited independently of the 
parent part, can only be adjusted with respect to their size by changing the size of the font used (accessed through the relevant 
Parameter Properties dialog). As such, editing handles are not available when any of these objects are selected: 

 

Click anywhere inside the dashed box and drag to reposition the text object as required. The object can be rotated or flipped 
while dragging: 
• Press the Spacebar to rotate the text. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the text along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the value for the Designator, Comment or user-defined parameter directly in 
the workspace. Select the text object and then click once to invoke the feature. Type the new value as required and then click 
away from the text object or press Enter to effect the change. 

Part Actions 
Right-clicking over a placed part will pop-up a context-sensitive menu, from which a variety of commands are available that act 
on that part (or on all selected parts where applicable). The following sections detail each of these commands. 
Note: Many of the following commands are also available from the Schematic Editor's main menus. Commands on the main 
menus apply to the selected part(s) or allow you to choose the part on which the command will act, rather than just the part 
under the cursor. Where such commands exist, reference to their access is made. 

Incrementing the Part Number 
This command is used to visually toggle through the available part numbers for the chosen multi-part component on the current 
document. 

The command can be accessed either by: 
• choosing Edit » Increment Part Number from the main menus. You will be prompted to choose a part. After incrementing a 

part, you will remain in increment mode, enabling you to increment further parts 
• right-clicking over the required part and choosing Part Actions » Increment Part Number from the menu that appears. 

After launching the command (and choosing the part if applicable), the designator of the part will change to display the next part 
number for the device and the associated pins for the part will change accordingly. 

Using this command on a non-multi-part component will have no effect. 
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Pushing a Part onto a New Sub-Sheet 
This command allows you to "push" a placed part onto a new schematic sub-sheet. Access this command by: 
• choosing Tools » Convert » Push Part to Sheet from the main menus. You will be prompted to choose a part 

• right-clicking over the required part and choosing Part Actions » Push Part to Sheet from the menu that appears. 

After launching the command (and choosing the part if applicable), the part will be pushed to a newly-created sub-sheet. 
Breaking the process down, the following sequence of steps are essentially performed: 

• the chosen part is copied 

 

• the original part is converted to a sheet symbol, whose Designator field is set to the designator of the original part and 
whose Filename field will have an entry of the format PartComment.SchDoc. 

 

Note: If the part has a linked sub-project, such as a processor with a linked embedded software project, then the sheet 
symbol's Filename field will have an entry of the format LinkedProjectName.SchDoc. In the previous example image, 
the TSK51A_D processor has a linked sub-project called SpiritLevel.PrjEmb, which can be seen in the Sub-Design 
Links region of the corresponding properties dialog for the part. 
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• a new schematic sub-sheet is then created from the sheet symbol, the name of which is taken from the symbol's Filename 
field 

• the copy of the original part is then pasted onto the center of this sheet and the corresponding ports wired to the part's pins 
accordingly 

 

Note: The new sheet is initially unsaved. You will need to save it and recompile before the modification to the project structure is 
reflected in the Projects panel. 

Converting a Part to a Sheet Symbol 
This command is used to convert a chosen part to a sheet symbol. 

The command can be accessed either by: 
• choosing Tools » Convert » Convert Part To Sheet Symbol from the main menus. You will be prompted to choose a part. 

After converting a part, you will remain in conversion mode, enabling you to convert further parts 
• right-clicking over the required part and choosing Part Actions » Convert Part To Sheet Symbol from the menu that 

appears. 

After launching the command (and choosing the part if applicable), the part will be converted to a sheet symbol, with 
Designator initially set to the part's designator and Filename initially set to the part's comment text. Sheet entries will be 
created based on the part's pins. 
Change the Filename for the sheet symbol as required, in order to point to the required schematic sub-sheet. 

Change the sheet entries as required, in accordance with the ports defined on the sub-sheet that you wish to reference from the 
sheet symbol. 

Converting a Part to Ports 
This command is used to convert a chosen port component into standard port primitives. 

Although this feature will convert any schematic component into equivalent ports, it is specifically intended for conversion of port 
components (placed from the FPGA NanoBoard Port-Plugin integrated library). These components illustrate the hardware on 
the NanoBoard that the signals will eventually be taken to. However, the signals do not connect directly to the illustrated board 
hardware. Rather they are routed to the physical pins of the FPGA device. It is therefore often clearer to represent the signal 
lines to these physical pins using standard ports, rather than the port components. 

The command can be accessed either by: 
• choosing Tools » Convert » Convert Part To Ports from the main menus. You will be prompted to choose a part. After 

converting a part, you will remain in conversion mode, enabling you to convert further parts 
• right-clicking over the required part and choosing Part Actions » Convert Part To Ports from the menu that appears. 
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After launching the command (and choosing the part if applicable), the port component will be converted into electrically 
equivalent ports. 

 

Creating a VHDL File from a Part 
This command is used to create a new VHDL document (*.Vhd) from a placed part on the current schematic document. 
Although the command will create a VHDL file from any schematic part, it is intended for use when creating core components. 

The command can be accessed either by: 
• choosing Tools » Convert » Create VHDL from FPGA-Part from the main menus. You will be prompted to choose an 

FPGA part 
• right-clicking over the required part and choosing Part Actions » Create VHDL from FPGA-Part from the menu that 

appears. 

After launching the command (and choosing the part if applicable), the VHDL document will be created and opened as the 
active document. The pins on the part will be included as declared ports in the document's entity definition. 

The template for the architecture will be defined, but the component and signal declarations are left ready for you to code in. 
The VHDL document is named using the entry in the part's Library Ref field. This entry is also used as the name for the 
document's entity. 
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Creating a Verilog File from a Part 
This command is used to create a new Verilog document (*.V) from a placed part on the current schematic document. Although 
the command will create a VHDL file from any schematic part, it is intended for use when creating core components. 

The command can be accessed either by: 
• choosing Tools » Convert » Create Verilog from FPGA-Part from the main menus. You will be prompted to choose an 

FPGA part 
• right-clicking over the required part and choosing Part Actions » Create Verilog from FPGA-Part from the menu that 

appears. 

After launching the command (and choosing the part if applicable), the Verilog document will be created and opened as the 
active document. The pins on the part will be included in the document's module definition. 
The Verilog document is named using the entry in the part's Library Ref field. This entry is also used as the name for the 
document's module. 

 

Accessing Variant Information 
This command enables you to access the variant-related information for the chosen part directly from the schematic. The 
command is accessed by right-clicking on the part of interest and choosing the Part Actions » Assembly Variants command 
from the menu that appears. 

The Assembly Variant Management dialog will open with the target part already selected – enabling you to quickly assess both 
its inclusion state in any defined board variants, and view its component-level parameters across all variations of the design. 
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Cross-Selecting on the PCB 
This command is used to cross-select between parts selected on one or more schematic source documents and the 
corresponding component footprints on the PCB document, for the active project. This can be very useful should you wish to 
select a set of parts in the source documents and create a new component class quickly in the PCB document. 

The command can be accessed either by: 
• choosing Tools » Select PCB Components from the main menus 

• right-clicking over the required part (or one part in a selection of parts) and choosing Part Actions » Select PCB 
Components from the menu that appears. 

If you wish to cross select for the part under the cursor, use the second method of access, without prior selection. If you wish to 
cross select multiple parts, ensure they are first selected (on their respective sheets) before launching the command. Also 
ensure that the target PCB document is open. 

After launching the command, the PCB document for the project will become the active document in the main design window 
and all corresponding component footprints for the selection will become selected. The view of the main design window will 
change to fit all component footprints in the selection. 

For ease of reference, you may find it easier to have the source document(s) and target PCB document open side-by-side in the 
workspace, for example tiled or as separate windows across dual monitors. 
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All schematic source documents will be automatically compiled before the PCB document is made active. Those schematic 
documents that are not currently open as tabbed documents in the main design window will be opened and automatically 
hidden, to avoid cluttering the design window. 

If the active project contains multiple PCB documents, you should open only the document upon which you wish to work/have 
the component footprints selected. If more than one PCB document is opened, the command will interrogate all documents for a 
corresponding match to the parts selected on the schematic document(s). 

Notes 
When placing multiple instances of the same part, it is advisable to set the designator of the first part before placing it (press the 
Tab key during placement to edit the part's properties). By doing this, the designator will automatically increment as each 
subsequent part is placed. 

 

If you change the Unique ID for the component, the unique ID entry in the corresponding component on the PCB design 
document will no longer match. You will need to match components again using the Edit Component Links between Flattened 
Project and PCB dialog (from the PCB document). 

 

Colors defined for Fill, Lines and Pins will only be used if the Local Colors option is enabled. These colors are used to override 
those that are defined for the component in the source schematic library. 

 

For a multi-part component, the relevant pins for the selected part will be highlighted with a white background in the Component 
Pin Editor dialog. All pins of other parts will be lowlighted with a grey background. You are, however, still able to edit the pins of 
these non-selected parts. 

 

Each parameter has a Unique ID assigned to it. This is used for those parameters that have been added as design rule 
directives. When transferring the design to the PCB document, any defined rule parameters will be used to generate the 
relevant design rules in the PCB. These generated rules will be given the same Unique IDs, allowing you to change rule 
constraints in either schematic or PCB and push the change across when performing a synchronization. 

 

In the Schematic Library Editor, model linking for a component can also be carried out: 
• in the Models section of the SCH Library panel 

 

• in the Models section of the main design window 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 114 

 

• in the dedicated Model Manager dialog (Tools » Model Manager) 

 

Only one model of a particular model type can be enabled as the currently linked model, at any one time. 

 

The name and description for a model can be edited directly in the Models List section of the Component Properties/Library 
Component Properties dialog. 

 

Any parameters defined in the Parameters List section of the Component Properties/Library Component Properties dialog will 
be made available in the Matching Options region of the Annotate dialog (Tools » Annotate Schematics). This is particularly 
useful if you wish to group specific parts of a multi-part component, using a unique parameter that you have defined and 
included for those parts. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 

 

If you attempt to graphically modify a component object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Pie Chart 

 

Description 
A pie chart is a non-electrical drawing primitive. It is a circular sector graphic element that can be placed on a schematic sheet. 
It can be filled or unfilled. 

Availability 
Pie charts are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Pie Chart [P, D, C] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Pie Chart [P, C] from the main menus 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter pie chart placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the center point of the pie chart 

• move the cursor to adjust the radius of the pie chart, then click or press Enter to set it 

• move the cursor to adjust the start point of the segment, then click or press Enter to anchor it. 

• move the cursor to change the position of the segment's end point, then click or press Enter to anchor it and complete 
placement of the pie chart. 

Continue placing further pie charts, or right-click or press Esc to exit placement mode. 

The pie chart object can be rotated or flipped while in placement mode and before the center of the pie chart is anchored: 
• Press the Spacebar to rotate the pie chart. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the pie chart along the X-axis or Y-axis respectively. 

Editing 
The properties of a pie chart object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a pie chart object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Pie Chart dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the pie chart object, 
which will be applied when placing subsequent pie charts. 
During placement, the Pie Chart dialog can be accessed by pressing the Tab key. 

After placement, the Pie Chart dialog can be accessed in one of the following ways: 

• double-clicking on the placed pie chart object 
• selecting the pie chart object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed pie chart object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed pie chart object directly in the workspace and change its size, shape or 
location, graphically. 

When a pie chart object is selected, the following editing handles are available: 

 

Click and drag A to adjust the radius. 

Click and drag B to adjust the end points. 

Click anywhere on the pie chart - away from editing handles - and drag to reposition it. The pie chart can be rotated or flipped 
while dragging. 
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If you attempt to graphically modify a pie chart object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page in the Schematic section of the Preferences dialog - is 
enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed 
during the same placement session. 
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Pin 

 

Description 
A pin is an electrical design primitive. Pins give a part its electrical properties and define connection points on the part for 
directing signals in and out. 

Availability 
Pins are available for placement in the Schematic Library Editor only. Use one of the following methods to place a pin: 
• choose Place » Pin [P, P] from the main menus 

• click the  button on the Utility Tools drop-down of the Utilities toolbar 

• click the Add button in the Pin List section of the SCH Library panel 

• click the Add button in the Component Pin Editor dialog 

Placement 
The way in which a pin is placed on a sheet depends on how, and from where, placement mode is invoked. 

Placement using menu or toolbar command 
After launching the command, the cursor will change to a cross-hair and you will enter pin placement mode. The pin will appear 
floating on the cursor held by its electrical end, which goes against the component body. Position the cursor and click or press 
Enter to effect placement. 

Continue placing further pins or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the pin. Rotation is anti-clockwise 
and in steps of 90°. 
Press the X or Y keys while in placement mode to flip the pin along the X-axis or Y-axis 
respectively. 

Placement from SCH Library panel 
Pins can be added directly from the SCH Library panel. 

First ensure that the component to which you wish to add one or more pins to is active in 
the main design window. To do this, select its entry in the main Components list section of 
the panel. 
To add a new pin, click on the Add button beneath the Pin List section of the panel (which 
lists all pins currently defined for the active component). The pin will appear floating on the 
cursor in the Symbol section of the main design window, held by its electrical end, which 
goes against the component body. Position the cursor and click or press Enter to effect 
placement. Upon placement, an entry for the new pin will be added to the Pin List section 
of the panel. 
Continue placing further pins or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the pin. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the pin along the X-axis or Y-axis respectively. 

Placement from Component Pin Editor dialog 
Pins can be placed directly from the Component Pin Editor dialog. 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 119 

 
To place an additional pin on the sheet for the active component in the library, click the Add button at the bottom left of the 
dialog. 

Only a single pin is placed directly on the sheet. You do not remain in placement mode and the pin cannot be rotated or flipped. 

The Designator of the new pin will be the next available unused designator. If one or more pins have previously been removed, 
such that the designators of the remaining pins are not sequentially continuous, a new pin will be given the first available 
unused designator in the sequence. 

Editing 
The properties of a pin object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following five methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a pin object. 

 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Pin Properties dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the pin object, 
which will be applied when placing subsequent pins. 
During placement, the Pin Properties dialog can be accessed by pressing the Tab key. 

After placement, the Pin Properties dialog can be accessed in one of the following ways: 
• double-clicking on the placed pin object in the Symbol section of the Schematic Library Editor's main design window 

• choosing the Change command from the Edit menu and then clicking once over the placed pin object 

• double-clicking on the pin's entry in the Pin List section of the SCH Library panel 

• selecting the pin's entry in the Pin List section of the SCH Library panel and then clicking on the associated Edit button for 
the section 

• double-clicking on the required pin entry (or selecting it and pressing the Edit button) in the Component Pin Editor dialog. 
This dialog is accessed by clicking the Edit Pins button at the bottom left of the Library Component Properties dialog, which 
itself is accessed by double-clicking on the pin's parent component entry in the Components list of the SCH Library panel 
(or, alternatively, selecting the component entry and clicking the Edit button beneath the list). 

The Pin Properties dialog can also be accessed from the Schematic Editor, once a part has been placed. Double-click on the 
placed part to access the Component Properties dialog. When the dialog appears, click on the Edit Pins button at the bottom 
left, to access the Component Pin Editor dialog. Then either double-click on the required pin entry or select the entry and press 
the Edit button, to bring up the Pin Properties dialog. 

Editing via the Component Pin Editor 
Certain pin properties can be edited from the Component Pin Editor dialog, which is accessed by pressing the Edit Pins button 
in either the Component Properties or Library Component Properties dialogs. 

 

The dialog contains all pins associated with either: 

• the selected, placed component in the Schematic Editor or 

• the active component in the current schematic library document. 

With the exception of fields displaying mapping information for any models linked to the parent part, displayed fields for a pin are 
directly editable within the dialog. Click once on a field to focus it for editing and then type the value or select the option as 
required. Click away from the field or press Enter to effect the change. 

The following table shows the corresponding entries for each of these fields in the Pin Properties dialog. 

Field in Component Pin Editor dialog Corresponding field in Pin Properties dialog 

Designator Designator 

Name Display Name 

Desc Description 

Type Electrical Type 

Owner Part Number 
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Show Hide 

Number Visible option for Designator 

Name Visible option for Display Name 

In addition to providing a means of editing pin properties, the Component Pin Editor dialog also allows you to add new pins or 
delete existing ones. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed pin object directly in the workspace and change its location or orientation, 
graphically. Pins can only be adjusted with respect to their size by changing their Length property (accessed through the Pin 
Properties dialog). As such, editing handles are not available when the pin object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the pin object as required. The object can be rotated or flipped 
while dragging. 
If you attempt to graphically modify a pin object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
While placing pins on the workspace, the pin name and pin number will automatically increment if the first or last characters are 
numbers. 

 

Should you need to negate (include a bar over the top of) a pin name, this can be done in one of two ways: 
• Include a backslash character after each character in the name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the name (e.g. \ENABLE). 

 

When you are creating a component that represents a physical multi-pin, multi-part device, such as an IC, you should number 
the pins carefully to correspond to the physical pinout of the device. 
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As well as graphical properties, pins also have electrical properties. On the Logical tab of the Pin Properties dialog, set the 
Electrical Type field to represent the type of electrical connection the pin makes. This can be used by the Compiler to detect 
electrical wiring errors in your schematic. 

 

Enable the Hide option on the Logical tab of the Pin Properties dialog (or disable the Show option if editing directly using the 
Component Pin Editor dialog) to have the pin hidden when it is placed in a schematic. As well as being hidden in the schematic, 
hidden pins also have the property that they are automatically assumed to be connected to any other hidden pins with the same 
name and to any net on the schematic with the same net name. This is normally used to define power and ground pins on a 
component, which will then automatically be connected to power and ground nets of the same name. Use the associated 
Connect To field in the Pin Properties dialog to specifically define the net to which the hidden pin should be attached. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Polygon 

 

Description 
A polygon is a non-electrical drawing primitive. It is a multi-sided graphical object that can be placed on a schematic sheet. A 
polygon must have at least three sides and can be filled or unfilled. 

Availability 
Polygons are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Polygon [P, D, Y] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Polygon [P, Y] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter polygon placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the polygon 

• position the cursor and click or press Enter to anchor a series of vertex points that define the shape of the polygon 

• after placing the final vertex point, right-click or press Esc to complete placement of the polygon. 

Continue placing further polygons, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a polygon object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a polygon object. 

 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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Editing Vertices 
The Polygon dialog provides a Vertices tab, from where you 
can edit the individual vertices of the currently selected polygon 
object as required. 

The main region of the tab lists all of the vertex points currently 
defined for the polygon. You can add new vertices to the 
polygon, edit the coordinates of existing vertices, or remove 
selected vertices altogether. 
Click the Menu button or right-click within the main list region to 
access a pop-up menu containing the following commands: 
• Edit - right click on a coordinate cell (X or Y) for a vertex 

and use this command to edit the value in that cell. 
Alternatively, click directly on the cell 

• Add - use this command to add a new vertex point. The new vertex will be added below the currently focused vertex entry 
(as distinguished by a dotted outline around a cell in its row) and will initially have the same coordinates as the focused entry 

• Remove - use this command to remove the currently selected vertex entries in the list. This command will be unavailable if 
there are only two vertices present for the polygon 

• Copy - use this command to copy the content of the selected cells in the list to the clipboard (alternatively use Ctrl+C) 

• Paste - use this command to paste the content of the clipboard into the list, starting at the selected cell (alternatively use 
Ctrl+V) 

• Select All - use this command to quickly select the entire grid contents of the list 

• Select Column - use this command to quickly select the entire column in which the currently focused cell resides 

• Move Up - use this command to move the selected vertex upward in the list 

• Move Down - use this command to move the selected vertex downward in the list 

• Move Polygon By XY - use this command to move the entire polygon object. The Move Polygon By dialog will appear, from 
where you can enter the increment value to be applied to each vertex point's X and Y coordinates. 

Dialog access 
The Polygon dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the polygon object, 
which will be applied when placing subsequent polygons. 
During placement, the Polygon dialog can be accessed by pressing the Tab key. 

After placement, the Polygon dialog can be accessed in one of the following ways: 

• double-clicking on the placed polygon object 
• selecting the polygon object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed polygon object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a placed polygon object directly in the workspace and change its size, shape or 
location, graphically. 

When a polygon object is selected, the following editing handles are available: 

 

Click and drag an editing handle to move a vertex point of the polygon. 

Click anywhere on the polygon - away from editing handles - and drag to reposition it. The polygon can be rotated or flipped 
while dragging: 
• Press the Spacebar to rotate the polygon. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the polygon along the X-axis or Y-axis respectively. 

Right-click on a vertex point and choose the Edit Polygon Vertex n command to access the Vertices tab of the Polygon dialog, 
with the entry for the nth vertex selected ready for editing. 

With the polygon selected, click on a vertex or segment to individually select that vertex or segment. This polygon 'sub-selection' 
is distinguished by the associated editing handles becoming red in color. 

 Individual vertex sub-selection. 

 Individual segment sub-selection. 

The associated vertex (or vertices for a segment) can then be edited directly using the SCH Inspector or SCH List panels, with 
any changes appearing immediately on the schematic. 
If you attempt to graphically modify a polygon object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Complex polygonal shapes are supported. A complex polygon is a self-intersecting or self-crossing polygon. 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Port 

 

Description 
A port is an electrical design primitive. It is used to make an electrical connection between one schematic sheet and another 
sheet or sheet symbol in a design using multiple sheets (both flat and hierarchical designs). The name of the port defines the 
connection (i.e. a port on a schematic sheet connects to ports or sheet entries with the same name on other sheets in the 
project). 

Availability 
Ports are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Port [P, R] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter port placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press Enter to anchor the left hand edge of the port 

• move the cursor to adjust the radius of the pie chart, then click or press Enter to set it 

• move the cursor to adjust the start point of the segment, then click or press Enter to anchor it. 

• move the cursor to adjust the length of the port as required, then click or press Enter to complete placement of the port. 

Continue placing further ports or right-click or press Esc to exit placement mode. 

The port object can be rotated or flipped while in placement mode and before the left hand edge of the port is anchored: 
• Press the Spacebar to rotate the port. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the port along the X-axis or Y-axis respectively. 

Editing 
The properties of a port object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a port object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Port Properties dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page 
of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the port 
object, which will be applied when placing subsequent ports. 
During placement, the Port Properties dialog can be accessed by pressing the Tab key. 

After placement, the Port Properties dialog can be accessed in one of the following ways: 

• double-clicking on the placed port object 
• selecting the port object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed port object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed port object directly in the workspace and change its length or location 
graphically. 

When a port object is selected, the following editing handles are available: 

 

Click and drag A to change the length of the port. 

Click anywhere on the port - away from editing handles - and drag to reposition it. The port can be rotated or flipped while 
dragging. 
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If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the port directly in the workspace. Select the port and then click 
once to invoke the feature. Type the new name as required and then click away from the port or press Enter to effect the 
change. 
If you attempt to graphically modify a port object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
All Ports with the same name, within one schematic document, are considered to be electrically connected. 

 

When a Port is connected to a Signal Harness, the Port becomes a Harness object. By default, the Port will change color to 
match the color of the Signal Harness. Disable the option, Sheet Entries and Ports use Harness Color in Schematic – 
Graphical Editing page of the Preferences dialog to specify your own color for Ports or to use the default color. 

 

When a Port is connected to a Harness Connector by a Signal Harness, the Harness Type in the Port Properties dialog is 
automatically populated with the Harness Type of the Harness Connector. When a Port is connected to a Sheet Entry by a 
Signal Harness and the Sheet Entry has a Harness Type declared, the Port will become a Harness object and change to the 
color of the Signal Harness. If you move the Port away from the Harness Connector or the Sheet Entry, the Port will revert back 
to the default color. 

 

The I/O Type option in the Port Properties dialog allows you to define the port's electrical type. Choose from either Input, 
Output, Bidirectional or Unspecified. 

 

Should you need to negate (include a bar over the top of) a port name, this can be done in one of two ways: 
• Include a backslash character after each character in the name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the name (e.g. \ENABLE). 

 

When compiling a schematic or generating a netlist, the relationship between ports and sheet symbols is determined by the Net 
Identifier Scope chosen for the project. This scope is defined by setting the Net Identifier Scope option in the Options tab of 
the Options for Project dialog (Project » Project Options). 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Power Port 

 

Description 
A power port is an electrical design primitive. It is a special schematic object that lets you easily define a power or ground net. 

Power ports allow you to conveniently indicate a power net at any location in the design, which can then be connected to pins or 
wires. 

Availability 
Power ports are available for placement in the Schematic Editor only. Use one of the following methods to access a placement 
command: 
• choose Place » Power Port [P, O] from the main menus 

• click the  button on the Wiring toolbar to place a bar style power port, pre-assigned to the VCC net 

• click the  button on the Wiring toolbar to place a bar style bus power port, pre-assigned to the VCC net. This button is 
only available when the source schematic is part of an FPGA project 

• click the  button on the Wiring toolbar to place a power ground style power port, pre-assigned to the GND net 

• click the  button on the Wiring toolbar to place a power ground style bus power port, pre-assigned to the GND net. This 
button is only available when the source schematic is part of an FPGA project 

• click the  button on the Utilities toolbar to access a drop-down providing an array of power port commands, including the 
various styles and several net-pre-assigned power ports. 

Power port styles 
The following seven graphical styles of power port are available and can be set by editing the object's properties: 

 

Circle 

 

Arrow 

 

Bar 

 

Wave 

 

Power Ground 

 

Signal Ground 

 

Earth 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter power port placement mode. A power 
port symbol will appear "floating" on the cursor. Position the object and click or press Enter to effect placement. 

Continue placing further power ports, or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the power port. Rotation is anti-clockwise and in steps of 90°. 
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Press the X or Y keys while in placement mode to flip the power port along the X-axis or Y-axis respectively. 

Editing 
The properties of a power port object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the 
properties of a power port object. 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click 
over a field or option to pop-up information specific to that field or 
option. 

The Power Port dialog can be accessed prior to entering placement 
mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows 
you to change the default properties for the power port object, which 
will be applied when placing subsequent power ports. 

During placement, the Power Port dialog can be accessed by 
pressing the Tab key. 

After placement, the Power Port dialog can be accessed in one of the following ways: 

• double-clicking on the placed power port object 
• selecting the power port object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed power port object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed power port object directly in the workspace and change its location 
graphically. Power ports are fixed with respect to their size and shape. As such, editing handles are not available when the 
power port object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the power port as required. The power port object can be rotated 
or flipped while dragging. 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the assigned net for the power port directly in the workspace. Select the 
power port and then click once to invoke the feature. Type the new net name as required and then click away from the power 
port or press Enter to effect the change. 
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If you attempt to graphically modify a power port object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
The graphical symbol selected for a power port does not determine which net it is assigned to. You must explicitly set the net 
name in the Power Port dialog. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Probe 

 

Description 
A probe is a design directive. It is a special marker which is placed on a schematic sheet to identify nodes for digital simulation 
during netlist generation. It can also be used to interrogate the status, in real time, of a net connecting to a pin on a programmed 
FPGA device. 

Availability 
Probes are available for placement in the Schematic Editor only, by choosing Place » Directives » Probe [P, V, R] from the 
main menus. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter probe placement mode. Position the 
cursor over a wire or other net object and click or press Enter to effect placement. 

Continue placing further probe directives or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the probe directive. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the probe directive along the X-axis or Y-axis respectively. 

Editing 
The properties of a probe directive can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a probe directive. 

 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Probe dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the probe directive, 
which will be applied when placing subsequent probe directives. 
During placement, the Probe dialog can be accessed by pressing the Tab key. 
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After placement, the Probe dialog can be accessed in one of the following ways: 

• double-clicking on the placed probe directive 
• selecting the probe directive and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed probe directive. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed probe directive directly in the workspace and change its location 
graphically. Probe directives are fixed with respect to their size and shape. As such, editing handles are not available when the 
probe directive is selected: 

 

Click anywhere inside the dashed box and drag to reposition the probe directive as required. The probe directive can be rotated 
or flipped while dragging. 
If you attempt to graphically modify a probe object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
For an FPGA design, the status of FPGA device pins can be monitored directly from the 
schematic sheet by placing a probe directive on any net that connects to an FPGA pin, as 
illustrated in the image below. 
Note: For this feature to function, the source FPGA design must be downloaded to the 
physical FPGA device and the associated pin states panel for that device must be open 
and remain open. 
The pin states panel for a physical device is accessed by clicking the Show Pins Panel 
button on the associated instrument panel for that device. The latter is loaded into the Instrument Rack – Hard Devices panel 
upon double-clicking the entry for the device, in the Hard Devices chain of the Devices view. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Rectangle 

 

Description 
A rectangle is a non-electrical drawing primitive. It is a graphic element that can be placed on a schematic sheet and can be 
filled or unfilled. 

Availability 
Rectangles are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Rectangle [P, D, R] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Rectangle [P, R] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter rectangle placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the first corner of the rectangle 

• move the cursor to adjust the size of the rectangle, then click or press Enter to anchor the diagonally-opposite corner and 
thereby complete placement of the rectangle. 

Continue placing further rectangles, or right-click or press Esc to exit placement mode. 

The rectangle object can be rotated or flipped while in placement mode and before the first corner of the rectangle is anchored: 
• Press the Spacebar to rotate the rectangle. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the rectangle along the X-axis or Y-axis respectively. 

Editing 
The properties of a rectangle object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a rectangle object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Rectangle dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the rectangle object, 
which will be applied when placing subsequent rectangles.  
During placement, the Rectangle dialog can be accessed by pressing the Tab key. 

After placement, the Rectangle dialog can be accessed in one of the following ways: 

• double-clicking on the placed rectangle object 
• selecting the rectangle object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed rectangle object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed rectangle object directly in the workspace and change its size, shape or 
location, graphically. 

When a rectangle object is selected, the following editing handles are available: 

 

Click and drag A to resize the rectangle in the vertical and horizontal directions separately. 

Click and drag B to resize the rectangle in the vertical and horizontal directions simultaneously. 

Click anywhere on the rectangle - away from editing handles - and drag to reposition it. The rectangle can be rotated or flipped 
while dragging. 
If you attempt to graphically modify a rectangle object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Round Rectangle 

 

Description 
A round rectangle is a non-electrical drawing primitive. Essentially a rectangle object with rounded corners, it is a graphic 
element that can be placed on a schematic sheet - filled or unfilled. 

Availability 
Round rectangles are available for placement in both Schematic and Schematic Library Editors: 

Schematic Editor 
• Choose Place » Drawing Tools » Round Rectangle [P, D, O] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Schematic Library Editor 
• Choose Place » Round Rectangle [P, O] from the main menus 

• Click the  button on the Utility Tools drop-down of the Utilities toolbar 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter round rectangle placement mode. 
Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the first corner of the round rectangle 

• move the cursor to adjust the size of the round rectangle, then click or press Enter to anchor the diagonally-opposite corner 
and thereby complete placement of the rectangle. 

Continue placing further round rectangles, or right-click or press Esc to exit placement mode. 

The round rectangle object can be rotated or flipped while in placement mode and before the first corner of the rectangle is 
anchored: 
• Press the Spacebar to rotate the round rectangle. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the round rectangle along the X-axis or Y-axis respectively. 

Editing 
The properties of a round rectangle object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a round rectangle object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Round Rectangle dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives 
page of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the 
round rectangle object, which will be applied when placing subsequent round rectangles. 
During placement, the Round Rectangle dialog can be accessed by pressing the Tab key. 

After placement, the Round Rectangle dialog can be accessed in one of the following ways: 

• double-clicking on the placed round rectangle object 
• selecting the round rectangle object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed round rectangle object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed round rectangle object directly in the workspace and change its size, shape 
or location, graphically. 

When a rounded rectangle object is selected, the following editing handles are available: 

 

Click and drag A to resize the round rectangle in the vertical and horizontal directions separately. 

Click and drag B to resize the round rectangle in the vertical and horizontal directions simultaneously. 

Click and drag C to change the curvature of the corners. This affects all corners equally, regardless of which editing handle is 
chosen. 

Click anywhere on the round rectangle - away from editing handles - and drag to reposition it. The round rectangle can be 
rotated or flipped while dragging. 
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If you attempt to graphically modify a rounded rectangle object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Sheet Entry 

 

Description 
A sheet entry is an electrical design primitive that belongs within a sheet symbol. It is placed within a sheet symbol to designate 
input/output ports for the symbol. The sheet entries correspond to ports placed in the source schematic sub-sheet that the 
symbol represents. 

Availability 
Sheet entries are available for placement in the Schematic Editor only. Use one of the following methods to access the 
placement command: 
• choose Place » Add Sheet Entry [P, A] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter sheet entry placement mode. Placement 
is made by performing the following sequence of actions: 

• the sheet symbol is implicitly chosen by the position of the new sheet entry by the mouse on the schematic sheet (this sheet 
needs to have at least one sheet symbol). 

• move the cursor to adjust the position of the sheet entry in relation to any edge of the sheet symbol, then click or press 
Enter to anchor the sheet entry and complete placement. 

Continue placing further sheet entries, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a sheet entry object can be modified before, during and after placement. Editing itself falls into two categories 
- graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a sheet entry object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
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The Sheet Entry dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the sheet entry 
object, which will be applied when placing subsequent sheet entries. 
During placement, the Sheet Entry dialog can be accessed by pressing the Tab key. 

After placement, the Sheet Entry dialog can be accessed in one of the following ways: 

• double-clicking on the placed sheet entry object 
• selecting the sheet entry object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed sheet entry object.  

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed Sheet Entry object directly in the workspace and change its location 
graphically. The Sheet Symbol itself gets resized automatically when you attempt to move the existing Sheet Entry beyond the 
current extends of the symbol. To move an existing Sheet Entry (or a group of sheet entries) to a different Sheet Symbol, press 
the CTRL key while dragging the Sheet Entry. 

Sheet Entry colors help you identify whether you are making correct placement or not. If you move the Sheet Entry outside of a 
Sheet Symbol using the CTRL key, the Sheet Entry changes to a gray color to indicate incorrect Sheet Entry placement and you 
will not be able to place the Sheet Entry. A blue Sheet Entry indicates correct placement and you will be able to place the Sheet 
Entry. 

Sheet entries can only be adjusted with respect to their shape by changing their I/O Type (accessed through the Sheet Entry 
dialog). As such, editing handles are not available when the Sheet Entry object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the sheet entry within the sheet symbol as required. 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the sheet entry directly in the workspace. Select the sheet entry 
object and then click once to invoke the feature. Type the new name as required and then click away from the sheet entry object 
or press Enter to effect the change. 

Sheet Entry Actions 
Right-clicking over a placed sheet entry will pop-up a context-sensitive menu, from which a variety of commands are available 
that act on that sheet entry (or on all selected sheet entries where applicable). The following sections detail each of these 
commands. 
Note: Many of the following commands are also available from the Schematic Editor's main menus. Commands on the main 
menus apply to the selected sheet entry(ies) or allow you to choose the sheet entry on which the command will act, rather than 
just the sheet entry under the cursor. Where such commands exist, reference to their access is made. 
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Jumping to the Corresponding Port 
This command is used to jump to the chosen sheet entry's corresponding port on the sub-sheet referenced by that entry's 
parent sheet symbol. The command is accessed by right-clicking over the required sheet entry and choosing Sheet Entry 
Actions » Jump to Port PortName from the menu that appears. 

Toggling Sheet Entry I/O Type 
This command is used to toggle the I/O Type for the currently selected sheet entries, irrespective of sheet symbol to which they 
are associated, on the current schematic sheet. 

The command can be accessed either by: 
• choosing Edit » Move » Toggle Selected Sheet Entries IO Type from the main menus 

• right-clicking over the required sheet entry (or one sheet entry in a selection of sheet entries) and choosing Sheet Entry 
Actions » Toggle Selected Sheet Entries IO Type from the menu that appears. 

If you wish to toggle the I/O Type for the sheet entry under the cursor, use the second method of access, without prior selection. 
If you wish to toggle the I/O Type for multiple sheet entries, ensure they are first selected (in their respective sheet symbols) 
before launching the command. 

After launching the command, the I/O Type defined for each sheet entry in the selection will be toggled, where applicable. 

 

The actual change depends on the current I/O Type as follows: 
• Unspecified remains Unspecified 

• Output changes to Input 

• Input changes to Output 

• Bidirectional remains Bidirectional. 

Swapping Sheet Entry Side 
This command is used to relocate a selected sheet entry to the side 
of its parent sheet symbol that is directly opposite to its current 
position. The sheet entry's I/O Type is not changed by the swap. The 
command acts on all selected sheet entries, irrespective of sheet 
symbol to which they are associated, on the current schematic sheet. 

The command can be accessed either by: 
• choosing Edit » Move » Swap Selected Sheet Entries Side from 

the main menus 

• right-clicking over the required sheet entry (or one sheet entry in a 
selection of sheet entries) and choosing Sheet Entry Actions » Swap Selected Sheet Entries Side from the menu that 
appears. 

If you wish to swap sides for the sheet entry under the cursor, use the second method of access, without prior selection. If you 
wish to swap sides for multiple sheet entries, ensure they are first selected (in their respective sheet symbols) before launching 
the command. 

After launching the command, each sheet entry in the selection will be swapped to the opposite side of its sheet symbol. 

Reversing Sheet Entry Order 
This command allows you to reverse the order that selected sheet entries appear along a side of a parent sheet symbol. The I/O 
Type of a sheet entry is not changed by the reordering. 
The command can be accessed by choosing Edit » Move » Reverse Selected Sheet Entries Order from the Schematic 
Editor's main menus. 

Ensure that all sheet entries that you wish to reorder are selected prior to launching the command. Two or more sheet entries 
must be selected for a particular side of a sheet symbol in order for the command to have effect. You can simultaneously 
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reorder sheet entries along different sides of the same parent sheet symbol and across different sheet symbols on the active 
schematic sheet. 

After launching the command, the reordering will take place. The reordering is achieved by mirroring the positions of the 
selected sheet entries - along a particular sheet symbol side - about an imaginary line at the mid point of the distance between 
the extents of the two most-outer selected sheet entries. 

The following image shows reordering for two selected sheet entries - whereby they exchange positions. 

 

The next image shows reordering for four selected sheet entries. The position of the center line used for the reordering is 
indicated to better show the mirroring effect on their pre- and post- reordering positions. 

 

Notes 
Different arrow kinds or shapes can be defined for the sheet entries. The following arrow kinds are; 
Arrow: Display as an arrow. The direction of the arrow is dependent on the I/O type setting. 

Triangle: Display as a triangle. The direction of the triangle is dependent on the I/O type setting. 

Block & Triangle: Display as a standard entry symbol. The direction of the entry is dependent on the I/O type setting. 

 

When a Sheet Entry is connected to a Signal Harness, the Sheet Entry becomes a Harness object. By default, the Sheet Entry 
will change color to match the color of the Signal Harness. Disable the option, Sheet Entries and Ports use Harness Color in 
Schematic – Graphical Editing page of the Preferences dialog to specify your own color for Sheet Entries or to use the default 
color. 

 

When a Sheet Entry is connected to a Harness Connector by a Signal Harness, the Harness Type in the Sheet Entry dialog is 
automatically populated with the Harness Type of the Harness Connector. When a Sheet Entry is connected to a Port by a 
Signal Harness and the Port has a Harness Type declared, the Sheet Entry will become a Harness object and change to the 
color of the Signal Harness. If you move the Sheet Entry away from the Harness Connector and the Harness Type field is not 
populated, the Sheet Entry will revert back to the default color. 

 

Should you need to negate (include a bar over the top of) a sheet entry name, this can be done in one of two ways: 
• Include a backslash character after each character in the name (e.g. E\N\A\B\L\E\) 

• Enable the Single '\' Negation option on the Schematic - Graphical Editing page of the Preferences dialog, then include 
one backslash character at the start of the name (e.g. \ENABLE). 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 143 

 

When instantiating multiple channels from the same sheet symbol, certain signals are repeated and sent individually to each 
instantiated channel. With respect to a sheet entry, a signal is repeated by using the Repeat keyword in the sheet entry's name 
(e.g. Repeat(Headphone)) as illustrated in the example image below: 

 

The sheet entry is wired to a bus, which in turn carries the individual signals to their correspondingly instantiated destinations. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 

 

If you attempt to graphically modify a sheet entry object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Sheet Symbol 

 

Description 
A sheet symbol is an electrical design primitive. It is used to represent a sub-sheet in a multi-sheet hierarchical design. Sheet 
symbols include sheet entry symbols, which provide a connection point for signals between the parent and child sheets, similar 
to the way that Ports provide connections between sheets in a flat-sheet design. 

Availability 
Sheet symbols are available for placement in the Schematic Editor only. Use one of the following methods to access the 
placement command: 
• choose Place » Sheet Symbol [P, S] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter sheet symbol placement mode. 
Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the top-left corner of the sheet symbol 

• move the cursor to adjust the size of the sheet symbol, then click or press Enter to anchor the diagonally-opposite corner 
and thereby complete placement of the sheet symbol. 

Continue to place other sheet symbols, or right-click or press Esc to exit placement mode. 

Editing 
The properties of a sheet symbol object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a sheet symbol object. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 
The Sheet Symbol dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of 
the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the sheet 
symbol object, which will be applied when placing subsequent sheet symbols.  
During placement, the Sheet Symbol dialog can be accessed by pressing the Tab key. 

After placement, the Sheet Symbol dialog can be accessed in 
one of the following ways: 

• double-clicking on the placed sheet symbol object 

• selecting the sheet symbol object and choosing 
Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and 
then clicking once over the placed sheet symbol object. 

The sheet symbol Designator and Filename text fields can 
be formatted independently of the sheet symbol itself. The 
corresponding properties dialogs for each - the Sheet Symbol 
Designator and Sheet Symbol File Name dialogs respectively 
- can be accessed using the three methods described above 
(replacing sheet symbol with the relevant object whose 
properties you wish to view/modify). 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a placed sheet symbol object directly in the workspace and change its size, shape or 
location, graphically. 

When a sheet symbol object is selected, the following editing handles are available: 

 

Click and drag A to resize the sheet symbol in the vertical and horizontal directions separately. 

Click and drag B to resize the sheet symbol in the vertical and horizontal directions simultaneously. 

Resizing the sheet symbol will not affect the absolute positions of any defined sheet entries within. 

Click anywhere on the sheet symbol - away from editing handles - and drag to reposition it. 

The sheet symbol's Designator and Filename text fields can only be adjusted with respect to their size by changing the size of 
the font used (accessed through the Sheet Symbol Designator and Sheet Symbol File Name dialogs, respectively). As such, 
editing handles are not available when either of these objects are selected: 

 

Click anywhere inside the dashed box and drag to reposition the text object as required. The object can be rotated or flipped 
while dragging: 
• Press the Spacebar to rotate the text. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the text along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the Designator or File Name directly in the workspace. Select the 
text object and then click once to invoke the feature. Type the new name as required and then click away from the text object or 
press Enter to effect the change. 

Sheet Symbol Actions 
Right-clicking over a placed sheet symbol will pop-up a context-sensitive menu, from which a variety of commands are available 
that act on that sheet symbol (or on all selected sheet symbols where applicable). The following sections detail each of these 
commands. 
Note: Many of the following commands are also available from the Schematic Editor's main menus. Commands on the main 
menus apply to the selected sheet symbol(s) or allow you to choose the sheet symbol on which the command will act, rather 
than just the sheet symbol under the cursor. Where such commands exist, reference to their access is made. 

Opening a Selected Sheet Symbol's Sub-Sheet 
This command applies only to the sheet symbol under the cursor and is accessed by right-clicking and choosing Sheet Symbol 
Actions » Open SubSheet "SheetName.SchDoc" from the menu that appears. 

The child sheet for the symbol will be opened (if not already) and made the active document in the main design window. 

Creating a Schematic Sheet directly from a Sheet Symbol 
This command is used to create a new schematic document from a sheet symbol and add ports to that document corresponding 
to each of the sheet entries on the symbol. In this way, you can automatically create the sub-sheets for a multi-sheet schematic 
design, based on the sheet symbols you have created and placed on the top sheet. 

The command can be accessed either by: 
• choosing Design » Create Sheet From Symbol from the main menus. You will be prompted to choose a sheet symbol 

• right-clicking over the required sheet symbol and choosing Sheet Symbol Actions » Create Sheet From Symbol from the 
menu that appears. 
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After launching the command (and choosing the sheet symbol if applicable), a dialog will appear asking whether you wish to 
reverse input/output directions. This option changes the electrical type for a port on the newly created sheet to be the opposite 
of that for the corresponding sheet entry that it represents. Choose Yes or No as required - the schematic document will be 
created and opened as the active document. The matching ports for the sheet entries on the symbol will be located in the 
bottom left-hand corner of the new document. 
The schematic document that is created is named using the entry in the sheet symbol's Filename field. You can either enter the 
intended name for the document in this field before launching the command, complete with extension (i.e. 
DocumentName.SchDoc), or leave the name blank and enter the name when saving the generated document at a later stage. 

Care should be taken when creating a sheet from a sheet symbol and a sheet with that filename already exists. A new sheet 
with the same filename will be created. The duplication can be resolved when saving, by either saving the new sheet with a 
different name, or overwriting the existing sheet if required. 

Creating a VHDL File directly from a Sheet Symbol 
This command is used to create a new VHDL document (*.Vhd) from a placed sheet symbol on the current schematic 
document. 

The command can be accessed either by: 
• choosing Design » Create HDL File From Symbol » Create VHDL File From Symbol from the main menus. You will be 

prompted to choose a sheet symbol 
• right-clicking over the required sheet symbol and choosing Sheet Symbol Actions » Create VHDL File From Symbol from 

the menu that appears. 

After launching the command (and choosing the sheet symbol if applicable), the VHDL document will be created and opened as 
the active document. The sheet entries on the symbol will be included as declared ports in the document's entity definition. 

The template for the architecture will be defined, but the component and signal declarations are left ready for you to code in. 
The VHDL document is named using the entry in the sheet symbol's Filename field. This entry is also used as the name for the 
document's entity. 

 

Creating a Verilog File directly from a Sheet Symbol 
This command is used to create a new Verilog document (*.V) from a placed sheet symbol on the current schematic document. 

The command can be accessed either by: 
• choosing Design » Create HDL File From Symbol » Create Verilog File From Symbol from the main menus. You will be 

prompted to choose a sheet symbol 
• right-clicking over the required sheet symbol and choosing Sheet Symbol Actions » Create Verilog File From Symbol 

from the menu that appears. 
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After launching the command (and choosing the sheet symbol if applicable), the Verilog document will be created and opened 
as the active document. The sheet entries on the symbol will be included in the document's module definition. 
The Verilog document is named using the entry in the sheet symbol's Filename field. This entry is also used as the name for the 
document's module. 

 

Renaming a Sheet Symbol's Child Sheet 
This command provides a quick and efficient facility for renaming the child schematic sheet referenced by a selected sheet 
symbol. 

The command can be accessed either by: 
• choosing Design » Rename Child Sheet from the main menus. You will be prompted to choose a sheet symbol 

• right-clicking over the required sheet symbol and choosing Sheet Symbol Actions » Rename Child Sheet from the menu 
that appears. 

After launching the command (and choosing the sheet symbol if applicable), the Rename Child Sheet dialog will appear. 
Initially, the New child sheet file name field will contain 
the current name for the document. Type the new name for 
the document as required - ensuring that the .SCHDOC 
extension remains. 
The Rename Mode region of the dialog allows you to 
determine how the renaming should proceed. The first two 
options, as their names suggest, rename the child sheet. 
The options differ in the scope of the update with respect 
to the sheet symbols that point to this sheet - either in the 
active project or across all projects in the active design 
workspace. In each case, the Filename field for the sheet 
symbol will be updated to reflect the newly named child 
sheet. 

The third option takes a copy of the child sheet before 
renaming the original. Only the current sheet symbol is updated using this option. This is useful when the current child sheet is 
referenced by multiple sheet symbols, and one sheet symbol needs to reference a modified version of the circuitry contained on 
that sheet. You still want to keep the original sheet - you are creating a renamed copy of this sheet with which to point to from a 
single sheet symbol. You can then modify the content of the sheet as required. 
Enabling the Compile project(s) after rename option will ensure that the newly named child sheet is correctly inserted into the 
design hierarchy, which will be reflected on the Projects panel. 
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Example 
Consider the three sheet symbols in the adjacent image, each one pointing to the DigitHolder.SchDoc sub-sheet. 

 
Consider now that the middle symbol is required to point to a slightly modified version of the underlying schematic. The canvas 
for the modified sheet can be quickly generated and this sheet symbol made to point to it, by using the Rename Child Sheet 
feature, and selecting the third option - to copy the original sheet and update only the current sheet symbol. 

 

After defining the required rename options, clicking OK will proceed with the rename, updating the sheet symbol's Filename 
field to point to the newly named document. 
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As can be seen in the image and the image below, the original schematic document has not been deleted and the other sheet 
symbols still point to it. The copy of the original document - renamed to DigitHolder(Modified).SchDoc - is referenced 
only by the intended sheet symbol. The Projects panel is updated to reflect the two child sheets that are accessed by sheet 
symbols on the parent sheet. 

 

Synchronizing Sheet Entries and Ports 
The Schematic Editor provides a facility for maintaining synchronization between the sheet entries on a sheet symbol and the 
corresponding ports on the referenced child sheet below. Two commands are used to implement this facility, differing only in 
their scope. 

Synchronization for Current Sheet Symbol 
Allows you to synchronize the sheet entries and sub-sheet ports for the sheet symbol currently under the cursor. The command 
can be accessed by right-clicking over the required sheet symbol and choosing Sheet Symbol Actions » Update ports and 
sheet entries on the chosen sheet symbol from the menu that appears. 

After launching the command, the Synchronize Ports To Sheet Entries On SheetSymbolDesignator dialog will appear: 

 

This incarnation of the Synchronize dialog includes a single tab for the sheet symbol under the cursor. 

Synchronization for all Sheet Symbols 
Allows you to synchronize the sheet entries and sub-sheet ports for each sheet symbol in the active design project. The 
command can be accessed by choosing Design » Synchronize Sheet Entries And Ports from the main menus. 

After launching the command, the Synchronize Ports To Sheet Entries In ActiveProjectName dialog will appear: 
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This incarnation of the Synchronize dialog includes a separate tab for each sheet symbol found in the project. The ordering of 
the tabs depends on the order in which documents have been added to the project and the order in which sheet symbols were 
added to each document. 

Using the Dialog 
The aim, when using the Synchronize dialog, is to ensure that all sheet entries on a sheet symbol are matched to ports on the 
referenced child sheet both in terms of name and I/O Type. The left-hand side of the dialog provides two regions: 

• one listing all currently unmatched sheet entries associated to the chosen sheet symbol. The Designator of the sheet symbol 
appears as the header for the region. Each sheet entry in this region is listed in terms of its Designator and I/O Type 

• one listing all currently unmatched ports on the schematic sheet referenced by the sheet symbol. The document name 
appears as the header for the region. Each port entry in this region is listed in terms of its Name and I/O Type. 

The right-hand side of the dialog lists all currently linked (or matched) sheet entry-port pairings. Each entry shows the common 
name used by both the sheet entry as its Designator and the port as its Name. The IO column shows the current I/O Type set 
for each pairing. Both name and I/O Type can be modified from this dialog - click on the required field entry and enter the new 
name/choose the required I/O Type. Any modification will be passed 
immediately to both the sheet entry and port. 

The simplest way to explain the workings of the dialog, in terms of 
matching sheet entries with ports, is to use an underlying example. 
Consider the sheet symbol and corresponding ports in the image to the 
right. 

Each sheet entry in the symbol corresponds, both in name and I/O Type, 
to a port in the referenced schematic sub-sheet. Accessing the 
Synchronize dialog for this sheet symbol, there are no unmatched 
entries. 

 

Now consider the same sheet symbol, but with a few intentional changes made within the design, as listed below and 
summarized in the following image: 
• sheet entry designator changed to G[4..0] 
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• sheet entry designator changed to R[4..0] and I/O Type changed to Output 

• extra sheet entry added, with designator B and I/O Type Input 

• sheet entry for ENABLE removed 

• port name changed to GR[4..0] 

 

This time when the Synchronize dialog is accessed, the changes introduced cause links between sheet entries and ports to be 
broken and the unmatched lists become populated. 

 

The two unmatched regions must now be used to resolve the current unsynchronized state that exists between the sheet entries 
of the symbol and the ports of the sub-sheet. Below each region are two buttons, the use of which will involve making one or 
more of the following matching decisions: 
• If there are sheet entries that you no longer require, select each (use Ctrl+click, Shift+click or click-and-drag for multi-select) 

and click the Delete Sheet Entries button. Each sheet entry in the selection will be removed from the sheet symbol. 

• If there are ports that you no longer require, select each and click the Delete Ports button. Each port in the selection will be 
removed from the child sheet. 

• If there are existing sheet entries that you need to keep but no corresponding ports for these entries, you can automatically 
create ports with the same names and I/O Types by selecting each sheet entry and clicking the Add Ports button. You will 
be taken to the child sheet, with the port(s) floating on the cursor ready for initial placement. Click or press Enter to place the 
port(s). The Synchronize dialog will reappear, with an entry for each sheet entry-port pairing automatically entered into the 
Links region of the dialog. 

• If there are existing ports that you need to keep but no corresponding sheet entries for these ports, you can automatically 
create sheet entries with the same names and I/O Types by selecting each port and clicking the Add Sheet Entries button. 
You will be taken to the sheet symbol, with the sheet entry(ies) floating on the cursor ready for initial placement. Click or 
press Enter to place the sheet entry(ies). The Synchronize dialog will reappear, with an entry for each sheet entry-port 
pairing automatically entered into the Links region of the dialog. 

All other residual unmatched entries will either be due to name or I/O Type mismatching. For these, manual matching can be 
carried out. This is done by selecting a sheet entry in one region and a port in the other and then using one of the following two 
buttons to determine which name and I/O Type attributes are used when linking: 

 - Use this button to link the selected sheet entry with the selected port, using the name and I/O Type defined for the 
sheet entry. The port will be renamed and/or its I/O type changed. 

 - Use this button to link the selected sheet entry with the selected port, using the name and I/O Type defined for the 
port. The sheet entry will be renamed and/or its I/O type changed. 
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If the name or I/O Type is not as you require, remember that these can be changed from the Synchronize dialog, after the 
unmatched entries have been linked. 

If you want to break up a linked entry, select it in the Links region of the dialog and click on the  button. 

The actual process of matching will vary from sheet symbol to sheet symbol, depending on the discrepancies involved and your 
preferred matching techniques. Considering the point reached with the underlying example: 

 

the sheet entries and ports could be quite easily matched and re-synchronized back to their original states by performing the 
following actions: 
• Selecting the entry for port ENABLE and clicking the Add Sheet Entries button 

• Selecting the entry for sheet entry B and clicking the Delete Sheet Entries button 

• Selecting the entries for sheet entry R[4..0] and port RED[4..0] and clicking the  button 

• Selecting the entries for sheet entry G[4..0] and port GR[4..0] and clicking the  button This keeps the I/O Type 
setting of Input, as required. Then, once linked, change the name to GREEN[4..0] in the Links region of the dialog 

The approach to matching is not set in stone - the tools are provided to allow you to match as quickly and as efficiently as 
possible. For example, the first two actions in the list above could be achieved by a single, alternative action - to select the 
entries for sheet entry B and port ENABLE and click on the  button. 

Flipping Selected Sheet Symbols along the X-Axis 
This command allows you to flip selected sheet symbols along the X-axis. 

The command can be accessed either by: 
• selecting the required symbols and choosing Edit » Move » Flip Selected Sheet Symbols Along X from the main menus 

• right-clicking over the required sheet symbol (or a symbol in a selected group of symbols) and choosing Sheet Symbol 
Actions » Flip Selected Sheet Symbols Along X from the menu that appears. 

After launching the command the selected sheet symbols will be flipped. The sheet entries associated with a symbol will 
essentially be swapped to the opposite side of the symbol (in the horizontal plane) - those on the left will be repositioned on the 
right and vice-versa. 

 

Note: When flipping multiple selected sheet symbols, the symbols will be flipped about an imaginary vertical line which is 
located mid-way between the bounding extents of the symbols in the selection. 

Flipping Selected Sheet Symbols along the Y-Axis 
This command allows you to flip selected sheet symbols along the Y-axis. 

The command can be accessed either by: 
• selecting the required symbols and choosing Edit » Move » Flip Selected Sheet Symbols Along Y from the main menus 

• right-clicking over the required sheet symbol (or a symbol in a selected group of symbols) and choosing Sheet Symbol 
Actions » Flip Selected Sheet Symbols Along Y from the menu that appears. 

After launching the command the selected sheet symbols will be flipped. The sheet entries associated with a symbol will 
essentially be swapped to the opposite side of the symbol (in the vertical plane) - those at the top will be repositioned at the 
bottom and vice-versa. 
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Note: When flipping multiple selected sheet symbols, the symbols will be flipped about an imaginary horizontal line which is 
located mid-way between the bounding extents of the symbols in the selection. 

Toggling Sheet Entry IO Type in a Selected Sheet Symbol 
This command allows you to toggle the I/O Type for all sheet entries in all selected sheet symbols, simultaneously. 

The command can be accessed either by: 
• selecting the required symbols and choosing Edit » Move » Toggle All Sheet Entries IO Type In Selected Sheet Symbol 

from the main menus 
• right-clicking over the required sheet symbol (or a symbol in a selected group of symbols) and choosing Sheet Symbol 

Actions » Toggle All Sheet Entries IO Type In Selected Sheet Symbol from the menu that appears. 

After launching the command, the I/O Type defined for each sheet entry will be toggled, where applicable. 

 

The actual change depends on the current I/O Type as follows: 
• Unspecified remains Unspecified 

• Output changes to Input 

• Input changes to Output 

• Bidirectional remains Bidirectional. 

Notes 
The Filename property of the sheet symbol, set on the Properties tab of the Sheet Symbol dialog, must be set to the file name 
of the schematic sheet that the symbol represents. 

 

If a group of sheet entries is pasted into a selected sheet symbol and those entries fall outside the current bounds of the symbol, 
it will automatically be resized to accommodate them. 

 

By using sheet symbol instantiation, multiple channels on the same sub-sheet can be referenced from a single sheet symbol. 
The syntax used involves the use of the Repeat keyword in the sheet symbol's Designator field and takes the form: 
Repeat(SheetSymbolDesignator, FirstInstance, LastInstance), 

where SheetSymbolDesignator is the base name for the sheet symbol and FirstInstance and LastInstance together 
define the number of channels to be instantiated. The FirstInstance parameter must start at a value of one (1) onwards. 
The following example image illustrates the use of the Repeat keyword to instantiate 8 input channels for an audio mixer. 
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When the project is built, the Compiler instantiates the channel the required number of times as it builds the internal compiled 
model, using a chosen annotation scheme to uniquely identify each component in each channel. The channel sub-sheet is not 
duplicated. Instead, once compiled, a Compiled Document Tabs appear at the bottom of the sub-sheet document in the main 
design window for each channel on that sheet, as shown in the example image below. 

 

 

Multiple sub-sheets may be referenced by a single sheet symbol. Separate each filename by a semi-colon in the Filename field. 
With the effective use of off-sheet connectors placed on the sub-sheets, you can effectively spread a section of your design over 
multiple sheets, treated as though they were one giant (flat) sheet. Note however, that use of off-sheet connectors is only 
possible for sheets referenced by the same sheet symbol. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 

 

If you attempt to graphically modify a sheet symbol object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Sheet Symbol Designator 

 

Description 
The sheet symbol designator is a non-electrical child object of an electrical design primitive. It is used to provide a sheet symbol 
with a meaningful name that will distinguish it from other sheet symbols placed on the same schematic sheet. Typically the 
name will reflect the overall function of the schematic sub-sheet that the symbol represents. 

Availability and Placement 
The sheet symbol designator is automatically placed when the parent sheet symbol object is placed. As such, it is not a design 
object that can be accessed and placed by the user. 

Editing 
The properties of a sheet symbol designator object can be modified before and after placement of the parent sheet symbol. 
Editing itself falls into two categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a sheet 
symbol designator object, independently of the parent sheet symbol object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of 
the options available. Click on the question mark button at the top right of the dialog and 
then click over a field or option to pop-up information specific to that field or option. 

The Sheet Symbol Designator dialog can be accessed prior to entering sheet symbol 
placement mode, from the Schematic - Default Primitives page of the Preferences 
dialog (Tools » Schematic Preferences). This allows you to change the default 
properties for the sheet symbol designator object, which will be applied when placing 
subsequent sheet symbols. 

After placement, the Sheet Symbol Designator dialog can be accessed in one of the 
following ways: 

• double-clicking on the designator field of the placed sheet symbol object 
• selecting the designator field of the sheet symbol object and choosing Properties 

from the right-click pop-up menu 
• choosing the Change command from the Edit menu and then clicking once over the designator field of the placed sheet 

symbol object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a sheet symbol designator object directly in the workspace and change its location 
graphically. Sheet symbol designators can only be adjusted with respect to their size by changing the size of the font used 
(accessed through the Sheet Symbol Designator dialog). As such, editing handles are not available when the sheet symbol 
designator object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the sheet symbol designator object as required. The object can be 
rotated or flipped while dragging: 
• Press the Spacebar to rotate the designator. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the designator along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the name for the sheet symbol designator directly in the workspace. Select the 
designator and then click once to invoke the feature. Type the new name as required and then click away from the designator 
field or press Enter to effect the change. 

Notes 
By using sheet symbol instantiation, multiple channels on the same sub-sheet can be referenced from a single sheet symbol. 
The syntax used involves the use of the Repeat keyword in the sheet symbol's Designator field and takes the form: 
Repeat(SheetSymbolDesignator, FirstInstance, LastInstance), 

where SheetSymbolDesignator is the base name for the sheet symbol and 
FirstInstance and LastInstance together define the number of channels to be 
instantiated. The FirstInstance parameter should start at 1 or greater. The example 
image below illustrates the use of the Repeat keyword to instantiate 8 input channels for 
an audio mixer. 

When the project is built, the Compiler instantiates the channel the required number of 
times as it builds the internal compiled model, using a chosen annotation scheme to 
uniquely identify each component in each channel. The channel sub-sheet is not 
duplicated. Instead, once compiled, a separate tab appears at the bottom of the sub-
sheet document in the main design window, for each channel on that sheet, as shown in 
the example image below. 

 

 

Any changes made to the Designator field during sheet symbol placement will cause the default properties for the sheet symbol 
designator object to be updated, unless the Permanent option - on the Schematic - Default Primitives page of the 
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Preferences dialog - is enabled. When this option is enabled, changes made will affect only the designator of the sheet symbol 
object being placed and subsequent sheet symbol objects placed during the same placement session. 
If you attempt to graphically modify a sheet symbol designator object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 
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Sheet Symbol Filename 

 

Description 
The sheet symbol filename is a non-electrical child object of an electrical design primitive. It provides the link between the sheet 
symbol and the schematic sub-sheet that the symbol represents. 

Availability and Placement 
The sheet symbol filename is automatically placed when the parent sheet symbol object is placed. As such, it is not a design 
object that can be accessed and placed by the user. 

Editing 
The properties of a sheet symbol filename object can be modified before and after placement of the parent sheet symbol. 
Editing itself falls into two categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a sheet 
symbol filename object, independently of the parent sheet symbol object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of 
the options available. Click on the question mark button at the top right of the dialog 
and then click over a field or option to pop-up information specific to that field or option. 

The Sheet Symbol File Name dialog can be accessed prior to entering sheet symbol 
placement mode, from the Schematic - Default Primitives page of the Preferences 
dialog (Tools » Schematic Preferences). This allows you to change the default 
properties for the sheet symbol filename object, which will be applied when placing 
subsequent sheet symbols. 

After placement, the Sheet Symbol File Name dialog can be accessed in one of the 
following ways: 

• double-clicking on the filename field of the placed sheet symbol object 
• selecting the filename field of the sheet symbol object and choosing Properties 

from the right-click pop-up menu 
• choosing the Change command from the Edit menu and then clicking once over 

the filename field of the placed sheet symbol object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 
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For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a sheet symbol filename object directly in the workspace and change its location 
graphically. Sheet symbol filenames can only be adjusted with respect to their size by changing the size of the font used 
(accessed through the Sheet Symbol File Name dialog). As such, editing handles are not available when the sheet symbol 
filename object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the sheet symbol filename object as required. The object can be 
rotated or flipped while dragging: 
• Press the Spacebar to rotate the filename. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the filename along the X-axis or Y-axis respectively. 

If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the entry for the sheet symbol filename directly in the workspace. Select the 
filename field and then click once to invoke the feature. Type the new entry as required and then click away from the filename 
field or press Enter to effect the change. 

If you attempt to graphically modify a sheet symbol filename object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
The Filename property of the sheet symbol, which can also be set on the Properties tab of the Sheet Symbol dialog, must be 
set to the file name of the schematic sub-sheet that the symbol represents. 

 

Multiple sub-sheets may be referenced by a single sheet symbol. Separate each filename by a semi-colon, in the Filename 
field. With the effective use of off-sheet connectors, placed on the sub-sheets, you can effectively spread a section of your 
design over multiple sheets, treated as though they were one giant (flat) sheet. Note however, that use of off-sheet connectors 
is only possible for sheets referenced by the same sheet symbol. 

 

Any changes made to the Filename field during sheet symbol placement will cause the default properties for the sheet symbol 
filename object to be updated, unless the Permanent option - on the Schematic - Default Primitives page of the Preferences 
dialog - is enabled. When this option is enabled, changes made will affect only the filename field of the sheet symbol object 
being placed and subsequent sheet symbol objects placed during the same placement session. 
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Signal Harness 

 

Description 
A Signal Harness is an electrical design primitive. It is an abstract connection which combines different signals. 

Availability 
Signal Harnesses are available for placement in the Schematic Editor only. Use one of the following methods to access the 
placement command: 
• choose Place » Harness » Signal Harness [P, H, H] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter Signal Harness placement mode. 
Placement is made by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the Signal Harness 

• position the cursor and click or press Enter to anchor a series of vertex points that define the shape of the signal harness 

• after placing the final vertex point, right-click or press Esc to complete placement of the Signal Harness. 

Continue placing further Signal Harness objects, or right-click or press Esc to exit placement mode. 

Use the Backspace or Delete keys to remove the last Signal Harness segment placed. 

Guided wiring of a Signal Harness 
Schematics have a definable electrical grid that makes it easy to define electrical connections between objects. As you are 
placing a Signal Harness, when the Signal Harness falls within the electrical grid range of another electrical object the cursor will 
snap to the fixed object and a Hot Spot (red cross) will appear. 

 
The Hot Spot guides you to where a valid connection can be made and automatically snaps the cursor to electrical connection 
points. 
The electrical grid can be defined on the Sheet Options tab of the Document Options dialog (Design » Document Options). It 
is recommended that you set the electrical grid to be slightly smaller than the current snap grid, or it becomes difficult to position 
electrical objects one snap grid apart. 

Editing 
The properties of a Signal Harness object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 
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The following three methods of non-graphical editing are available:  

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a Signal Harness object. 

 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. 

Editing Vertices 
The Signal Harness dialog provides a Vertices tab, from where you can edit the individual vertices of the currently selected 
Signal Harness object as required. 

 
The main region of the tab lists all of the vertex points currently defined for the Signal Harness. You can add new vertices to the 
Signal Harness, edit the coordinates of existing vertices, or remove selected vertices altogether. 
Click the Menu button or right-click within the main list region to access a pop-up menu containing the following commands: 

• Edit - right click on a coordinate cell (X or Y) for a vertex and use this command to edit the value in that cell. Alternatively, 
click directly on the cell 

• Add - use this command to add a new vertex point. The new vertex will be added below the currently focused vertex entry 
(as distinguished by a dotted outline around a cell in its row) and will initially have the same coordinates as the focused entry 

• Remove - use this command to remove the currently selected vertex entries in the list. This command will be unavailable if 
there are only two vertices present for the wire 

• Copy - use this command to copy the content of the selected cells in the list to the clipboard (alternatively use Ctrl+C) 

• Paste - use this command to paste the content of the clipboard into the list, starting at the selected cell (alternatively use 
Ctrl+V) 

• Select All - use this command to quickly select the entire grid contents of the list 

• Select Column - use this command to quickly select the entire column in which the currently focused cell resides 

• Move Up - use this command to move the selected vertex upward in the list 

• Move Down - use this command to move the selected vertex downward in the list 
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• Move Signal Harness By XY - use this command to move the entire signal harness object. The Move Signal Harness By 
dialog will appear, from where you can enter the increment value to be applied to each vertex point's X and Y coordinates. 

Dialog access 
The Signal Harness dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page 
of the Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the signal 
harness object, which will be applied when placing subsequent signal harnesses. 
During placement, the Signal Harness dialog can be accessed by pressing the Tab key. 

After placement, the Signal Harness dialog can be accessed in one of the following ways: 

• double-clicking on the placed Signal Harness object 
• selecting the Signal Harness object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed Signal Harness object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed Signal Harness object directly in the workspace and change its size and/or 
shape, graphically. 

When a Signal Harness object is selected, the following editing handles are available: 

 

Click and drag A to reposition the end points of the Signal Harness. 

Click and drag B to move a vertex. The end points will remain anchored. 

Click and drag near the center of a Signal Harness segment to "grab" that segment and reposition it. The end points and other 
vertices will remain anchored. 

With the Signal Harness selected, click on a vertex or segment to individually select that vertex or segment. This Signal Harness 
'sub-selection' is distinguished by the associated editing handles becoming red in color. 
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 Individual vertex sub-selection. 

 Individual segment sub-selection. 

The associated vertex (or vertices for a segment) can then be edited directly using the SCH Inspector or SCH List panels, with 
any changes appearing immediately on the schematic. 
If you attempt to graphically modify a signal harness object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Please refer to the Using Signal Harnesses document for more information on how to use Signal Harnesses. 

Notes 
When placing a Signal Harness, various placement modes are available: 90 Degree, 45 Degree, Any Angle and Auto Wire. The 
mode specifies how corners are created when placing wires and the angles at which wires can be placed. The 90 Degree and 
45 Degree modes (true orthogonal modes) both have Start and End sub-modes. 

 

When placing a Signal Harness, press Shift+Spacebar to cycle through the wire placement modes. Press Spacebar to toggle 
between the Start and End sub-modes (when in 90 Degree or 45 Degree modes), or between Any Angle and Auto Wire modes 
(when either of these modes is active). The current placement mode is displayed in the status bar. You can change modes at 
any time during Signal Harness placement. 

In all modes other than Any Angle, the Signal Harness segment attached to the cursor is a "look ahead" segment. The segment 
you are actually placing precedes this look ahead segment. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Text Frame 

 

Description 
A text frame is a non-electrical drawing primitive. It is used to define an area on a schematic to contain textual information. The 
frame is a resizable rectangular area that can contain multiple lines of text and can automatically wrap and clip text to keep it 
within the bounds of the frame. 

Availability 
Text frames are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Text Frame [P, F] from the Schematic Editor main menus 

• click the  button on the Utility Tools drop-down of the Utilities toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter text frame placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the first corner of the text frame 

• move the cursor to adjust the size of the text frame, then click or press Enter to anchor the diagonally-opposite corner and 
thereby complete placement of the text frame. 

Continue placing further text frames, or right-click or press Esc to exit placement mode. 

The text frame object can be rotated or flipped while in placement mode and before the first corner of the frame is anchored: 
• Press the Spacebar to rotate the text frame. Rotation is anti-clockwise and in steps of 90°. 

• Press the X or Y keys to flip the text frame along the X-axis or Y-axis respectively. 

Editing 
The properties of a text frame object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a text frame object. 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click 
over a field or option to pop-up information specific to that field or 
option. 

The Text Frame dialog can be accessed prior to entering 
placement mode, from the Schematic - Default Primitives page 
of the Preferences dialog (Tools » Schematic Preferences). This 
allows you to change the default properties for the text frame 
object, which will be applied when placing subsequent text frames. 

During placement, the Text Frame dialog can be accessed by 
pressing the Tab key. 

After placement, the Text Frame dialog can be accessed in one of 
the following ways: 



 TR0111 Schematic Editor and Object Reference 

 

Version (v1.9) Aug 6,2008 166 

• double-clicking on the placed text frame object 
• selecting the text frame object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed text frame object. 

The actual text of the frame can be entered/edited via the Text 
Frame dialog. Press the Change button associated with the 
frame's Text property to access the TextFrame Text dialog. 

In addition to providing a Word Wrap option, the main Text 
Frame dialog provides a Clip to Area option. With this option 
enabled, text will be kept within the bounds of the frame. When 
disabled, text will spill out of the frame onto the schematic sheet. 

For example, consider the text frame in the previous image. Both 
Word Wrap and Clip to Area options were enabled. If word 
wrapping is disabled, leaving only the clipping option enabled, 
only text that fits within the text frame will remain displayed: 

 

However, if the option to clip the text is disabled, the text is free to be displayed beyond the constraints of the frame's boundary: 

 

In-Place Editing 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the 
Preferences dialog (Tools » Schematic Preferences), you will be able to edit the textual 
content of the text frame directly in the workspace. Select the text frame and then click once to 
invoke the feature. 

Make changes to the text as required. The available right-click menu provides standard editing 
commands such as cut, copy, paste and delete. 

To effect a change either click away from the text frame or press the green tick button to effect 
the change. If you decide the change made is not needed, press the red cross button to discard 
the change. 
If the Word Wrap option is disabled in the Text Frame dialog, a horizontal scroll bar will also be 
available when editing the text in-situ. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more 
design objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to 
multiple objects of the same kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 
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Graphical editing 
This method of editing allows you to select a placed text frame object directly in the workspace and change its size, shape or 
location, graphically. 

When a text frame object is selected, the following editing handles are available: 

 

Click and drag A to resize the text frame in the vertical and horizontal directions simultaneously. 

Click and drag B to resize the text frame in the vertical and horizontal directions separately. 

Click anywhere on the text frame - away from editing handles - and drag to reposition it. The text frame can be rotated or flipped 
while dragging. 
If you attempt to graphically modify a text frame object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
While text frames can be rotated or flipped along the x or y axis, this has no effect on the orientation of the text. 

 

For simple one line text annotations, use the Text String object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Text String 

 

Description 
A text string (also referred to as an annotation) is a non-electrical drawing primitive. It is a single line of free text that can be 
placed on a schematic sheet. Uses might include section headings, revision history, timing information or some other descriptive 
or instructive text. 

Availability 
Text strings are available for placement in both Schematic and Schematic Library Editors by: 
• Choosing Place » Text String [P, T] from the main menus 

• Clicking the  button on the Utility Tools drop-down of the Utilities toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter text string placement mode. Position the 
cursor on the sheet and click or press Enter to effect placement of the string. 

Continue placing further text strings or right-click or press Esc to exit placement mode. 

Press the Spacebar while in placement mode to rotate the text string. Rotation is anti-clockwise and in steps of 90°. 

Press the X or Y keys while in placement mode to flip the text string along the X-axis or Y-axis respectively. 

Editing 
The properties of a text string object can be modified before, during and after 
placement. Editing itself falls into two categories - graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a text string 
object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of 
the options available. Click on the question mark button at the top right of the dialog 
and then click over a field or option to pop-up information specific to that field or 
option. 

The Annotation dialog can be accessed prior to entering placement mode, from the 
Schematic - Default Primitives page of the Preferences dialog (Tools » Schematic 
Preferences). This allows you to change the default properties for the text string 
object, which will be applied when placing subsequent text strings. 
During placement, the Annotation dialog can be accessed by pressing the Tab key. 

After placement, the Annotation dialog can be accessed in one of the following ways: 

• double-clicking on the placed text string object 
• selecting the text string object and choosing Properties from the right-click pop-up menu (Schematic Editor only) 

• choosing the Change command from the Edit menu and then clicking once over the placed text string object. 

The actual content of the text string can be entered/edited via the Annotation dialog using the Text field. Type the required text 
directly into the field. The Text field also provides a drop-down list of special strings that link to parameter information defined 
for the active document on the Parameters tab of the Document Options dialog (Design » Document Options). 
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Special Strings 
Special strings are text strings which are recognized and 
interpreted when the sheet is printed or plotted. Certain 
special strings provide current information, such as date and 
time, which are inserted at the time of printing.  

Some special stings can be displayed on the document prior 
to printing, by enabling the Convert Special Strings option on 
the Schematic - Graphical Editing page of the Preferences 
dialog (Tools » Schematic Preferences).  
Special Strings are preceded by the ‘=’ character. Navigate 
to the Parameters tab in the Document Options dialog from the Design menu to check the available Special Strings. You can 
set up different special strings for each Schematic Document using the Document Options dialog 

The following lists the defined set of special schematic strings: 
• =CurrentTime – the current time, automatically calculated from your system settings and in the format hh:mm:ss, updated 

upon editing your schematic or on redraw. For example, this special string is converted to 2:39:47 PM on the schematic. 

• =CurrentDate – the current date, automatically calculated from your system settings and in the format dd/mm/yyyy, 
updated upon editing your schematic or on redraw. For example this special string is converted to 24/04/2008 on the 
schematic. 

• =DocumentFullPathAndName – the full path and name of the document. For example, this special string is converted to 
C:\Program Files\Altium Designer 6\Examples\Reference Designs\Multi-Channel 
Mixer\Mixer.SchDoc on the schematic. 

• =DocumentName – the schematic’s file name only (without the file path). For example, this special string is converted to 4 
Port UART and Line Drivers.SchDoc on the schematic. 

• =ModifiedDate – the modified date stamp of the schematic, automatically populated. For example, this special string is 
converted to as 2/04/2008 on the schematic. 

• =Time – user defined field. Enter the value in the Document Options dialog 

• =Date – user defined field. Enter the value in the Document Options dialog 

• =ApprovedBy – user defined field. Enter the value in the Document Options dialog 

• =CheckedBy  – user defined field. Enter the value in the Document Options dialog 

• =Author  – user defined field. Enter the value in the Document Options dialog 

• =CompanyName  – user defined field. Enter the value in the Document Options dialog 

• =DrawnBy  – user defined field. Enter the value in the Document Options dialog 

• =Engineer  – user defined field. Enter the value in the Document Options dialog 

• =Organization  – user defined field. Enter the value in the Document Options dialog 

• =Address1  – user defined field. Enter the value in the Document Options dialog 
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• =Address2  – user defined field. Enter the value in the Document Options dialog 

• =Address3  – user defined field. Enter the value in the Document Options dialog 

• =Address4  – user defined field. Enter the value in the Document Options dialog 

• =Title  – user defined field. Enter the value in the Document Options dialog 

• =DocumentNumber  – user defined field. Enter the value in the Document Options dialog 

• =Revision  – user defined field. Enter the value in the Document Options dialog 

• =SheetNumber – the sheet number of the current schematic. This value is calculated when you perform Number 
Schematic Sheets or Annotate Compiled Sheets from the Tools menu. To display your Compiled Sheet Number, navigate 
to Tools » Schematic Preferences » Schematic » Compiler and enable the flag to expand Sheet Number in the 
Compiled Names Expansion section. 

• =SheetTotal – the sheet total for the project. This value is calculated when you perform Number Schematic Sheets or 
Annotate Compiled Sheets from the Tools menu. To display your Compiled Sheet Number, navigate to Tools » 
Schematic Preferences » Schematic » Compiler and enable the flag to expand Sheet Number in the Compiled Names 
Expansion section. 

• =ImagePath  – user defined field.  

• =VariantName – this is the name of your variant specified in Project » Assembly Variants. The value of this special 
string is dependent on the Variant selected when printing or creating a PDF, therefore it is not interpreted until output. 

• =[VariantParameterName] – enter the actual name of your Variant Parameter as the special string name. The value of 
the variant parameter displayed is dependent on the Variant selected. You can specify the same variant parameter name for 
all of your variants and enter a different value for each. As with VariantName, this special string is not interpreted until 
output. 

• Custom special strings that can be added to the Parameters tab of either the Document Options or Project Options dialog. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed text string object directly in the workspace and change its location 
graphically. Text strings can only be adjusted with respect to their size by changing the size of the font used (accessed through 
the Annotation dialog). As such, editing handles are not available when the text string object is selected: 

 

Click anywhere inside the dashed box and drag to reposition the text string as required. The text string can be rotated or flipped 
while dragging. 
If the Enable In-Place Editing option is enabled on the Schematic - General page of the Preferences dialog (Tools » 
Schematic Preferences), you will be able to edit the content for the text string directly in the workspace. Select the text string 
and then click once to invoke the feature. Type the new text as required and then click away from the text string or press Enter 
to effect the change. 
If you attempt to graphically modify a text string object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
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If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Notes 
A newly placed text string will initially have a default name of Text. Edit the properties of the text string to change the text to 
that required. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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Wire 

 

Description 
A wire is an electrical design primitive. It is a polyline object that forms an electrical connection between points on a schematic 
and is analogous to a physical wire. 

Availability 
Wires are available for placement in the Schematic Editor only. Use one of the following methods to access the placement 
command: 
• choose Place » Wire [P, W] from the main menus 

• click the  button on the Wiring toolbar. 

Placement 
After launching the command, the cursor will change to a cross-hair and you will enter wire placement mode. Placement is 
made by performing the following sequence of actions: 
• click or press Enter to anchor the starting point for the wire 

• position the cursor and click or press Enter to anchor a series of vertex points that define the shape of the wire 

• after placing the final vertex point, right-click or press Esc to complete placement of the wire. 

Continue placing further wire objects, or right-click or press Esc to exit placement mode. 

Use the Backspace or Delete keys to remove the last wire segment 
placed. 

Guided wiring 
Schematics have a definable electrical grid that makes it easy to define 
electrical connections between objects. As you are placing a wire, when the 
wire falls within the electrical grid range of another electrical object the 
cursor will snap to the fixed object and a Hot Spot (red cross) will appear. 

The Hot Spot guides you to where a valid connection can be made and 
automatically snaps the cursor to electrical connection points. 
The electrical grid can be defined on the Sheet Options tab of the 
Document Options dialog (Design » Document Options). It is 
recommended that you set the electrical grid to be slightly smaller than the 
current snap grid, or it becomes difficult to position electrical objects one 
snap grid apart. 

Auto-junctioning 
The schematic auto-junctioning feature places an electrical junction (compiler generated junction) when two wires are 
connected in a T-type fashion, or when a wire connects orthogonally to a pin or power port. 

 

This feature allows you to easily create electrical connections at junction points without the need to manually define the 
connection (through placement of a manual junction). Wires that cross away from their end points do not have a junction 
automatically inserted. 
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Display of auto-junctions on the schematic sheet, with respect to wires, can be controlled from the Schematic - Compiler page 
of the Preferences dialog (Tools » Schematic Preferences). Additional options provide control over junction size and color. 

Editing 
The properties of a wire object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following three methods of non-graphical editing are available: 

Editing via an associated properties dialog 
This method of editing uses the following dialog to modify the properties of a 
wire object. 

Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right 
of the dialog and then click over a field or option to pop-up information specific 
to that field or option. 

Editing Vertices 
The Wire dialog provides a Vertices tab, from where you can edit the individual vertices of the currently selected wire object as 
required. 

 
The main region of the tab lists all of the vertex points currently defined for the wire. You can add new vertices to the wire, edit 
the coordinates of existing vertices, or remove selected vertices altogether. 
Click the Menu button or right-click within the main list region to access a pop-up menu containing the following commands: 

• Edit - right click on a coordinate cell (X or Y) for a vertex and use this command to edit the value in that cell. Alternatively, 
click directly on the cell 

• Add - use this command to add a new vertex point. The new vertex will be added below the currently focused vertex entry 
(as distinguished by a dotted outline around a cell in its row) and will initially have the same coordinates as the focused entry 

• Remove - use this command to remove the currently selected vertex entries in the list. This command will be unavailable if 
there are only two vertices present for the wire 

• Copy - use this command to copy the content of the selected cells in the list to the clipboard (alternatively use Ctrl+C) 

• Paste - use this command to paste the content of the clipboard into the list, starting at the selected cell (alternatively use 
Ctrl+V) 

• Select All - use this command to quickly select the entire grid contents of the list 

• Select Column - use this command to quickly select the entire column in which the currently focused cell resides 

• Move Up - use this command to move the selected vertex upward in the list 

• Move Down - use this command to move the selected vertex downward in the list 

• Move Wire By XY - use this command to move the entire wire object. The Move Wire By dialog will appear, from where you 
can enter the increment value to be applied to each vertex point's X and Y coordinates. 

Dialog access 
The Wire dialog can be accessed prior to entering placement mode, from the Schematic - Default Primitives page of the 
Preferences dialog (Tools » Schematic Preferences). This allows you to change the default properties for the wire object, 
which will be applied when placing subsequent wires. 
During placement, the Wire dialog can be accessed by pressing the Tab key. 
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After placement, the Wire dialog can be accessed in one of the following ways: 

• double-clicking on the placed wire object 
• selecting the wire object and choosing Properties from the right-click pop-up menu 

• choosing the Change command from the Edit menu and then clicking once over the placed wire object. 

Editing via the SCH Inspector panel 
The SCH Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on the SCH Inspector panel, press F1 when the cursor is over the panel. 

Editing via the SCH List panel 
The SCH List panel allows you to display design objects from one or more documents in tabular format, enabling you to quickly 
inspect and modify object attributes. When used in conjunction with the SCH Filter panel, it enables you to display just those 
objects falling under the scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy 
and efficiency. 

For more information on the SCH List and SCH Inspector panels, press F1 when the cursor is over a panel. 

Graphical editing 
This method of editing allows you to select a placed wire object directly in the workspace and change its size and/or shape, 
graphically. 

When a wire object is selected, the following editing handles are available: 

 

Click and drag A to reposition the end points of the wire. 

Click and drag B to move a vertex. The end points will remain anchored. 

Click and drag near the center of a wire segment to "grab" that segment and reposition it. The end points and other vertices will 
remain anchored. 
Right-click on a vertex point and choose the Edit Wire Vertex n command to access the Vertices tab of the Wire dialog, with 
the entry for the nth vertex selected ready for editing. 

With the wire selected, click on a vertex or segment to individually select that vertex or segment. This wire 'sub-selection' is 
distinguished by the associated editing handles becoming red in color. 

 Individual vertex sub-selection. 

 Individual segment sub-selection. 

The associated vertex (or vertices for a segment) can then be edited directly using the SCH Inspector or SCH List panels, with 
any changes appearing immediately on the schematic. 
If you attempt to graphically modify a wire object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit.  
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If the Protect Locked Objects option is enabled in the Schematic – Graphical Editing page of the Preferences dialog (Tools 
» Schematic Preferences), and the Locked option for this design object is enabled as well then this object cannot be selected 
or graphically edited.  
You will have to double click on this locked object directly and disable the Locked property or disable the Protect Locked 
Objects option in the Schematic – Graphical Editing Preferences dialog to graphically edit this object. 

If you attempt to select locked objects along with other objects, only those objects that are unlocked can be selected and moved 
as a group if the Protect Locked Objects option is enabled. Otherwise if the Protect Locked Objects option is disabled you 
will be prompted for confirmation to proceed with the edit of the objects including locked objects. 

Multi-wire Editing 
If multiple selected wires share a coordinate for their end vertex, then you can 
drag the vertex of one wire and the vertices of all other wires in the selection will 
be moved to keep the wire ends aligned. 

This becomes an important productivity enhancer for those times when you 
need to quickly extend a group of wires – for example when connecting to the 
pins of a placed component. 

Notes 
A wire is an electrical object and should ONLY be used to make electrical 
connections between points on a schematic. To draw a non-electrical line on a 
schematic, use the Line object. 

 

When placing a wire, various placement modes are available: 90 Degree, 45 Degree, Any Angle and Auto Wire. The mode 
specifies how corners are created when placing wires and the angles at which wires can be placed. The 90 Degree and 45 
Degree modes (true orthogonal modes) both have Start and End sub-modes. 

 

The Auto Wire mode is a special mode that allows you to automatically connect between two points on the schematic. The 
Autowirer will automatically route the bus around obstacles. When in this mode, press the Tab key to set the Autowirer options 
in the subsequent Point to Point Router Options dialog: 

 

 

When placing a wire, press Shift+Spacebar to cycle through the wire placement modes. Press Spacebar to toggle between the 
Start and End sub-modes (when in 90 Degree or 45 Degree modes), or between Any Angle and Auto Wire modes (when either 
of these modes is active). The current placement mode is displayed in the status bar. You can change modes at any time during 
wire placement. 

In all modes other than Any Angle, the wire segment attached to the cursor is a "look ahead" segment. The segment you are 
actually placing precedes this look ahead segment. 

 

When launching the command to place a wire, the initial placement mode is dependant on the placement mode last used when 
previously placing wires or lines. Therefore, if the last line you placed used 90 Degree Start, then the next wire or line you place 
will have 90 Degree Start as the initial placement mode. If you last placed a wire using Auto Wire mode, placement of a 
subsequent line will be confined to Any Angle mode only. You will need to place a wire in any mode other than Auto Wire in 
order for line placement to have all placement modes fully restored and functional. 
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Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the Schematic - Default Primitives page of the Preferences dialog - is enabled. When this option is 
enabled, changes made will affect only the object being placed and subsequent objects placed during the same placement 
session. 
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