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PCB Editor and Object Reference 

Summary  
Technical Reference  
TR0112 (v2.5) May 22, 2008 

This comprehensive reference provides information on the PCB Editor and the 
various objects that can be used to layout your PCB design. 

 

PCB Editor 

 

Function 
The PCB Editor allows you to create, edit and verify the PCB design, as well as generate the output files required to 
manufacture the printed circuit board. 

Editor Environment 
When the PCB Editor is active (i.e. a PCB document (*.PcbDoc) is open and active) the main application window will contain: 

• a main design window in which to design – capable of display in 2D and 3D modes. 2D mode has a larger feature set as the 
majority of board design is carried out more naturally in a 2D model space. View settings for any project can be saved as a 
“view configuration” and used time and again. 

• editor-specific menus and toolbars 

• workspace panels - both global and editor-specific. 

Object placement, routing and graphical editing is carried out on the PCB document which, when opened, appears as a tabbed 
document view in the main design window. 
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The use of the main design window in terms of actual design (placement, editing, routing, design rule checking, etc) is outside 
the scope of this topic and information for such should be sought in the relevant documentation. The following sections, 
however, offer useful hints and tips with respect to the main design workspace in general. 

Specifying Document Options 
Options specific to the active PCB document are defined in the Board Options dialog, which can be accessed by selecting 
Design » Board Options. 

 

This dialog provides controls for defining the various grid systems, specifying units of measurement and controlling the display 
and position of an associated (back) sheet on which the board is placed. 

Note: Many dialogs feature a units toggle control  in the top-left corner that will change the units of measurement currently 
used in the dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is displayed in the dialog 
title area. Toggling units at any time does not affect system accuracy as all numerical calculations are carried out at system 
resolution. The workspace Preferences dialog (DXP » Preferences) can also be used to control the display precision and 
rounding of metric units between three and five digits to the right of the decimal point. 
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To define the layer stack for the active PCB document, select Design » Layer Stack Manager. The Layer Stack Manager 
dialog will appear. 

 

View Configurations 
The PCB Editor can display the PCB model in 2D or 3D modes with definitions for layers, surfaces, 3D colors, visibility and other 
items, known as view configurations, available from the View Configurations dialog. You can save any 2D or 3D view 
configurations for use time and again. Select Design » Board Layers & Colors [shortcut: L] to display the View Configurations 
dialog. 

 

2D mode is a multi-layered environment that is ideal for normal PCB design routines such as placing components, routing and 
connecting. 3D mode is useful for examining your design both inside and out as a full 3D model (3D mode does not provide the 
full range of editing functionality available in 2D mode). You can switch between 2D and 3D modes through File » Switch To 
3D or File » Switch To 2D [shortcut: 2 (2D), 3 (3D)].  

Note: 2D layer and system colors edited via the View Configurations dialog are system-based. Ie, they will be applied to all PCB 
documents, similarly to editing them via the Preferences dialog. 

In each case, use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click 
on the question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to 
that field or option. 
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Specifying Workspace Preferences 
General workspace preferences - applicable to all PCB documents - are defined on the relevant pages contained within the 
PCB Editor section of the Preferences dialog. Select Tools » Preferences to display the PCB Editor - General page of this 
dialog. 

 

Again, use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available across the 
various pages. 

Right-click Menus 
Right-clicking in the main design window will open a [pop-up] menu providing 
commands to access commonly used features, such as document options and 
workspace preferences, as well as commands that are in context with the 
object currently under the cursor. 

Panning 
Panning in the workspace can be carried out in the following ways: 

• using the horizontal and vertical scroll bars 
• using the keyboard arrow keys (holding SHIFT key for faster movement) 

• using mouse-wheel for up/down, SHIFT + Mouse-wheel for left/right 

• right-drag mouse to pan in any direction. 

Zooming 
Zooming in the workspace can be achieved in the following ways: 
• CTRL + Right-drag mouse or CTRL + Mouse-wheel or PAGE UP / PAGE DOWN keys  

• using the PAGE UP (zoom in) and PAGE DOWN (zoom out) keyboard shortcuts. (Hold down the SHIFT and CTRL keys to 
provide finer and coarser zooming respectively) 

• using the mouse-wheel (push the mouse-wheel button down and move mouse). 
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Rotation (3D Mode) 
Hold down SHIFT to enter 3D rotation mode. This is represented on screen as a directional sphere at 
the cursor position. Rotational movement of the model is made about the center of the sphere using 
the following controls: 
• Right-drag sphere Center Dot with the mouse for full floating view – rotate in any direction. 

• Right-drag sphere Horizontal Arrow with the mouse to rotate the view about the Y-axis. 

• Right-drag sphere Vertical Arrow with the mouse to rotate the view about the X-axis. 

• Right-drag sphere Circle Segment with the mouse to rotate the view in the Y-plane. 

Note: Altium Designer supports a number of 3D mouse and 3D space navigation devices. These 
devices can improve the 3D navigation experience. 

Moving a Group of Selected Objects 
You can move selected objects using a combination of the CTRL key and arrow keys (vertically or horizontally), the CTRL and 
SHIFT keys and arrow keys, or freely using the mouse, on the PCB document. 

When using the keyboard to reposition selected objects, the distances are set according to the current Snap Grid setting in the 
Board Options dialog (Design » Board Options or shortcut D, O). Use this dialog to change the Snap Grid X (horizontal) and Y 
(vertical) values. This Grid value also appears on the Status bar of Altium Designer. Use the G shortcut to cycle through 
different snap grid setting values. You can also use the View » Grids submenu or the Snap Grid right-click menu. 

• Selected objects can be 'nudged' by small amounts (according to the current snap grid value) by pressing the arrow keys 
while holding down the CTRL key. 

• Selected objects can also be 'nudged' by large amounts (snap grid value by a factor of 10) by pressing the arrow keys while 
holding down the CTRL and SHIFT keys together. 

Moving a Group of Selected Components Sequentially 
You can reposition a number of selected components sequentially in the order that you selected them. 
You need to select the components you want to move one at a time using SHIFT + Click on each. 

Once your components are selected, select the Tools » Component Placement » Reposition Selected Components 
command. The cursor appears as a crosshair with the first selected component attached to it. Reposition the component by 
clicking at the new position (normal cursor snap movement and free mouse movement are available). 

Once component placement is finished, all the originally selected components will remain selected. Click anywhere in the 
workspace to exit sequential component placement mode. 

Changing the Current Layer 
One workspace layer is current at any given time. Some design objects, such as tracks, fills, text or single layer pads are placed 
on the current layer. Other design objects, such as components, multi-layer pads and vias, can be placed without regard to the 
current layer. Selection (for moving, deleting, etc) is layer-independent - you can perform these operations on any primitives 
without having to change the current layer. 

At the bottom of the main design window there is a color-coded tab for each layer that is enabled with respect to its visibility in 
the workspace (from the View Configurations dialog). 

 

The currently selected layer name is shown bolded for easy identification. A layer can be made current by clicking on its 
corresponding tab. Alternatively use the + and - keys on the numeric keypad to cycle forward and backward through all enabled 
layers in the workspace. Pressing the * key on the numeric keypad cycles through enabled signal layers. Use layer tabs as 
follows: 

• Click selects the layer 
• CTRL + Click selects the layer and highlights layer content 

• CTRL + ALT + Cursor-hover selects the layer and highlights its content 

• CTRL + SHIFT + Click selects the layer and toggles highlighting 

• Right-click for pop-up menu with commonly-used layer-related commands including layer visibility. 

The color assigned to each layer is indicated by the color swatch on the left of each layer tab. 
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Selection Memory 
The Selection Memory feature enables you to select objects in your design and 
save the selection for recall at any time. You can reselect the objects directly via 
the Selection Memory dialog. Selections are saved with the PCB document.  

Click the  button at the bottom right of the main design window to access the 
Selection Memory dialog. This dialog provides full control over the selection 
memory feature. 

Mask Level Controls 
Click the Mask Level button at the bottom right of the main design window to 
access a pop-up containing controls for adjusting the masking level when the 
mask highlight method is employed as part of temporary or permanent filtering, eg. when applying a query from the PCB Filter 
panel, when browsing design objects using the PCB panel, or when interactively routing. The effectiveness of masking and 
dimming is determined by the Highlighting Options set in the PCB Editor – Display page of the Preferences dialog. 

When Mask is enabled, filtered objects will appear visible in the design 
editor window, with all other objects being made monochrome. The 
Masked Objects Factor slide control determines the level of shade 
applied to unfiltered objects, the Background Objects Factor slide 
control determines the level of visibility of unfiltered objects. 
When Dim is enabled, filtered objects will appear visible in the design 
editor window, with all other objects retaining their colors, but being 
shaded. There are two controls to set the contrast between filtered and 
unfiltered objects. The Masked Objects Factor slide control 
determines the level of shade applied to unfiltered objects, the 
Highlight Objects Factor determines how white the filtered objects highlight is. 

    

Clear Filtering 
Click the Clear button at the bottom right of the main design window, or use the SHIFT + C keyboard shortcut, to clear any 
existing filtering applied to the current PCB document. If the filtering is temporary in nature, click anywhere inside the main 
design window to clear it. If the filtering is permanent in nature, you must use the Clear button, or one of its counterparts which 
can be found in the respective dialog(s) or panel(s) from which the original filtering was initiated. 

TrueType Font Support 
The PCB Editor offers the ability to use Stroke-based or TrueType fonts for text-related objects in a design (string, coordinate 
and dimension text). Choice of font is made from within the associated properties dialog for an object. 
Three Stroke-based fonts are available - Default, Sans Serif and Serif. The Default style is a simple vector font which supports 
pen plotting and vector photoplotting. The Sans Serif and Serif fonts are more complex and will slow down vector output 
generation, such as Gerber. The Stroke-based fonts are built into the software and cannot be changed. All three fonts have the 
full IBM extended ASCII character set that supports English and other European languages 

When using TrueType fonts, TrueType and OpenType (a superset of TrueType) fonts found in the \Windows\Fonts folder will be 
available for use. The feature also offers full Unicode support. 
The PCB Editor – TrueType Fonts page of the Preferences dialog provides options for embedding TrueType fonts when 
saving a design, and for applying font substitution when loading a design. 
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Embedding fonts can be particularly useful when you explicitly require text to 
be displayed in a font that may or may not be available on a target computer 
upon which the design is loaded (eg. at the fabrication house). By default 
embedding of fonts is disabled. 

Font substitution enables you to specify a TrueType font to be used as a 
replacement when loading a design where the TrueType fonts have not been 
embedded and one or more fonts used within the design - and that were 

available for use on the source computer - are not available on the computer upon which you are currently loading the design. 
By default Arial is used for the substitution. 

Associated Panels 
The following workspace panels are specific to the PCB Editor. 
• PCB  

• PCB Filter  
• PCB Inspector  
• 3D Visualization  
• Board Insight  
• PCB List  
Certain workspace panels, although not specific to the PCB Editor, will be used frequently as you design. These include the 
Projects panel and Messages panel. 

For more information on a specific panel, press F1 when the cursor is over that panel. For a complete listing of all workspace 
panels, refer to the Altium Designer Panels Reference. 

Associated Design Objects 
The following is a list of the various objects available for PCB design. Pressing F1 over a design object in the main design 
window will access information for that object directly. 

• Arc • Board Shape • Component • 3D Body • Connection • Coordinate 

• Dimension • Embedded 
Board Array 

• Fill • From-To • Pad • Polygon 
Pour 

• Region • Room • String • Track • Via • Violation 

 

Notes 
A key feature of the PCB Editor is the way logical and physical (or electrical) connections between the elements in a design are 
recognized and managed. At all times the PCB Editor monitors the state of the connectivity, adding and removing connection 
lines as you place and delete tracks. 

 

Autorouting is performed using the Situs Autorouter, which itself is an integral part of the PCB Editor. Situs is a topological 
autorouter, which uses advanced topological mapping to first define the routing path, then calls on a variety of proven routing 
algorithms (passes) to convert this 'human-like' path to a high-quality route. The router closely follows PCB electrical and routing 
rule definitions. 

 

Design Rules 
The PCB Editor is a rules-driven environment. As you work in the editor and carry out design changes (such as placing tracks, 
moving components and autorouting) the editor constantly monitors each action and checks to see if the design still complies 
with defined design rules. 

Design rules collectively form an instruction set for the PCB Editor to follow. Each rule represents a requirement of your design 
and many of the rules, for example clearance and width constraints, can be monitored as you work by the Online Design Rule 
Checker (DRC). Certain rules are monitored when using additional features of the software, for example routing-based rules 
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when using the Situs Autorouter to route a design, or signal integrity-based rules used by the Signal Integrity Analyzer when 
performing a detailed signal integrity analysis of a design. 

The PCB Editor provides a powerful interface from where you can define the various design rules as required. The rules 
themselves are divided into the following ten categories: Electrical; Placement; Routing; Manufacturing; SMT; Plane; Mask; Test 
Point; High Speed and Signal Integrity. Select Design » Rules from the main menus to access the PCB Rules and Constraints 
Editor dialog, from where you can specify rule constraints for your design as required. 

 

Setting up the design rules before you start working on the board allows you to remain focused on the task of designing. With a 
well-defined set of design rules, you can successfully complete board designs with varying and often stringent design 
requirements. This is further enhanced by the fact that the PCB Editor allows you to export and import rule sets, enabling you to 
store and retrieve your favorite design rule configurations, depending on the job at hand. 

For more detailed information with respect to the types of design rule available for use and how they can be defined, refer to 
the Design Rules Reference. 

 

Re-entrant Editing 
The PCB Editor includes a powerful feature which allows you to perform a second operation without having to exit the operation 
you are currently carrying out. This facility is known as re-entrant editing. 

Re-entrant editing allows you to work more flexibly and intuitively. For example, you start placing a track then realize that 
another track segment must be deleted. There is no need to drop out of Interactive Routing mode. Press the E, D shortcut keys, 
delete the required track segment then press the ESC key to return to interactively routing your design. 

Note: The second operation can only be accessed by using its shortcut keys. 

A large number of processes can be completed within another process. The number of times another process can be launched 
before the current process is complete depends on the demands each of these incomplete processes is placing on the software. 

Arrangement of panels and toolbars is totally configurable and, once you have set up the working environment to your liking, 
can be saved using the View » Desktop Layouts » Save Layout command. 
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PCB Design Objects 

Arc 

 

Description 
An arc is a primitive design object. It is essentially a circular track segment that can be placed on any layer. Arcs can have a 
variety of uses in PCB layout. For example, they can be used when defining component outlines on the overlay layers, or on a 
mechanical layer to indicate the board outline, cut outs, and so on. They can also be used to produce curved paths while 
interactively routing. Arcs can be open, or closed to create a circle (often referred to as a full circle arc). 

Availability 
Arcs are available for placement in both PCB and PCB Library Editors. In the PCB Editor they can be placed via the main Place 
menu and the Utilities toolbar. In the PCB Library editor they can be placed via the main Place menu, the right-click Place 
menu, and the PCB Lib Placement toolbar. They can also be placed using Altium Designer’s shortcut keys, for example P, A 
will launch the Place » Arc (Center) command. 

Placement 
The way in which an arc is placed depends on the particular method of placement that you have chosen to invoke. Four 
different methods of arc placement are supported: 
• Place arc by center – this method enables you to place an arc object using the arc center as the starting point. 

• Place arc by edge – this method enables you to place an arc object using the edge of the arc as the starting point. The arc 
angle is fixed at 90°. 

• Place arc by edge (any angle) – this method enables you to place an arc object using the edge of the arc as the starting 
point. The angle of the arc can be any value. 

• Place full circle arc - this method enables you to place a 360° (full circle) arc. 

Placing an Arc Starting at the Center 
After launching the command, the cursor will change to a crosshair and you will enter arc placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press ENTER to anchor the center point of the arc 

• move the cursor to adjust the radius of the arc, then click or press ENTER to set it 

• move the cursor to adjust the start point for the arc, then click or press ENTER to anchor it. 

• move the cursor to change the position of the arc's end point, then click or press ENTER to anchor it and complete 
placement of the arc. 

Continue placing further arcs, or right-click or press ESC to exit placement mode. 

Press the SPACEBAR before defining the arc's end point, to render the arc in the opposite direction. 

Placing an Arc Starting at the Edge 
After launching the command, the cursor will change to a crosshair and you will enter arc placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press ENTER to anchor the start point for the arc 

• move the cursor to change the position of the arc's end point, then click or press ENTER to anchor it and complete 
placement of the arc. 

Continue placing further arcs, or right-click or press ESC to exit placement mode. 

Press the SPACEBAR before defining the arc's end point, to render the arc in the opposite direction. 
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The following Arc 
properties cannot be 
changed before or during 
placement – only post 
placement: 
Start Angle 
End Angle 
Radius 
Center X, Y 

Placing an Arc Starting at the Edge (any angle) 
After launching the command, the cursor will change to a crosshair and you will enter arc placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press ENTER to anchor the start point for the arc 

• move the cursor to adjust the radius of the arc, then click or press ENTER to anchor the center point 

• move the cursor to change the position of the arc's end point, then click or press ENTER to anchor it and complete 
placement of the arc. 

Continue placing further arcs, or right-click or press ESC to exit placement mode. 

Press the SPACEBAR before defining the arc's end point, to render the arc in the opposite direction. 

Placing a Full Circle Arc 
After launching the command, the cursor will change to a crosshair and you will enter arc placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press ENTER to anchor the center point of the arc 

• move the cursor to adjust the radius of the arc, then click or press ENTER to set it and complete placement of the arc. 

Continue placing further arcs, or right-click or press ESC to exit placement mode. 

Editing 
The properties of an arc object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of an arc object: 

Use the dialog's 'What's This Help' feature to obtain detailed information 
about each of the options available. Click on the question mark button at the 
top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. This dialog feature a units toggle 
control  in the top-left corner that will change the units of measurement 
currently used in the dialog between metric and imperial [shortcut: CTRL + 
Q]. The current unit of measurement is displayed in the dialog title area. 

The Arc dialog can be accessed prior to entering placement mode, from the 
PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the arc 
object, which will be applied when placing subsequent arcs. 

During placement, the Arc dialog can be accessed by pressing the TAB key. 

After placement, the Arc dialog can be accessed in the following ways: 

• double-clicking on the placed arc object 
• selecting the arc object and choosing Properties from the right-click pop-up menu 

• selecting Edit » Change from the main menus and then clicking once over the placed arc object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design 
objects in the active document. Used in conjunction with appropriate filtering, the panel can be used to make changes to 
multiple objects of the same kind, from one convenient location. 

 For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 
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Arc placed by center or edge   Full circle arc 

 

Graphical Editing 
This method of editing allows you to select a placed arc object directly in the workspace and change its size, shape or location, 
graphically. 

When an arc object is selected, the following editing handles are available: 
Click and drag A to adjust the radius. 

Click and drag B to adjust the end points. 

Click anywhere on the arc - away from editing handles - 
and drag to reposition it. The arc can be rotated or flipped 
while dragging: 
• press the SPACEBAR to rotate the arc anti-clockwise 

or SHIFT + SPACEBAR for clockwise rotation. 
Rotation is in accordance with the value for the 
Rotation Step, defined on the PCB Editor - General 
page of the Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the arc along the X-axis or Y-axis respectively. 

Notes 
If you attempt to graphically modify an arc object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit. 

 

Arcs can be placed as layer-specific keepout objects to act, for example, as routing barriers. A keepout arc is simply an arc 
object with its Keepout property enabled. You can therefore either place a standard arc and then enable this property, or use 
the predefined keepout arc placement commands, available from the Place » Keepout sub-menu. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Board Shape 

 

Description 
The board shape, also referred to as the board outline, is a closed polygon that defines the boundary, or extents, of the PCB. 
The board shape is used to determine the extents of the power planes when calculating plane edge pull back, used when 
defining split planes on internal plane layers and also for calculating the board edge when exporting design data to other tools. 

Availability & Placement 
The board shape object is available only in the PCB Editor and is automatically placed 
when you create a new PCB document. As such, it is not an object that can be placed in 
the traditional sense, however, you can redefine the board shape and size - in effect 
discarding the existing shape and placing a new one. You can also redefine the board 
shape based on selected line and arc objects in the workspace or from the surface of an 
imported STEP model. 

Redefining the Board Shape Using a Polygon 
This feature is accessed by selecting Design » Board Shape » Redefine Board Shape from the main menus [shortcut: D, S, 
R]. 

After launching the command, the existing board shape will be displayed, green over a black background, and the cursor will 
change to a crosshair, ready to define the outline of the new board shape. The Jump Location command [shortcut: J, L] can 
speed up accurately positioning the board vertices. 

Placement of the new outline is made by performing the following actions: 

• position the cursor and click to anchor a starting point for the polygon 

• position the cursor and click to anchor a series of vertices that define the polygonal outline of the board shape 
• after placing the final vertex point, right-click or press ESC to complete placement of the board shape. There is no need to 

"close" the polygon as the software will automatically complete the shape by connecting the start point to the final point 
placed. 

Upon closing the polygon, the existing board shape will be updated. 
While defining the shape, use SHIFT + SPACEBAR to cycle through various corner modes. Modes available are: any angle, 
45°, 45° with arc, 90° and 90° with arc. Arcs can be increased or decreased in radius using SHIFT + . (period or full stop) or 
SHIFT + , (comma) respectively. Use SPACEBAR to toggle the direction of the corner. 

Use the BACKSPACE key while in placement mode, to remove the last placed vertex point. Repeatedly use this key to 'unwind' 
the outline for the polygon, right back to the initial starting point. 

Redefining the Board Shape Using Selected Objects 
This method of redefining the board shape allows you to define the required outline for the board using standard track and arc 
objects. The track and arc segments must be placed to form a closed boundary. 
Once the outline is the required shape, select all objects defining it then select Design » Board Shape » Define from selected 
objects from the main menus. The existing board shape will be modified to fill the area defined by your selected boundary. 

This method can be used in conjunction with the defining primitives from the existing board shape command to replicate that 
current board shape as primitive objects. You can then edit the primitives for the desired shape, then use the primitive objects to 
reassign the board shape to. 
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Redefining the Board Shape Using a 3D Body 
This feature is accessed by selecting Design » Board Shape » Define from 3D body from the main menus [shortcut: D, S, S]. 
Prior to launching this command, you must have already placed a 3D body in the workspace and be in 3D mode for the 
command to be available. 

After launching the command, click the 3D body to select it, the cursor will change to a crosshair, ready to select the desired 
surface. Click on a flat surface of the STEP model - this surface will become the new board shape. As you move the cursor 
around the model, when a surface is found, it is highlighted by the rest of the model being made somewhat transparent. 
Note: Only surfaces aligned with the X-Y plane can be used to create the board shape from. If you select a model surface that 
requires alignment in the X-Y plane, you will be asked, via a Confirmation dialog, to align the surface before you can continue. 
This dialog also allows you to vertically position the model, using the selected face, in relation to either the top or bottom surface 
of the board. This means that the vertical position of the model can also be set at the same time. After alignment you will need 
to select Design » Board Shape » Define from 3D Body again. 

After the board shape has been redefined, you will be given the option to hide the 3D body. 

 

Editing 
The board shape object can not be edited in the usual manner. Non-graphical editing does not apply as the board does not 
have an associated properties dialog. Although it can be selected, it does not appear as an object in either the PCB List or PCB 
Inspector panels. When selected, the editing handles that appear cannot be used to graphically modify its shape. Modification 
is possible however, with respect to location, orientation and shape, using available commands from the Design » Board 
Shape sub-menu, which are detailed in the following sections. 

Redefining the Outline of the Existing Board Shape Using Vertices 
This feature allows you to edit the existing board shape without having to completely 
redefine it and is accessed by selecting Design » Board Shape » Move Board Vertices 
from the main menus. 

After launching the command, the existing board shape will be displayed green on a 
black background, the vertices will become handles and the cursor will change to a 
crosshair, ready to define the outline of the new board shape. 
• click A then move to reposition an existing vertex and click again to place 

• click B to add a new vertex points (between selected vertex and nearest vertices) and reposition as required 

• click on the outline (between vertices) then move to reposition a section of outline. 
After modifying the board shape as required, right-click or press ESC to exit. 

Creating Primitives Using the Existing Board Shape 
You can create primitive objects (arcs and lines) from the existing board shape, including board cutouts, by selecting Design » 
Board Shape » Create Primitives From Board Shape from the main menus. 

Once your primitives have been created, you can freely edit them to define a new shape that you can use to redefine the board 
shape by selecting Design » Board Shape » Define From Selected Objects from the main menus. 
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Moving the Existing Board Shape 
The existing board shape can be moved within the workspace by selecting Design » 
Board Shape » Move Board Shape from the main menus. After launching the 
command, the cursor will change to a crosshair and the board shape will appear floating 
on the cursor. 
Move the shape to the required position within the workspace and click or press ENTER 
to effect placement. The display will update accordingly. 

The board shape can be rotated or flipped while being moved: 
• press SPACEBAR to rotate the board shape anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the board shape along the X-axis or Y-axis respectively. 

Notes 
The visible grid will be drawn to fill the area defined by the bounding rectangle of the board 
shape. This is illustrated in the accompanying image, where the board shape has been rotated to 
emphasize the area that is occupied by the visible grid. 

 

If you need to move the board shape and all objects currently placed within its bounds, select all 
objects - including the board shape - and then click on any design object and drag the whole to a 
new location. Again, the entire selection can be rotated and/or flipped while dragging. By 
pressing the L key, you can flip the design objects contained within the board shape, to the 
opposite side of the board (eg. Top layer to Bottom layer). 
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Component 

 

Description 
A component footprint is a group design object that represents a physical device on a PCB. A footprint may include such items 
as pads for connecting to the pins of a device, a physical outline of the package and device mounting features. 

Availability 
Component footprints are available for placement in the PCB Editor only. Use one of the following methods to place a 
component footprint: 
• select Place » Component [shortcut: P, C] from the main menus 

• click the  button on the Wiring toolbar 

• place a specific component footprint directly from the Libraries panel 

• place a specific component footprint from within the PCB Library Editor. 

Placement 
The way in which a component footprint is placed within a PCB design depends on how, and from where, placement mode is 
invoked. 

Placement Using Menu or Toolbar Command 
After launching the command, the Place Component dialog will appear. 

Use the dialog to select the component footprint you wish to place. You can type the 
name of the footprint directly into the Footprint field. In this case, the first matching 
footprint found in the Available Libraries will be used. 

If you are unsure of the name of the footprint, or wish to control from which library the 
footprint is placed, press the ... button to the right of the field. The Browse Libraries 
dialog will appear, from where you can browse through the currently Available 
Libraries for the active project. The Available Libraries consist of project libraries, 
installed libraries and libraries found along search paths defined in the Search Paths 
tab of the Options for Project dialog (Project » Project Options). 

Clicking the ... button in the Browse Libraries dialog will open the Available Libraries 
dialog, from where you can add/remove additional libraries to/from the overall list of those available to the project. 

The dialog also provides a search facility - accessed by clicking the Find button - allowing you to search for a specific 
component footprint across the Available Libraries or in any library along an external search path. 
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Once the required footprint has been chosen, set the appropriate designator and any comment text, then click OK to close the 
dialog. You will return to the PCB document and an outline of the component footprint will appear floating on the cursor. Position 
the footprint at the location required and click or press ENTER to effect placement. 

Continue placing further instances of the same component footprint or right-click or press ESC to exit. The Place Component 
dialog will reappear. Either browse for a different component footprint to place or click Cancel to exit placement mode. 

The component footprint can be rotated or flipped while in placement mode: 
• press the SPACEBAR to rotate the footprint anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the footprint along the X-axis or Y-axis respectively 

• press the L key to flip the footprint to the other side of the board. 

Placement from Libraries Panel 
Component footprints can be placed onto the active PCB document directly from the Libraries panel. 

Footprints can be placed from the panel when a PCB document is active in the main 
design window and the library being browsed is one of the following: 
• a Footprint library (*.PcbLib) 

• an integrated library (*.IntLib) with the suffix [Footprint View] 

• a schematic components library (*.SchLib) or an integrated library with the suffix 
[Component View] and the selected component in the main list has a linked 
Footprint model that exists in a Footprint library in the Available Libraries list. 

When a selected component footprint can be validly placed onto the active document, 
the Place button at the top-right of the panel will become available and its text will 
change to incorporate the name of that footprint. 

To place a selected component footprint, either: 
• click on the Place button, 

• double-click on the component footprint entry, 
• right-click on the entry and select the Place[FootprintName] command from the 

pop-up menu that appears, or 

• click on the component footprint entry and drag it into the PCB design workspace. 

When placing a footprint on a PCB document using the first three methods, the Place 
Component dialog will appear, with the selected footprint loaded ready for placement. 

Set the appropriate designator and any comment text, then click OK to close the 
dialog. The footprint will appear floating on the cursor. Position the footprint as required 
and click to effect placement. 

The component footprint can be rotated or flipped while in placement mode: 
• press the SPACEBAR to rotate the footprint anti-clockwise or SHIFT + 

SPACEBAR for clockwise rotation. Rotation is in accordance with the value for 
the Rotation Step, defined on the PCB Editor - General page of the Preferences 
dialog (Tools » Preferences) 

• press the X or Y keys to flip the footprint along the X-axis or Y-axis respectively 

• press the L key to flip the footprint to the other side of the board. 

Continue placing further instances of the same component footprint or right-click or 
press ESC to exit. The Place Component dialog will reappear, set ready for placing 
another instance of this footprint type, with the designator already incremented. 
Continue placing instances of the same footprint or other footprints, or press Cancel 
to exit. 

When using the click-and-drag placement method, only a single instance of the component footprint is placed. You do not 
remain in placement mode and the footprint cannot be rotated or flipped. 

Placement From within PCB Library Editor 
Component footprints can be placed onto a PCB document directly from the active PCB Library document. 
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Placement is carried out in one of two ways: 
• from the PCB Library panel - allows you to place the focused component footprint (which need not necessarily be the active 

component footprint currently displayed in the main design window) 

Right-click on the component footprint you wish to place and select Place from the 
pop-up menu. 

• by selecting Tools » Place Component from the PCB Library Editor main 
menus. This command places the active component footprint only. 

After launching either command, the last PCB document to have been active 
(irrespective of the project it belongs to) will be made the active document in the 
main design window and the Place Component dialog will appear with the chosen 
component footprint already loaded. Use this dialog to define footprint designator 
and comment as required and click OK. 

The footprint will appear floating on the cursor. Position the footprint as required and 
click to effect placement. 

The component footprint can be rotated or flipped while in placement mode: 
• press the SPACEBAR to rotate the footprint anti-clockwise or SHIFT + 

SPACEBAR for clockwise rotation. Rotation is in accordance with the value for 
the Rotation Step, defined on the PCB Editor - General page of the 
Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the footprint along the X-axis or Y-axis respectively 

• press the L key to flip the footprint to the other side of the board. 

Continue placing further instances of the same component footprint or right-click or 
press ESC to exit. The Place Component dialog will reappear, set ready for placing 
another instance of this footprint type, with the designator already incremented. 
Continue placing instances of the same footprint or other footprints, or press Cancel to exit. 

Editing 
The properties of a component footprint object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog 
to modify the properties of a component 
footprint object. The header of the dialog 
reflects which component footprint is currently 
being edited (in the following example, U6 is 
being edited): 

Use the dialog's 'What's This Help' feature to 
obtain detailed information about each of the 
options available. Click on the question mark 
button at the top right of the dialog and then 
click over a field or option to pop-up information 
specific to that field or option. This dialog 
feature a units toggle control  in the top-left 
corner that will change the units of 
measurement currently used in the dialog 
between metric and imperial [shortcut: CTRL + 
Q]. The current unit of measurement is 
displayed in the dialog title area. 

The following sections provide an overview of 
each of the specific regions of the dialog: 
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Component Properties 
Use this region of the dialog to define properties for the component, including its location and rotation, the layer it is currently 
placed on and its type. 
Enable the Lock Prims option to lock the position of all primitives that make up the component relative to one another. If this 
option is disabled, you can change the shape of the component on the board. 

If the placement of the component is critical, then it can be locked in place to prevent accidental movement or repositioning by 
the Autoplacer, by enabling the Locked option. 

Designator & Comment 
The options in the Designator and Comment regions are used to change the way the component designator and comment text 
are displayed on the PCB document, and in relation to the associated component footprint. 

Footprint 
This section of the dialog contains the name of the current footprint model used for the component. The current component 
footprint model can be changed to any other footprint model available. Use the ... button to the right of this field to open the 
Browse Libraries dialog. From here, you can browse through the currently Available Libraries (project libraries, installed libraries 
and libraries found along search paths defined in the Search Paths tab of the Options for Project dialog). 

The Browse Libraries dialog also provides a search facility - allowing you to search for a specific component footprint model 
across all Available Libraries or in any library along an external search path. 
After choosing the required model, you will return to the Component dialog. The Name, Library and Description fields of the 
region will be filled with information associated to the chosen footprint model. 

Schematic Reference Information 
This region of the dialog contains valuable information with respect to the schematic component that the PCB footprint model is 
linked to. 
The Unique ID field is used to link the PCB component footprint to the schematic component - particularly useful when 
synchronizing the PCB document with the source schematic documents after re-annotation. The easiest way to link components 
is from the PCB, using the Edit Component Links between Flattened Project and PCB dialog (Project » Component Links). 

The unique ID entry consists of the unique ID of the source schematic component (given at the time of its placement onto the 
schematic document), prefixed with the unique IDs of any connected sheet symbols that exist in the path to the schematic 
component's document. 

The schematic component's designator and hierarchical document path are also shown, along with any information pertaining to 
the source schematic library that the schematic component is placed from. 

Dialog Access 
The Component dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change the default properties for the component footprint object, 
which will be applied when placing subsequent component footprints. 
During placement, the Component dialog can be accessed by pressing the TAB key. 

After placement, the Component dialog can be accessed in the following ways: 

• double-clicking on the placed component footprint object 
• right-clicking the component footprint object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed component footprint object. 

Designator and Comment 
The component footprint's Designator and Comment text fields can be formatted independently of the footprint itself. The 
corresponding properties dialogs for each - the Designator and Comment dialogs respectively - can be accessed using the three 
methods described above (replacing component footprint with the relevant object whose properties you wish to view/modify). 
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TrueType Fonts 
Designator and/or Comment text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - 
Default, Sans Serif and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. 
The Sans Serif and Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-
based fonts are built into the software and cannot be changed. All three fonts have the full IBM extended ASCII character set 
that supports English and other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. Use the Inverted option (and Inverted Border setting) to display the text in 
the board color on a layer colored background. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

Constituent Primitives 
If the Lock Prims option in the Component Properties region of the Component dialog is disabled, you will be able to edit the 
properties of the primitive objects constituting the component footprint, individually and independently. Editing is carried out 
using the associated properties dialog for a track, arc, pad, etc. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed component footprint object directly in the workspace and change its size, 
shape, location or orientation, graphically. 
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Changing Location or Orientation 
With the Lock Prims option enabled in the Component Properties region of the Component dialog, the component footprint 
can only be changed graphically with respect to its location and orientation. As such, no editing handles appear when the object 
is selected: 

Click anywhere on the main body of the footprint and drag to reposition it. The footprint can be rotated or 
flipped as it is being dragged: 

• press the SPACEBAR to rotate the footprint anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. 
Rotation is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page 
of the Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the footprint along the X-axis or Y-axis respectively 

• press the L key to flip the footprint to the other side of the board. 

Moving a Group of Selected Components Sequentially 
You can reposition a number of selected components sequentially in the order that you selected them. 
You need to select the components you want to move one at a time using SHIFT + click on each. 

Once your components are selected, select the Tools » Component Placement » Reposition Selected Components 
command. The cursor appears as a crosshair with the first selected component attached to it. Reposition the component by 
clicking at the new position (normal cursor snap movement and free mouse movement are available). 

Once component placement is finished, all the originally selected components will remain selected. Click anywhere in the 
workspace to exit sequential component placement mode. 

Changing Size and Shape 
Component primitives can be added, modified and deleted from a component footprint directly in the PCB workspace. To modify 
component primitives on the board - graphically - you must first unlock them. This is achieved by disabling the Lock Prims 
option, in the Component Properties region of the Component dialog. The existing primitives can be modified or deleted as 
required and then the Lock Prims option re-enabled. Refer to the Graphical Editing sections of the corresponding topics for the 
various applicable primitives, for further information. 
You can also add new primitives to a component footprint - again, ensure that the Lock Prims option is first disabled. Place the 
new primitives as required, select them and then select the Tools » Convert » Add Selected Primitives to Component 
command from the main menus. 

You will be prompted to select the component footprint to which you wish to add the primitives to. Click on the footprint - the 
primitives will be added. After all required primitives are added, re-enable the Lock Prims option. 

Graphically Changing Designator and Comment Fields 
The component footprint's Designator and Comment text fields can be graphically edited independently of the main footprint 
itself. They are essentially string objects and when selected, a single editing handle becomes available: 

Click & drag B to rotate the string about point A. 

Click anywhere on the string - away from the editing handle - and drag to reposition it. The string will 
be held by point A and can be rotated or flipped while dragging: 

• press the SPACEBAR to rotate the string anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 
accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the string along the X-axis or Y-axis respectively 

• press the L key to flip the string to the other side of the board. 

Notes 
Component footprints can be changed freely. However, if there are netlist connections to the pads the new footprint must have 
the same used pin numbers available as the previous one. If it does not the warning message "cannot match pads with new 
footprint" will be displayed and the substitution will be aborted. For example, changing a DIP16 to an SMD16A is a legitimate 
change as the pin numbers match. Changing a DIP16 to a TO-3 would generate a warning and the change would be aborted. If 
the change is successful the connection lines will also be updated to remain connected to the appropriate pads. 
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The unique ID can be reset for a schematic component. The corresponding PCB footprint will still carry the previous ID entry. In 
this case, you must re-link the two components in the Edit Component Links between Flattened Project and PCB dialog and 
push the change through to the PCB component footprint. 

 

It is important to note that graphical changes to a component footprint directly on the PCB, through modification of its primitives, 
affect only that instance of the component footprint. The changes do not affect the component footprint in the source PCB 
Library document. In general, modifications to component footprints should be carried out within the source footprint library 
(*.PcbLib) and then the changes pushed through to all instances of those footprints that have been placed on the PCB 
document, using the applicable Update command available from the PCB Library Editor's main Tools menu or the PCB Library 
panel. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 

 

Component Designators 
Component designators will auto-increment by 1 during placement if the initial component has a designator ending with a 
numeric character. Change the designator of the first component, prior to placement, from the Place Component dialog 
(accessed upon entering placement mode, or during placement by pressing the TAB key). 

To achieve alpha or numeric designator increments other than 1, use the Paste Array feature. Controls for this feature are 
provided in the Setup Paste Array dialog, accessed by pressing the Paste Array button in the Paste Special dialog (Edit » 
Paste Special). 
By setting the designator of the component prior to copying it to the clipboard 
and setting the Text Increment field in the Setup Paste Array dialog, the 
following types of component designator sequences can be placed: 
• numeric (eg. 1, 3, 5) 

• alphabetic (eg. A, B, C) 

• alphanumeric (eg. A1, A2; 1A, 1B; A1, B1; 1A, 2A, etc) 

To increment numerically set the Text Increment field to the amount you 
wish to increment by. For example, if the initial component had a designator 
of U1 and the Text Increment field was set to 2, the component footprints 
placed would have the designators U1, U3, U5 and so on. 

To increment alphabetically, set the Text Increment field to the letter in the alphabet that represents the number of letters you 
wish to skip. For example, if the initial component had a designator of 1A and the Text Increment field was set to C, the 
component footprints placed would have the designators 1A, 1D, 1G and so on. 
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3D Body 

       

Description 
A 3D body is a primitive polygon type design object that can be placed into a library component footprint or PCB document, on 
any enabled mechanical layer. It can be used to specifically define the physical size and shape of a component - both in the 
horizontal and vertical planes - enabling more precise and controlled component clearance checking by the Design Rule 
Checker.  
3D bodies are used in 3D mode [shortcut: 3] to render a thee-dimensional shape for the component or object. When creating 3D 
bodies, multiple individual 3D bodies may be used to define relatively complex shapes. This can prove especially useful in the 
vertical plane, as it allows you to vary the height of a component in different regions of that component. 

The 3D body object also acts as a placeholder for embedded or linked 3D STEP model files. The ability to handle STEP file 
imports in this way improves ECAD-MCAD compatibility in that it is possible for mechanical models representing non-board 
mounted, free-floating design objects, such as housings or enclosures, to be brought into Altium Designer and accurately 
assembled in the 3D workspace. The benefits to this being the ability to visually and accurately verify designs, including 
clearance checking between all types of 3D bodies, from directly within Altium Designer. 

Availability 
3D bodies are available for placement in the PCB and PCB Library Editors. They can be manually placed by selecting Place » 
3D Body [shortcut: P, B].  

In addition, potential 3D bodies - automatically created based on bounding rectangles and closed polygonal outlines of 
component footprint primitives - can be added/removed using the 3D Body Manager dialog. Two variants of the dialog are 
available, one for managing 3D bodies for the active component footprint and one for managing 3D bodies for the entire active 
library/board. This semi-automated management of 3D bodies is primarily intended for use at the source library level, but 
management dialogs are also available in the PCB design, allowing you to add/remove 3D bodies on-the-fly, as design 
requirements dictate. Method of access to the respective 3D Body Manager dialogs depends on the editor you are in: 

PCB Library Editor 
• to manage 3D bodies for the active component footprint, select Tools » Manage 3D Bodies for Current Component 
• to manage 3D bodies for the entire active library, select Tools » Manage 3D Bodies for Library. 

PCB Editor 
• to manage 3D bodies for the entire active design, select Tools » Manage 3D Bodies for Components on Board. 

For more detailed information on using the 3D Body Manager dialogs to add, edit and remove 3D bodies, see Editing Using the 
3D Body Manager Dialogs. 

Placement 
The following placement procedure applies when using the command to place a simple extruded 3D body. 
Note: You can place 3D bodies in either 2D or 3D modes [shortcut: 2 (2D), 3 (3D)]. 

1. After launching the command, the 3D Body dialog appears. Select the Extruded option in the 3D Model Type region. 

2. Use the controls in the Properties region to give the 3D body object an identifying name (Identifier), select which side of the 
board the 3D body is to project from in the vertical sense (Body Side) and select a mechanical layer on which to place it 
(Layer). 

3. Define the Overall Height - this is the distance between the surface of the board to the top surface of the 3D body. 

 Note: You must define an Overall Height to continue. 
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4. Optionally define the Standoff Height - this is the distance between the surface of the board to the bottom surface of the 3D 
body. In effect, the gap between 3D body and board. 

5. Click OK to close the 3D Body dialog and enter placement mode. The cursor will change to a crosshair in 2D mode, or a 
blue-cone cursor in 3D mode.  

6. Position the cursor and click to anchor the starting point for the body, then continue to anchor a series of vertex points that 
define the polygonal shape of the body. 

7. After placing the final vertex point, right-click or press ESC to complete placement of the body. There is no need to "close" 
the polygon as the software will automatically complete the shape by connecting the start point to the final point placed. 

While defining the shape, use SHIFT + SPACEBAR to cycle through various corner modes. Modes available are: any angle, 
45°, 45° with arc, 90° and 90° with arc. Arcs can be increased or decreased in radius using SHIFT + . (period or full stop) or 
SHIFT + , (comma) respectively. Use SPACEBAR to toggle the direction of the corner. 

Use the BACKSPACE key while in placement mode, to remove the last placed vertex point. Repeatedly use this key to 'unwind' 
the outline for the polygon, right back to the initial starting point. 
After finishing the 3D body, the 3D Body dialog will appear. Continue placing further 3D bodies, or click Cancel or press ESC to 
close the dialog. 

The 3D Body dialog has options and controls for further defining the appearance of 3D bodies. Complete the 3D body definition 
by doing the following: 
1. Open the 3D Body dialog for the 3D body (double-click the 3D body or right-click it and select Properties from the pop-up 

menu). 
2. Use the 3D Model Type region of the dialog to determine what the model is. Available options are: 

Extruded - a simple 3D body, made from a flat 2D shape with a height value added to it. 

Generic STEP Model - an embedded or linked STEP model. Linking is available in the PCB Editor only. 

Cylinder - a cylindrical object, created as a STEP model. 

Sphere - a spherical object, created as a STEP model. 

Note: The various editing options change in the 3D Body dialog depending upon which model type is selected. You can also 
redefine the model type at any time. 

3. Use the controls available for each 3D body model type to define it. 

For more information, see Editing via an Associated Properties Dialog in this section. 

Importing a STEP Model as a 3D Body 
Many component vendors supply detailed 3D models for use in popular mechanical CAD packages. Altium Designer can import 
3D STEP models (*.step or *.stp) directly as a 3D body object. This saves time in creating the model yourself and may provide a 
more sophisticated model too. 

STEP files in the AP214 and AP203 formats are supported. The AP203 format does not support coloration - the entire imported 
model will have a generic shading. 

Linked STEP Models 
The STEP model functionality extends to having the models either embedded or linked to the document. Linked STEP files are 
monitored by Altium Designer so that you always have the latest data in your Altium Designer documents, making concurrent 
project management between mechanical and electronics design areas easier. 
The filepaths for linked STEP models have to be set up within Altium Designer as 'watched' folders. This is managed in the PCB 
Editor - Models page of the Preferences dialog (Tools » Preferences). Whenever you link a STEP file, the watched folder 
contents are displayed for you to choose the file from. In other words, you can only link a STEP file if it resides in a watched 
folder. 
Note: Linked STEP models are not supported in the PCB Library Editor. 

Embedding STEP Models 
To embed a STEP model into a PCB or PCB Library document, do the following: 
1. Select Place » 3D Body [shortcut: P, B]. The 3D Body dialog appears. 

2. Select the Generic STEP Model option in the 3D Model Type region. 

3. Click the Embed STEP Model button. The Choose Model dialog appears, where you can browse for the *.step or *.stp file.  

4. Locate the desired STEP file, select it, then click the Open button to close the Choose Model dialog. 
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5. Back in the 3D Body dialog, click OK to close it. The 3D body appears floating on the cursor. 

6. Click in the workspace to place the 3D body object with the selected model loaded into it. 

Linking STEP Models 
To link a STEP model to a PCB document, do the following: 
1. Select Place » 3D Body [shortcut: P, B]. The 3D Body dialog appears. 

2. Select the Generic STEP Model option in the 3D Model Type region. 

3. Click the Link to STEP Model button. The Choose Model dialog appears, which displays the contents of the watched 
folders for you to select the linked file from.  

4. Select the required file and click OK in the Choose Model dialog to close it. 

5. Back in the 3D Body dialog, click OK to close it. The 3D body appears floating on the cursor. 

6. Click in the workspace to place the 3D body object with the selected linked model loaded into it. 

When a linked file is updated, Altium Designer will notify you that the linked file has changed and whether or not you want to 
update it immediately. Even if you choose not to update straight away, the file will be updated the next time the document is 
opened. 

Positioning and Orienting STEP Models 
When a STEP model has been imported, the placeholder 3D body re-sizes to house the model. The STEP model may not be 
oriented correctly in relation to the axes of the PCB document due to the origin used in the originating application. There are 
several methods for graphically positioning STEP models, using reference points (known as snap points) placed on the model to 
manipulate it, and using faces or surfaces on the model in relation to the board. Non-graphical positioning can be carried out 
through the settings in the Generic STEP Model region of the 3D Body dialog. 

Refer to the Integrating MCAD Objects and PCB Designs document for details on positioning and orienting STEP models. 

Editing 
The properties of a 3D body object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method uses the following dialog to edit the properties of a 3D 
body object. 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click the ? button at 
the top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. This dialog feature a units 
toggle control  in the top-left corner that will change the units of 
measurement currently used in the dialog between metric and imperial 
[shortcut: CTRL + Q]. The current unit of measurement is displayed in 
the dialog title area. 

The following sections provide an overview of each of the specific 
regions of the dialog: 

Use the 3D Model Type region of the dialog to determine what the 
model is. Available options are: 

Extruded - a simple 3D body, made from a flat 2D shape with a 
height value (Overall Height) added to it. 
Generic STEP Model - an embedded or linked STEP model. 
Linking is available in the PCB Editor only. 
Cylinder - a cylindrical 3D body object. 

Sphere - a spherical 3D body object. 

Note: The various editing options change in the 3D Body dialog 
depending upon which model type is selected. 
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Use the Properties region of the dialog to define some basic attributes for the model. Available options are: 

Identifier - give the 3D body object an identifying name. Using identifying names makes selecting 3D bodies via the PCB 
panel (in 3D Models mode) faster. The identifier can be used for query scripting using the parameter id. 

Body Side - defines which side of the board the 3D body should project from, in the vertical sense - either Top or Bottom. 

Layer - select a currently enabled mechanical layer to place the 3D body on. Only enabled mechanical layers are displayed. 

Locked - enable to prevent the 3D body from being graphically edited, without requiring confirmation first. 

Use the Display region of the dialog to determine how the 3D body is displayed. Available options are: 

3D Color Opacity - Controls the display opacity of the 3D body from invisible  (left-most) to completely opaque (right-most). 

Note: 3D body display opacity controls are also available in PCB panel when it is in 3D Models mode. 

Click the 3D Color panel to select a color to render the 3D body in via the Choose Color dialog.  

Note: STEP models are unaffected by color settings. 

For Extruded 3D Bodies - use the Overall Height and Standoff Height 
fields to accurately define a component in the vertical sense. The Overall 
Height defines the distance from the board to the topside of the component, 
while the Standoff Height defines the distance from the board to the 
underside of the component. Negative standoff heights will result in the 3D 
body passing through the board.  
For Generic STEP Models - use the Rotation controls to rotate the 
imported STEP model in three axes. The value of the axis will depend on the 
coordinate origin used in the STEP model’s originating application. The 
Standoff Height field determines vertical offset from the board surface. The 
Embed STEP Model and Link to STEP Model buttons facilitate selecting a 
STEP model to embed into the document or to link the document to, 
respectively. Use the Update from Disk button to 'refresh' an embedded 
model file; the Remove button to clear an embedded or linked model file. 
Use the Change to Embedded button to change a linked model file to an 
embedded type. 
For Cylinders - use the Rotation controls to rotate the cylinder model in 
three axes. Cylinders are created in STEP format and are oriented vertically 
by default, so that the value of the Height field determines the cylinder 
length. The Radius field determines the circular size of the cylinder. The 
Standoff Height field determines vertical offset from the board surface. 

For Spheres - use the Radius field to determines the size of the sphere. 
Spheres are created in STEP format .The Standoff Height field determines 
vertical offset from the board surface. 

 

 

 

 

The Snap Points region options of the dialog also pertain to positioning imported STEP files. Snap Points are references to 
specific vertices on the STEP model and can be added graphically in 3D mode (Tools » STEP 3D Body Placement » Add 
Snap Points From Vertices) or manually in this dialog using the Add button and entering the snap point coordinate positions. 
With three or more snap points added, you can reposition and orient the STEP model (Tools » STEP 3D Body Placement » 
Orient and Position STEP Model) using one snap point as an absolute reference and two others as alignment and plane 
references.  

Refer to the Integrating MCAD Objects and PCB Designs document for details on positioning and orienting STEP models. 
The 3D Body dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change the default properties for the 3D body object, which will 
be applied when placing subsequent 3D bodies. 
During placement, the 3D Body dialog can be accessed by pressing the TAB key. 

After placement, the 3D Body dialog can be accessed in the following ways: 

• double-clicking the placed 3D body object 
• selecting the 3D body object, right-clicking and selecting Properties from the pop-up menu 

• Selecting the Edit » Change command (in 2D mode only) from the main menus then clicking once over the placed 3D body 
object. 



Legacy documentation 
refer to the Altium Wiki for current information

PCB Editor and Object Reference 

26 TR0112 (v2.5) May 22, 2008 

Editing via the PCB Panel 
The PCB panel enables you to interrogate and edit the properties of 3D body objects in the active document. Set the mode to 
3D Models (list at top of panel) and the regions of the panel will show 3D models based on PCB components as well as "Free 
Models". Free models are non-PCB mounted, free-floating 3D bodies, such as a mechanical PCB housing. The panel controls 
allow you to identify, select and edit models (double-click an entry in the Models section to open the 3D Body dialog for it). The 
3D Bodies Display Options controls allow you to over-ride the current view configurations settings for the display of 3D bodies. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 

Editing via the PCBLib List Panel 
The PCBLib List panel allows you to display library objects in tabular format, enabling you to quickly inspect and modify 3D 
body properties. You can filter certain object types from the list using the panel controls. When used in conjunction with the PCB 
Filter panel, it enables you to display just those objects falling under the scope of the active filter - allowing you to target and 
edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Editing Using the 3D Body Manager Dialogs 
This method of editing allows you to manage 3D bodies for either the active component footprint or the entire active library/PCB 
design. In both cases, a variant of the 3D Body Manager dialog is used. The 3D Body Manager dialog is used the same way in 
both library and design editors, however, in the PCB Editor only the 3D Body Manager dialog for the entire PCB can be 
accessed. 
Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click the ? button 
at the top right of the dialog and then click over a field or option to pop-up information specific to that field or option. This dialog 
feature a units toggle control  in the top-left corner that will change the units of measurement currently used in the dialog 
between metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is displayed in the dialog title area. 

Managing Bodies for the Active Component Footprint 
Management of 3D bodies for the active component footprint is carried out in the PCB Library Editor using the 3D Body 
Manager for component… dialog. The following image shows the dialog when accessed for a DIP14 component footprint.  

The dialog provides a list of existing and potential extruded 3D bodies. An existing 3D body is one that has already been added 
to the component, for example by placing a 3D body primitive while defining the graphics for the footprint in the source PCB 
library. Such entries will be displayed in the list in the following format: 

3D Body on Mechanicaln (BodyArea) 

where, 

n is the specific mechanical layer number 

BodyArea is the area of the 3D body (either sq. mils or sq. mm, depending on measurement units). 
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A potential 3D body is a shape that has been automatically created by the software, based on detected elements on particular 
layers. The shape for the candidate body may be formed by: 

• creating a polygonal closed shape from the primitives used for the component footprint on a particular layer (eg. TopOverlay, 
BottomOverlay) 

• using the bounding rectangle found for the component footprint on a particular layer (eg. TopOverlay, MultiLayer, All Layers). 

Such entries will be displayed in the list in the following formats: 

Shape created from bounding rectangle on Layer (BodyArea) 

Polygonal shape created from primitives on Layer (BodyArea) 

where, 

Layer is the scope, in terms of layer, on which the element(s) for 
the body's shape have been detected 

BodyArea is the area of the 3D body (again, either sq. mils or sq. 
mm, depending on the current measurement units employed for the 
document). 

As you click on the description for a 3D body in the list, a preview 
of its shape is displayed in the lower-right window of the dialog. 
The lower-left window of the dialog displays the active component 
footprint, along with all 3D bodies currently added to it. 

To add a potential 3D body to the component footprint, click inside 
the corresponding Action field for that body. The field will change 
from Add To ComponentName (i.e. not currently added) to 
Remove From ComponentName (i.e. currently added) and the 
body's shape will be added to the lower-left display window. 

To remove a 3D body from the footprint, click Remove From … in the Action column. 

Note: You can only add potential 3D bodies to a footprint. Potential body shapes will remain listed, so if you add a potential 
body, then remove it, you can add it again from the list in the future. If you have manually placed a 3D body and then remove it 
using the dialog, it will not remain in the list for future addition. You must place it again manually using the Place » 3D Body 
command. 
Use the Registration Layer field to select which mechanical layer the 3D body is placed. You can assign a 3D body to any one 
of the 16 possible mechanical layers. The chosen layer will be enabled (if not already). 
Use the Body Projection field to define on which side of the board the 3D body should project in the vertical sense - either the 
Top Side or the Bottom Side. 
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Use the Standoff Height and Overall Height fields to define a component in the vertical sense. The Standoff Height defines 
the distance from the board to the underside of the component, while the Overall Height defines the distance from the board to 
the topside of the component. Negative standoff heights will result in the 3D body passing through the board. 
Click the color in the Body 3D Color column to select a new color for the 3D body object via the Choose Color dialog. 

Changes to the 3D body properties will be reflected in the associated properties dialog for the added 3D body. Conversely, 
changes made in the properties dialog will be reflected in the 3D Body Manager dialog. 

Managing Bodies for the Entire Active Library/Design 
Management of 3D bodies for the active component footprint library or PCB design is carried out in the PCB Editor and PCB 
Library Editor using the 3D Body Manager dialog. The following image shows the dialog when accessed for a component 
footprint library. 

The top region of the dialog lists each component footprint in the active library (in the actual design this would be a list of all 
components on the board). For each entry, designator (available on design side only), footprint name, height and source library 
information is displayed. 
The lower region of the dialog provides two tabs - Interactive and Batch Update. The Interactive tab provides exactly the 
same management features as the variant of the dialog accessed for the current component footprint. Refer to the previous 
section for more detail. 

 

The Batch Update tab provides a facility for quickly adding 3D body objects to all or selected footprints in a library, or all or 
selected placed footprints in a design.  

The main region of the tab is where you define search criteria for detecting and creating 3D bodies, and for defining 3D body 
properties, such as Projection Side (also referred to as Body Projection), Registration Layer, Standoff Height, Overall 
Height and 3D Body Color. 
Each entry in the list provides a different scope in terms of the layers that will be searched when detecting and creating possible 
3D body shapes. Each search is individually enabled using the Enabled column option. Multiple searches can be enabled, but 
bear in mind that a 3D body will be added for each successful search. Typically, you would enable a search on one particular 
layer - or layer set - depending on where you typically place the primitives or component outline information for a footprint. 

By default, a search of All Layers will be performed. 
The Detection Method field allows you to control how each 3D body shape is defined: 

• Bounding Rectangle - use the bounding rectangle of the footprint 
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• Closed Shapes - use polygonal closed shape created from component footprint primitives 

• Both (Prefer Closed Shapes) - detect either a bounding rectangle or a polygonal closed shape based on the footprint's 
primitives. If both are detected, use the polygonal closed shape. 

The Prefer component height if not 0 option allows you to control whether or not the height attribute defined for a component 
footprint is used as the Overall Height for the 3D body. With this option enabled, for each component with a defined height 
attribute greater than zero, that height will be set as the added 3D body's Overall Height and its Standoff Height will be set to 
zero. The Body 3D Color specifies the color to render the 3D body in. Click on the color to change it via the Choose Color 
dialog. 

 

Once the search and property criteria are defined, use the Options region to define two more options: 

• Apply Only To Selected Components - enable this option if you want to apply the 3D body criteria to only a selected group 
of footprints. Ensure that those components are selected in the top region of the dialog (use standard CTRL + Click and 
SHIFT + Click features to multi-select). If this option is disabled, the batch add process will be applied to all footprints in the 
library (or all components on the board). 

• Delete Existing Bodies In Components - enable this option to remove any currently defined 3D bodies for the footprints 
targeted by the batch process. 

Use the preview window at the bottom-right of the tab to get an idea of how the added 3D body will look, based on the currently 
selected component footprint and currently selected (and enabled) search entry. 
After defining all options for the batch process as required, click the Execute Batch Update button. The search will proceed for 
each footprint included in the process and, where a 3D body shape is detected and created, that body will be added to the 
footprint using the defined property criteria. 

Graphical Editing 
This method of editing allows you to select a placed extruded 3D body object in the 2D workspace and change its size, shape, 
location or orientation, graphically. 3D bodies that house STEP models, apart from location and orientation, cannot be edited 
graphically. 

When an extruded 3D body object is selected, editing handles are displayed at each vertex: 

When the cursor changes to  over a handle, click and drag to move the vertex. When this 
cursor appears over the middle of an object edge, click & drag to add a vertex to that edge and 
move it.  

When the cursor changes to  over an object edge, click & drag to move that edge of the 3D 
body. 

When the cursor changes to  over the object, click and drag to move the 3D body. The 3D body can be rotated or flipped 
while dragging: 
• press the SPACEBAR to rotate the 3D body anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 



Legacy documentation 
refer to the Altium Wiki for current information

PCB Editor and Object Reference 

30 TR0112 (v2.5) May 22, 2008 

• press the X or Y keys to flip the 3D body along the X-axis or Y-axis respectively. 

Notes 
The height properties of extruded 3D bodies allow you to accurately define a component in the vertical sense. The Standoff 
Height defines the distance from the board to the underside of the component, while the Overall Height defines the distance 
from the board to the topside of the component. Negative standoff heights will result in the 3D body passing through the board. 

 

The Design Rules Checker does not check for 3D bodies passing through the board surface. 

 

When used in conjunction with an appropriately configured Component Clearance design rule, two components, one larger than 
the other and each with defined 3D body primitives possessing specific height attributes, could be successfully stacked without 
violation. To pass component clearance checking, the 3D bodies would need to be defined such that: 

• horizontally, the body of the smaller component fits under the larger component, with a minimum horizontal gap between the 
two specified by the associated Component Clearance rule 

• vertically, the body of the smaller component fits under the body of the larger component, with a minimum horizontal gap 
between the two specified by the associated Component Clearance rule. 

 

When checking for component clearance violations, all types of 3D body object are used. The greater the accuracy of the 3D 
body, the greater the accuracy in component clearance checking. Components with no 3D body primitives are checked by using 
a combination of their bounding rectangle and height property.  

 

The 3D Body Manager dialog provides a quick way for defining and adding component bodies to footprints, through its auto-
detection and creation of base 3D body shapes. When used in Batch mode, this can allow you to quickly add 3D bodies to a 
whole library, and subsequently update the placed components with those changes. You can then use these added 3D bodies 
to perform component clearance checking with greater control. Note: Although the 3D Body Manager dialogs provide a fast, 
efficient means of adding 3D bodies, these are basic in shape. For the most part that will be fine, but for component footprints 
with irregular shapes, you will need to hand-craft the 3D body required. This becomes even more necessary if the required 
complexity of the component requires multiple 3D body objects of irregular shape and differing height. 

 

Should you explode a component in the PCB Editor, and that component has a 3D body defined for it, the 3D body will behave 
as another primitive object. It will not be used in any way while it is disassociated from a component. To use such a 'floating' 3D 
body primitive, you would need to add it to an existing component (appropriately sized and shaped) using the Tools » Convert 
» Add Selected Primitives to Component command. 

 

If you attempt to graphically modify a 3D body object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Connection 

 

Description 
Connection lines are the visual representation of the logical connectivity between net objects. Each of these lines, connecting 
one pin in a net to another pin in the net, is called a From To. The entire set of connections (From Tos) for a design is often 
referred to as the 'ratsnest'. 

The connection lines are subsequently used when interactively routing (or Autorouting) in order to achieve the physical, routed 
links between the logically connected objects in each net. 

Availability & Placement 
Default connections (From Tos) are automatically generated and placed by the PCB's Connectivity Analyzer when nets are 
loaded into the PCB design document (i.e. when importing the design or design changes from the schematic). As such, a 
connection is not a design object that can be accessed and placed by the user. 

Editing 
A connection object cannot be edited with respect to properties in the usual manner - it cannot be selected in the workspace, 
has no corresponding properties dialog and cannot be edited graphically. 

The layer upon which connection lines are displayed can be enabled/disabled with respect to its visibility using the 
corresponding Show checkbox for Connections and From Tos, in the System Colors region, Board Layers And Colors 
page of the View Configurations dialog (Design » Board Layers & Colors). 

 

Define the display color by clicking on the color swatch to bring up the 2D System Colors dialog, from where you can choose 
from a range of predefined colors, or create your own custom color. You can save any view configurations for use in other 
projects. 

You can control which connection lines in the entire ratsnest of connections are shown and which are hidden. Use the available 
commands on the View » Connections sub-menu to: 

• show or hide all connection lines for the design 

• show or hide all connection lines associated with a chosen net 

• show or hide the connection lines for all nets associated with chosen component. 

Notes 
When the components and connective (net) information are loaded into a PCB design, the pin-to-pin connections are displayed 
for each net. These connection lines are in fact system-generated From Tos, added and arranged by the PCB Editor to give the 
shortest overall connection length in each case - a net topology referred to as Shortest. 

 

The topology of part or all of a net can be changed by adding specific, user-defined From Tos. User-defined From Tos are 
added using the PCB panel configured in From-To Editor mode. 

For more information on a specific panel, press F1 when the cursor is over the panel. 
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A system-generated From To does not appear in the workspace as a separate entity - only the associated pin-to-pin connection 
line for the From To is displayed, which is used for interactive routing/Autorouting guidance. 

 

A user-defined From To appears in the workspace as a dotted line, separate and distinct from the pin-to-pin connection line that 
is also displayed when the From To is added. The user-defined From To line controls where the associated pin-to-pin 
connection line starts and finishes. 

 

If you specify user-defined From Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-
generated From Tos) to the Shortest topology. 

 

The type of From To determines how the Connectivity Analyzer treats the pin-to-pin connection line when, for example, a net 
object is moved or part of a net is manually routed: 
• System-generated From To - the connection line can be moved as required as part of the Connectivity Analyzer's re-

optimization to keep the default topology of the net (i.e. Shortest) 
• User-defined From To - if the From To is not the result of selecting a predefined topology, the connection line is not 

considered as part of the Connectivity Analyzer's re-optimization process. If the From To is part of a predefined net topology 
(other than Shortest), the Connectivity Analyzer can include it in re-optimization, so long as the chosen topology is kept. 

 

During component moves, connection lines are automatically hidden, except those that go from a moving component to a non-
moving component. If currently hidden, the connection lines that are part of the move are automatically displayed. 

 

Connectivity During Interactive Routing 
The PCB Editor is a connectivity-aware design environment. At all stages of routing your design, the software monitors and 
manages the netlist connectivity. Because the PCB's Connectivity Analyzer automatically monitors the completion status of the 
net you are routing, you can route without regard to the arrangement of the pin-to-pin connections. Once you complete a 
connection, the entire net is reanalyzed and connection lines are added and re-optimized as necessary. 

There are two distinct advantages to this methodology. The first is that you can route a track to any primitive on the net, you do 
not have to route between the two points connected by the connection lines. The Connectivity Analyzer monitors your progress 
and adds and removes the connection lines automatically. The second is that the net connectivity is "unbreakable", you cannot 
accidentally break it into two unconnected parts. If you delete a track segment, the software detects the break and immediately 
adds a connection line to restore the net connectivity. 

When a net is analyzed and a connection line added, the software automatically adds it based on the topology of the net. By 
default, all nets have their topology set to shortest. For these nets a from-to is added where the two sub-nets are closest. 

If the net has a user-defined topology applied, the connection line is added to maintain the topology and is shown as a dotted 
line (called a Broken Net Marker), indicating that the net should be routed between these two points to maintain the topology. 

 

If the Smart Track Ends option is enabled on the PCB Editor - General page of the Preferences dialog (Tools » 
Preferences), the connectivity Analyzer will attempt to keep connection lines attached to the ends of the tracks. For example, if 
you start routing from a pad, and then stop the routing (leaving the track end in free space), the Analyzer will attach the 
connection line to the track end. 
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Coordinate 

 

Description 
A coordinate is a group design object. It is used to mark the X (horizontal) and Y (vertical) distance of a point in the design 
workspace with respect to the current origin. Coordinates can be placed on any layer. 

Availability 
Coordinates are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Coordinate [shortcut: P, O] from the PCB Editor main menus 

• click the  button on the Utility Tools drop-down of the Utilities toolbar. 

PCB Library Editor 
• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » Coordinate from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter coordinate placement mode. Position the 
cursor and click or press ENTER to place a coordinate. 

Continue placing further coordinates, or right-click or press ESC to exit placement mode. 

Editing 
The properties of a coordinate object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a 
coordinate object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right 
of the dialog and then click over a field or option to pop-up information specific 
to that field or option. This dialog feature a units toggle control  in the top-
left corner that will change the units of measurement currently used in the 
dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

The Coordinate dialog can be accessed prior to entering placement mode, 
from the PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the 
coordinate object, which will be applied when placing subsequent coordinates. 

During placement, the Coordinate dialog can be accessed by pressing the 
TAB key. 

After placement, the Coordinate dialog can be accessed in the following ways: 

• double-clicking on the placed coordinate object 
• right-clicking the coordinate object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed coordinate object. 



Legacy documentation 
refer to the Altium Wiki for current information

PCB Editor and Object Reference 

34 TR0112 (v2.5) May 22, 2008 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed coordinate object directly in the workspace and change its location 
graphically. The size and shape of a coordinate object cannot be changed graphically. As such, editing handles are not 
available when the coordinate object is selected: 

Click anywhere on the coordinate and drag to reposition it. The position values 
are automatically updated as the coordinate is moved. 

Notes 
If you attempt to graphically modify a coordinate object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit. 

 

The coordinate group object is comprised of a string specifying the actual X,Y position and a point marker (small cross of two 
tracks). In the PCB Editor, coordinate objects can be converted to their set of primitive objects by choosing Tools » Convert » 
Explode Coordinate to Free Primitives from the main menus. Explode a coordinate when you need to reposition the position 
string without changing the location of the marker. Once exploded, a coordinate object can no longer be manipulated as a group 
object. 

 

Coordinate text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

Coordinate units, imperial (mil) or metric (mm), are determined by the Measurement Unit setting in the Board Options dialog 
(Design » Board Options). 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Linear Dimension 

 

Description 
A linear dimension is a group design object. It places dimensioning information on the current PCB layer, with respect to a linear 
distance. The dimension value is the distance between the start and end markers (reference points selected by the user) 
measured in the default units. The references may be objects (tracks, arcs, pads, vias, text, fills, polygons or components) or 
points in free space. 

Availability 
Linear dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Linear [shortcut: P, D, L] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Linear from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension start point (this is the first reference point) 

• move the cursor and click or press ENTER to anchor the dimension end point (this is the second reference point) 

• the text can now be initially positioned. Move the cursor and click or press ENTER when the text is in the desired position, to 
complete dimension placement. 

Continue placing further linear dimensions, or right-click or press ESC to exit placement mode. 

The linear dimension object can be rotated during placement. Press the SPACEBAR to rotate the dimension anti-clockwise or 
SHIFT + SPACEBAR for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the PCB 
Editor - General page of the Preferences dialog (Tools » Preferences). 

Editing 
The properties of a linear dimension object can be modified 
before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the 
properties of a linear dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click 
over a field or option to pop-up information specific to that field or 
option. This dialog feature a units toggle control  in the top-left 
corner that will change the units of measurement currently used in 
the dialog between metric and imperial [shortcut: CTRL + Q]. The 
current unit of measurement is displayed in the dialog title area. 

The Linear Dimension dialog can be accessed prior to entering 
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placement mode, from the PCB Editor - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to 
change the default properties for the linear dimension object, which will be applied when placing subsequent linear dimensions. 
During placement, the Linear Dimension dialog can be accessed by pressing the TAB key. 

After placement, the Linear Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed linear dimension object 
• right-clicking the linear dimension object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed linear dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed linear dimension object directly in the workspace and change properties 
such as the position of its text and its reference points, graphically. 

When a linear dimension object is selected, the following editing handles are available: 

Click & drag A or B to adjust the dimension text position and extension line length. 

Click & drag C or D to move the start or end reference points of the dimension. 

C and D allow for redefinable references - once the dimension is detached from a 
reference object it becomes non-referenced and can be moved for attachment to a 
different reference point or object. 

As you drag any of the editing handles, the dimension may be rotated. 

If the linear dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on 
it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is 
performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-axis respectively. 

Notes 
When dimensioning an object, anchor points become available, highlighting where the 
dimension can be attached. Depending on the location of the cursor in relation to the object, 
one of the anchor points will highlight in a different color, specifying where the dimension will 
attach if you proceed to click or press ENTER. 

You do not have to be exactly on the point for the anchor to highlight. 

 

A linear dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object(s) it is dimensioning. 

 

If you attempt to graphically modify a linear dimension object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit. 
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Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either 
reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this. 

 

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the 
dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Linear dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Angular Dimension 

 

Description 
An angular dimension is a group design object. It allows for the dimensioning of angular distances. 

Availability 
Angular dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Angular [shortcut: P, D, A] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Angular from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor over the first reference object and click or press ENTER to anchor the first dimension reference (the 

inside reference) 
• move the cursor to the next required position associated with the first object being dimensioned and click or press ENTER to 

anchor the second dimension reference (the outside reference) 
• position the cursor over the second reference object and click or press ENTER to anchor the third dimension reference (the 

inside reference) 

• move the cursor to the next required position associated with the second object being dimensioned and click or press 
ENTER to anchor the fourth dimension reference (the outside reference) 

• place the dimension text for the angle as desired and then click or press ENTER to complete placement. 

Continue placing further angular dimensions, or right-click or press 
ESC to exit placement mode. 

Editing 
The properties of an angular dimension object can be modified 
before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the 
properties of an angular dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click 
over a field or option to pop-up information specific to that field or 
option. This dialog feature a units toggle control  in the top-left 
corner that will change the units of measurement currently used in 
the dialog between metric and imperial [shortcut: CTRL + Q]. The 
current unit of measurement is displayed in the dialog title area. 
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The Angular Dimension dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change the default properties for the angular dimension object, 
which will be applied when placing subsequent angular dimensions. 
During placement, the Angular Dimension dialog can be accessed by pressing the TAB key. 

After placement, the Angular Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed angular dimension object 
• right-clicking the angular dimension object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed angular dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed angular dimension object directly in the workspace and change properties 
such as the position of its text and its reference points, graphically. 

When an angular dimension object is selected, the following editing handles are available: 

Click & drag A or B to change the position of the dimension text and extension line 
length. 

Click & drag C and E to detach the dimension from the first reference object. 

Click & drag D and F to detach the dimension from the second reference object. 

C & E and D & F allow for redefinable references - once the dimension is detached 
from a reference object it becomes non-referenced and can be moved for attachment 
to a different reference point or object. 

If the angular dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere 
on it - away from editing handles - and drag to reposition it. The angular dimension can be rotated or flipped while dragging: 
• press the SPACEBAR to rotate the angular dimension anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. 

Rotation is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the 
Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the angular dimension along the X-axis or Y-axis respectively. 

Notes 
When dimensioning an object, anchor points become available to you, highlighting where the 
dimension can be attached. Depending on the location of the cursor in relation to the object, 
one of the anchor points will highlight in a different color, specifying where the dimension will 
attach if you proceed to left- click or press ENTER. 

You do not have to be exactly on the point for the anchor to highlight. 

 

An angular dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned 
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• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify an angular dimension object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either 
reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this. 

 

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the 
dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Angular dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Radial Dimension 

 

Description 
A radial dimension is a group design object. It allows for the dimensioning of a radius with respect to an arc or circle. The 
dimension can be placed either internally or externally. The dimension must be placed on the layer same that the arc being 
measured is on. This is in order to create an association with the arc. The dimension can be moved to a different layer and the 
association will remain, so any changes to the arc will update the dimension. 

Availability 
Radial dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Radial [shortcut: P, D, R] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Radial from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension to the desired arc or circle 

• move the dimension's arrow pointer to the desired location around the arc or circle. The arrow can be placed either inside or 
outside and movement is in accordance with the Angular Step value in the Radial Dimension dialog. When the required 
position has been attained, click or press ENTER to lock the arrow in place 

• the text can now be initially positioned in relation to the tail of the arrow pointer. Move the text into the required position and 
click or press ENTER to complete placement. 

Continue placing further radial dimensions, or right-click or press ESC to exit dimension placement mode. 

Editing 
The properties of a radial dimension object can be modified 
before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the 
properties of a radial dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click 
over a field or option to pop-up information specific to that field or 
option. This dialog feature a units toggle control  in the top-left 
corner that will change the units of measurement currently used 
in the dialog between metric and imperial [shortcut: CTRL + Q]. 
The current unit of measurement is displayed in the dialog title 
area. 

The Radial Dimension dialog can be accessed prior to entering 



Legacy documentation 
refer to the Altium Wiki for current information

PCB Editor and Object Reference 

42 TR0112 (v2.5) May 22, 2008 

placement mode, from the PCB Editor - Defaults page of the Preferences dialog (Tools » Preferences). This allows you to 
change the default properties for the radial dimension object, which will be applied when placing subsequent radial dimensions. 
During placement, the Radial Dimension dialog can be accessed by pressing the TAB key. 

After placement, the Radial Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed radial dimension object 
• right-clicking the radial dimension object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed radial dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed radial dimension object directly in the workspace and change properties 
such as the position of its text, the location of its arrow pointer and its reference point, graphically. 

When an radial dimension object is selected, the following editing handles are available: 

Click & drag A to adjust the dimension text position, relative to the 'tail' of 
the arrow pointer. 

Click & drag B to adjust the position of the arrow pointer around the 
circumference of the circle or arc. 
Click & drag C to move the start point of the dimension. This handle allows 
you to redefine the reference - once the dimension is detached from a 
reference object it becomes non-referenced and can be moved for 
attachment to a different reference point or object. 

If the dimension text is placed within the circumference of the arc or circle, only two of the three editing handles will be available 
for use - A and C. Editing handle A will assume the additional role of editing handle B. 

If the radial dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on 
it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging: 
• press the SPACEBAR to rotate the radial dimension anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation 

is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the radial dimension along the X-axis or Y-axis respectively. 

Notes 
A radial dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension pointer and tail will expand/contract to keep the relationship between dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify a radial dimension object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit. 
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Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as the radius of the arc or circle changes. 

 

When the reference arc or circle to which a radial dimension object is attached is deleted, a dialog will appear, asking whether 
the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Radial dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Leader Dimension 

 

Description 
A leader dimension is a group design object. It allows for the labeling of an object, point or area. There are three types of leader 
available: Standard, Round and Square, which reflect the label text either being encapsulated in a circle or square or not at all. 
The pointer can be an arrow or a dot. 

Availability 
Leader dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Leader [shortcut: P, D, E] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Leader from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension start point (this is the location of the arrowhead or dot) 

• move the cursor and click or press ENTER to anchor a series of vertex points that define the shape of the leader 

• after placing the final required vertex point, right-click or press ESC to effect placement of the text label and exit placement 
mode.  

Editing 
The properties of a leader dimension object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the 
properties of a leader dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the question 
mark button at the top right of the dialog and then click over a field or 
option to pop-up information specific to that field or option. This dialog 
feature a units toggle control  in the top-left corner that will change 
the units of measurement currently used in the dialog between metric 
and imperial [shortcut: CTRL + Q]. The current unit of measurement 
is displayed in the dialog title area. 

The Leader Dimension dialog can be accessed prior to entering 
placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change 
the default properties for the angular dimension object, which will be 
applied when placing subsequent angular dimensions. 
During placement, the Leader Dimension dialog can be accessed by pressing the TAB key. 
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After placement, the Leader Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed leader dimension object 
• right-clicking the leader dimension object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed leader dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed leader dimension object directly in the workspace and change properties 
such as the position of its text, its shape and its reference point, graphically. 

When a leader dimension object is selected, the following editing handles are available: 

Click & drag A to move the start point of the dimension (i.e. the position of the arrowhead). This 
handle allows you to redefine the reference - once the dimension is detached from a reference 
object it becomes non-referenced and can be moved for attachment to a different reference point or 
object. 

Click & drag B to move the end point of the dimension (i.e. the position of the text label). 

Click & drag intermediate handles to change the shape of the leader. 

If the leader dimension object is totally non-referenced (i.e. it is not attached to any reference 
design objects), click anywhere on it - away from editing handles - and drag to reposition it. The 
dimension can be rotated or flipped while dragging: 

• press the SPACEBAR to rotate the leader dimension anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation 
is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the leader dimension along the X-axis or Y-axis respectively. 

Notes 
When dimensioning an object, anchor points become available to you, highlighting where the 
dimension can be attached. Depending on the location of the cursor in relation to the object, one 
of the anchor points will highlight in a different color, specifying where the dimension will attach if 
you proceed to left- click or press ENTER. 

You do not have to be exactly on the point for the anchor to highlight. 

 

A leader dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension will follow the object. The segment of the leader 
dimension - between the arrow/dot and the first defined elbow - will expand/contract to keep the relationship between 
dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 
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If you attempt to graphically modify a leader dimension object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note: the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

When the reference to which a leader dimension object is attached is deleted, a dialog will appear, asking whether the 
dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Leader dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Datum Dimension 

 

Description 
A datum dimension is a group design object. It allows for the dimensioning of a linear distance of a collection of objects, relative 
to a single reference object. The first object chosen is the 'base'. All subsequent objects are relative to this first object. The 
dimension value in each case is therefore the distance between each reference object and the 'base', measured in the default 
units. The references may be tracks, arcs, pads, vias, text, fills, polygons or components. 

Availability 
Datum dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Datum [shortcut: P, D, T] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Datum from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension start point (this is the first reference object or 'base') 

• move the cursor to the next required object and click or press ENTER to anchor the dimension end point (this is the second 
reference object) 

• move the cursor to subsequent reference objects and click or press ENTER. When all desired objects have been selected, 
right-click or press ESC 

• the text can now be initially positioned. Click or press ENTER when the text is in the desired position to complete placement 
and exit placement mode. 

The datum dimension object can be rotated during placement. Press the SPACEBAR to rotate the dimension anti-clockwise or 
SHIFT + SPACEBAR for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the PCB 
Editor - General page of the Preferences dialog (Tools » Preferences). 

Editing 
The properties of a datum dimension object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a datum dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. This dialog feature a units toggle control  in the top-left corner that will change the units of measurement currently 
used in the dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is displayed in the dialog 
title area. 
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The Datum Dimension dialog can be accessed prior to entering 
placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to 
change the default properties for the datum dimension object, which 
will be applied when placing subsequent datum dimensions. 

During placement, the Datum Dimension dialog can be accessed by 
pressing the TAB key. 

After placement, the Datum Dimension dialog can be accessed in 
the following ways: 

• double-clicking on the placed datum dimension object 

• right-clicking the datum dimension object and selecting 
Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over 
the placed datum dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the 
properties of one or more design objects in the active document. 
Used in conjunction with appropriate filtering, the panel can be used 
to make changes to multiple objects of the same kind, from one 

convenient location. 
For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed datum dimension object directly in the workspace and change properties 
such as the position of its text and its reference points, graphically. 

When a datum dimension object is selected, the following editing handles are available: 

Click & drag any of the handles at the text end of the extensions to 
adjust the dimension text position for all cases simultaneously. 

Click & drag A to move the base point of the dimension. 

Click & drag subsequent handles to move each reference 
individually, with respect to the base. 

All handles nearest to the object(s) being dimensioned allow for 
redefinable references - once the dimension is detached from a 
reference object it becomes non-referenced and can be moved for 
attachment to a different reference point or object. 

As you drag any of the editing handles, the dimension may be rotated. 

If the datum dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click anywhere on 
it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging. The latter is 
performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-axis respectively. 

Notes 
When dimensioning an object, anchor points become available to you, highlighting where the 
dimension can be attached. Depending on the location of the cursor in relation to the object, 
one of the anchor points will highlight in a different color, specifying where the dimension will 
attach if you proceed to click or press ENTER. 

You do not have to be exactly on the point for the anchor to highlight. 
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A datum dimension object can be moved in the following ways: 

• selecting both the dimension object and the object(s) being dimensioned. The whole can be dragged to a new location as 
required 

• selecting an object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify a datum dimension object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note that the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either 
reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this. 

 

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the 
dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Datum dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Baseline Dimension 

 

Description 
A baseline dimension is a group design object. It allows for the dimensioning of a linear distance of a collection of references, 
relative to a single base reference. The first point chosen is the 'base'. All subsequent points are relative to this first point. The 
dimension value in each case is therefore the distance between each reference point and the 'base', measured in the default 
units. The references may be objects (tracks, arcs, pads, vias, text, fills, polygons or components) or points in free space. 

Availability 
Baseline dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Baseline [shortcut: P, D, B] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Baseline from the pop-up menu. 

Placement  
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension start point (this is the first reference point or 'base') 

• move the cursor to the required end point and click or press ENTER to anchor the dimension end point (this is the second 
reference point) 

• the text can now be initially positioned. Click or press ENTER when the text is in the desired position to effect placement 

• move the cursor to subsequent reference points and click or press ENTER twice to effect placement (first click to anchor to a 
reference and second click after positioning the text) 

• when all required references in the baseline dimension have been covered, right-click or press ESC to exit placement mode.  

The baseline dimension object can be rotated during placement. Press the SPACEBAR to rotate the dimension anti-clockwise 
or SHIFT + SPACEBAR for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the 
PCB Editor - General page of the Preferences dialog (Tools » Preferences). 

Editing 
The properties of a baseline dimension object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a baseline dimension object: 
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Use the dialog's 'What's This Help' feature to obtain detailed information 
about each of the options available. Click on the question mark button at 
the top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. This dialog feature a units 
toggle control  in the top-left corner that will change the units of 
measurement currently used in the dialog between metric and imperial 
[shortcut: CTRL + Q]. The current unit of measurement is displayed in 
the dialog title area. 

The Baseline Dimension dialog can be accessed prior to entering 
placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change 
the default properties for the baseline dimension object, which will be 
applied when placing subsequent baseline dimensions. 

During placement, the Baseline Dimension dialog can be accessed by 
pressing the TAB key. 

After placement, the Baseline Dimension dialog can be accessed in the 
following ways: 

• double-clicking on the placed baseline dimension object 
• right-clicking the baseline dimension object and selecting Properties 

from the pop-up menu 
• selecting the Edit » Change command, then clicking once over the placed baseline dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed baseline dimension object directly in the 
workspace and change properties such as the position of its text and its reference points, 
graphically. 

When a baseline dimension object is selected, the following editing handles are available: 

Click & drag the handles at arrows to adjust the dimension text position parallel to the 
extensions. 
Click & drag A to move the base point of the dimension. 

Click & drag subsequent handles to move each reference individually, with respect to the 
base. 

All handles nearest to the object(s) being dimensioned allow for redefinable references - once 
the dimension is detached from a reference object it becomes non-referenced and can be 
moved for attachment to a different reference point or object. 

As you drag any of the editing handles, the dimension may be rotated. 

If the baseline dimension object is totally non-referenced (i.e. it is not attached to any 
reference design objects) click anywhere on it - away from editing handles - and drag to reposition it. The dimension can be 
rotated or flipped while dragging. The latter is performed by pressing the X or Y keys to flip the dimension along the X-axis or Y-
axis respectively. 
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Notes 
When dimensioning an object, anchor points become available to you, highlighting where the 
dimension can be attached. Depending on the location of the cursor in relation to the object, 
one of the anchor points will highlight in a different color, specifying where the dimension will 
attach if you proceed to click or press ENTER. 

You do not have to be exactly on the point for the anchor to highlight. 

 

A baseline dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting an object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify a baseline dimension object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note that the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as you move the start or end points. Likewise, if the position of the object that either 
reference point of the dimension is anchored to is changed, the dimension will update and expand/contract to reflect this. 

 

When the reference or references to which a dimension object is attached are deleted, a dialog will appear, asking whether the 
dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Baseline dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Center Dimension 

 

Description 
A center dimension is a group design object. It allows for the center of an arc or circle to be marked. 

Availability 
Center dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Center [shortcut: P, D, C] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Center from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension to the desired arc or circle 

• move the dimension until the desired sizing is achieved then click or press ENTER to complete placement. 

Continue placing further center dimensions, or right-click or press ESC to exit placement mode. 

The center dimension object can be rotated during placement. Press the SPACEBAR to rotate the dimension anti-clockwise or 
SHIFT + SPACEBAR for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on the PCB 
Editor - General page of the Preferences dialog (Tools » Preferences). 

Editing 
The properties of a center dimension object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a center 
dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of 
the options available. Click on the question mark button at the top right of the dialog and 
then click over a field or option to pop-up information specific to that field or option. This 
dialog feature a units toggle control  in the top-left corner that will change the units of 
measurement currently used in the dialog between metric and imperial [shortcut: CTRL 
+ Q]. The current unit of measurement is displayed in the dialog title area. 

The Center Dimension dialog can be accessed prior to entering placement mode, from 
the PCB Editor - Defaults page of the Preferences dialog (Tools » Preferences). This 
allows you to change the default properties for the center dimension object, which will be 
applied when placing subsequent center dimensions. 
During placement, the Center Dimension dialog can be accessed by pressing the TAB 
key. 

After placement, the Center Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed center dimension object 
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• right-clicking the center dimension object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed center dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed center dimension object directly in the workspace and change its size and 
orientation, graphically. 

When an center dimension object is selected, the following editing handles are available: 

Click & drag A to change the size of the dimension. As you drag a handle, the dimension may be rotated. 

Click & drag B to detach the dimension from the reference object. This handle allows for redefinable 
references - once the dimension is detached from a reference object it becomes non-referenced and can 
be moved for attachment to a different reference point or object. 

If the center dimension object is totally non-referenced (i.e. it is not attached to a reference design object) 
click anywhere on it - away from its perimeter editing handles - and drag to reposition it. The dimension 
can be rotated or flipped while dragging. The latter is performed by pressing the X or Y keys to flip the 

dimension along the X-axis or Y-axis respectively. 

Notes 
A center dimension object can be moved in the following ways: 

• selecting both the dimension object and the circle/arc that is being dimensioned. The whole can be dragged to a new 
location as required 

• selecting the circle/arc that is being dimensioned only. The dimension will move with the object 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify a center dimension object that has its Locked property enabled, a dialog will appear asking 
for confirmation to proceed with the edit. 

 

When the reference arc or circle to which a center dimension object is attached is deleted, a dialog will appear, asking whether 
the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Center dimensions are group objects consisting of track segments. They can be converted to their set of primitive objects by 
choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a dimension 
object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Linear Diameter Dimension 

 

Description 
A linear diameter dimension is a group design object. It allows for the dimensioning of an arc or circle with respect to the 
diameter, rather than the radius. The dimension can be placed either internally or externally. 

Availability 
Linear diameter dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Linear Diameter [shortcut: P, D, I] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Linear Diameter from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension to the desired arc or circle. The position of the 

dimension is determined by the alignment angle for the dimension 
• move the dimension text to the desired position (either internal or external) and click or press ENTER to complete 

placement. 
Continue placing further linear diameter dimensions, or right-click or press ESC to exit placement mode. 

The linear diameter dimension object can be rotated during placement. Press the SPACEBAR to rotate the dimension anti-
clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in accordance with the value for the Rotation Step, 
defined on the PCB Editor - General page of the Preferences dialog (Tools » Preferences). 

Editing 
The properties of a linear diameter dimension object can be modified before, during and after placement. Editing itself falls into 
two categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a linear diameter dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. This dialog feature a units toggle control  in the top-left corner that will change the units of measurement currently 
used in the dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is displayed in the dialog 
title area. 
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The Linear Diameter Dimension dialog can be accessed prior to 
entering placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change 
the default properties for the linear diameter dimension object, which 
will be applied when placing subsequent linear diameter dimensions. 

During placement, the Linear Diameter Dimension dialog can be 
accessed by pressing the TAB key. 

After placement, the Linear Diameter Dimension dialog can be 
accessed in the following ways: 

• double-clicking on the placed linear diameter dimension object 

• right-clicking the linear diameter dimension object and selecting 
Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the 
placed linear diameter dimension object. 

 

 

 

 

 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed linear diameter dimension object directly in the workspace and change 
properties such as the position of its text and its reference points, graphically. 

When a linear diameter dimension object is selected, the following editing handles are available: 

Click & drag A or B to adjust the dimension text position parallel to the extensions. 

Click & drag C to move the start point of the dimension. 

Click & drag D to move the end point of the dimension. 

C & D allow for redefinable references - once the dimension is detached from a reference object 
it becomes non-referenced and can be moved for attachment to a different reference point or 
object. 

If the linear diameter dimension object is totally non-referenced (i.e. it is not attached to any 
reference design objects) click anywhere on it - away from editing handles - and drag to 
reposition it. The dimension can be rotated while dragging. 

Notes 
A linear diameter dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension extensions will expand/contract to keep the relationship between dimension and object being dimensioned 
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• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 

 

If you attempt to graphically modify a linear diameter dimension object that has its Locked property enabled, a dialog will 
appear asking for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note that the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as the diameter of the reference arc or circle changes. 

 

When the reference arc or circle to which a linear diameter dimension object is attached is deleted, a dialog will appear, asking 
whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Linear diameter dimensions are group objects consisting of text and track segments. They can be converted to their set of 
primitive objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once 
exploded, a dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Radial Diameter Dimension 

 

Description 
A radial diameter dimension is a group design object. It allows for the dimensioning of an arc or circle with respect to the 
diameter, rather than the radius. The dimension can be placed either internally or externally. The dimension must be placed on 
the layer same that the arc being measured is on. This is in order to create an association with the arc. The dimension can be 
moved to a different layer and the association will remain, so any changes to the arc will update the dimension. 

Availability 
Radial diameter dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Radial Diameter [shortcut: P, D, M] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 
Right-click in the workspace and select Place » Dimension » Radial Diameter from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension to the desired arc or circle 

• move the dimension's arrow pointer to the desired location around the arc or circle. The arrow can be placed either inside or 
outside and movement is in accordance with the Angular Step value in the Radial Diameter Dimension dialog. When the 
required position has been attained, click or press ENTER to lock the arrow in place 

• the text can now be initially positioned in relation to the tail of the arrow pointer. Move the text into the required position and 
click or press ENTER to complete placement. 

Continue placing further radial diameter dimensions, or right-click or press ESC to exit placement mode. 

Editing 
The properties of a radial diameter dimension object can be modified 
before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the 
properties of a radial diameter dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the question 
mark button at the top right of the dialog and then click over a field or 
option to pop-up information specific to that field or option. This dialog 
feature a units toggle control  in the top-left corner that will change 
the units of measurement currently used in the dialog between metric 
and imperial [shortcut: CTRL + Q]. The current unit of measurement is 
displayed in the dialog title area. 

The Radial Diameter Dimension dialog can be accessed prior to 
entering placement mode, from the PCB Editor - Defaults page of the 
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Preferences dialog (Tools » Preferences). This allows you to change the default properties for the radial diameter dimension 
object, which will be applied when placing subsequent radial diameter dimensions. 
During placement, the Radial Diameter Dimension dialog can be accessed by pressing the TAB key. 

After placement, the Radial Diameter Dimension dialog can be accessed in the following ways: 

• double-clicking on the placed radial diameter dimension object 
• selecting the radial diameter dimension object and choosing Properties from the right-click pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed radial diameter dimension object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed radial diameter dimension object directly in the workspace and change 
properties such as the position of its text and its reference point, graphically. 

When an radial diameter dimension object is selected, the following editing handles are available: 

Click & drag A to adjust the leader position, relative to the 'tail' of the arrow 
pointer. 

Click & drag B to adjust the position of the arrow pointer around the 
circumference of the circle or arc or change the length of the arrow leader 
line. 
Click & drag C to move the start point of the dimension. This handle allows 
you to redefine the reference - once the dimension is detached from a 
reference object it becomes non-referenced and can be moved for 
attachment to a different reference point or object. 

If the dimension text is placed within the circumference of the arc or circle, only two of the three editing handles will be available 
for use - A and C. Editing handle A will assume the additional role of editing handle B. 

If the radial diameter dimension object is totally non-referenced (i.e. it is not attached to any reference design objects) click 
anywhere on it - away from editing handles - and drag to reposition it. The dimension can be rotated or flipped while dragging: 
• press the SPACEBAR to rotate the radial diameter dimension anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. 

Rotation is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the 
Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the radial diameter dimension along the X-axis or Y-axis respectively. 

Notes 
A radial diameter dimension object can be moved in the following ways: 

• selecting both the dimension object and the object that is being dimensioned. The whole can be dragged to a new location 
as required 

• selecting the object that is being dimensioned only. The dimension text will follow the object in its alignment plane only. The 
dimension pointer and tail will expand/contract to keep the relationship between dimension and object being dimensioned 

• selecting the dimension object only. It is important to note that the dimension cannot be moved on its own if it is referenced 
by a design object. To move the dimension only, it must first be detached from the object it is dimensioning. 
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If you attempt to graphically modify a radial diameter dimension object that has its Locked property enabled, a dialog will 
appear asking for confirmation to proceed with the edit. 

 

Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available. 

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note that the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

 

The dimension value automatically updates as the radius of the arc or circle changes. 

 

When the reference arc or circle to which a radial diameter dimension object is attached is deleted, a dialog will appear, asking 
whether the dimension should also be deleted. If the dimension is not deleted, it remains on the PCB sheet, but non-referenced. 

 

Radial diameter dimensions are group objects consisting of text and track segments. They can be converted to their set of 
primitive objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once 
exploded, a dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor -Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Standard Dimension 

 

Description 
A standard dimension is a group design object. It places dimensioning information on the current PCB layer. The dimension 
value is the distance between the start and end markers, measured in the default units. 

Availability 
Standard dimension objects are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Dimension » Dimension [shortcut: P, D, D] from the PCB Editor main menus 

• click the  button on the Place Dimension drop-down of the Utilities toolbar. 

PCB Library Editor 

• click the  button on the PCB Lib Placement toolbar. 

• right-click in the workspace and select Place » Dimension » Dimension from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter dimension placement mode. Placement is 
made by performing the following sequence of actions: 
• position the cursor and click or press ENTER to anchor the dimension start point 

• move the cursor to the required end point, then click or press ENTER to anchor this point and complete placement. 

Continue placing further standard dimensions, or right-click or press ESC to exit placement mode. 

Editing 
The properties of a standard dimension object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a standard dimension object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over 
a field or option to pop-up information specific to that field or option. 
This dialog feature a units toggle control  in the top-left corner 
that will change the units of measurement currently used in the 
dialog between metric and imperial [shortcut: CTRL + Q]. The 
current unit of measurement is displayed in the dialog title area. 

The Dimension dialog can be accessed prior to entering placement 
mode, from the PCB Editor - Defaults page of the Preferences 
dialog (Tools » Preferences). This allows you to change the default 
properties for the standard dimension object, which will be applied 
when placing subsequent standard dimensions. 

During placement, the Dimension dialog can be accessed by 
pressing the TAB key. 

After placement, the Dimension dialog can be accessed in the 
following ways: 

• double-clicking on the placed standard dimension object 
• selecting the standard dimension object and choosing Properties from the right-click pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed standard dimension object. 
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Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed standard dimension object directly in the workspace and change its 
location, orientation and position of its start and end points, graphically. The dimension value automatically updates as you 
move the start or end points. 

When a standard dimension object is selected, the following editing handles are available: 

Click & drag A to move the start point of the dimension. 

Click & drag B to move the end point of the dimension. 

Click anywhere on the standard dimension object - away from editing handles - and drag to reposition it. The dimension can be 
rotated or flipped while dragging: 
• press the SPACEBAR to rotate the standard dimension anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. 

Rotation is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the 
Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the standard dimension along the X-axis or Y-axis respectively. 

Notes 
If you attempt to graphically modify a standard dimension object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit. 

 

Standard dimensions are group objects consisting of text and track segments. They can be converted to their set of primitive 
objects by choosing Tools » Convert » Explode Dimension to Free Primitives from the main menus. Once exploded, a 
dimension object can no longer be manipulated as a group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
Dimension text is rendered using either a Stroke or TrueType font. Three Stroke-based fonts are available - Default, Sans Serif 
and Serif. The Default style is a simple vector font which supports pen plotting and vector photoplotting. The Sans Serif and 
Serif fonts are more complex and will slow down vector output generation, such as Gerber. The Stroke-based fonts are built into 
the software and cannot be changed. All three fonts have the full IBM extended ASCII character set that supports English and 
other European languages 
The Default Stroke font is used by default. Change to another Stroke-based font or enable the TrueType option in the 
Designator or Comment dialog as required. In the latter case, the Select TrueType Font options will become available.  

Select the particular TrueType font you wish to use from the Font Name list (populated with TrueType and OpenType (a 
superset of TrueType) fonts found in the \Windows\Fonts folder). Note that the list will only include entries for detected (and 
uniquely named) root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the 
Bold and Italic options to add emphasis to the text. The feature also offers full Unicode support. 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 

. 
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Embedded Board Array - Panelization 

 

Description 
An embedded board array is a primitive design object. It allows you to create a PCB panel (representing the physical board that 
the PCB is to be manufactured from) as part of your PCB design project. This is also known as panelization. You can use this 
panel to hold an array of PCBs on using the embedded board array command. This command links the panel to the original 
PCB design files, stepping it out the specified number of times. You cannot edit the PCBs directly from the board array, only 
through their original files. 

Multiple embedded board arrays can be placed and each can reference a different PCB file. By spacing out the boards in each 
array and then overlaying, rotating and flipping the different embedded arrays, any panelization arrangement can be created. 
This can be used to reduce manufacturing costs by maximizing the number of PCBs per panel of PCB material. 
Note: All PCBs on a board array must use the same layer stackup. 

Availability 
Embedded Board Arrays are available for placement in the PCB Editor only, by selecting Place » Embedded Board Array from 
the main menus. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter 
embedded board array placement mode. A generic outline for the array will appear floating 
on the cursor, held by its lower-left corner. 
Position this corner of the array at the required location and click or press ENTER to place. 

White cross-hatching is used to fill the outline of a placed array that does not yet reference 
a PCB document, so that its location may be readily identified in the design workspace. In 
addition, a small cross marks the lower-left corner of the array boundary. This cross 
appears in the color of the layer on which the array currently resides. In the example image 

below, an embedded board array object has been placed on the top layer. 
Continue placing further embedded board arrays, or right-click or press ESC to exit placement mode. 

The embedded board array object can be rotated or flipped while in placement mode: 
• press the SPACEBAR to rotate the embedded board array. Rotation is anti-clockwise and in steps of 90° 

• press the L key to flip the embedded board array to the other side of the board. 

Editing 
The properties of an embedded board array object can be modified before, during and after placement. Editing itself falls into 
two categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of an embedded board array object: 
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Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right of 
the dialog and then click over a field or option to pop-up information specific to that 
field or option. This dialog feature a units toggle control  in the top-left corner 
that will change the units of measurement currently used in the dialog between 
metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is 
displayed in the dialog title area. 

The Embedded Board Array dialog can be accessed prior to entering placement 
mode, from the PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the embedded 
board array object, which will be applied when placing subsequent embedded 
board arrays. 

During placement, the Embedded Board Array dialog can be accessed by 
pressing the TAB key. 

After placement, the Embedded Board Array dialog can be accessed in the 
following ways: 

• double-clicking on the placed embedded board array object 
• right-clicking the embedded board array object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed embedded board array object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed embedded board array object directly in the workspace and change its 
location or orientation, graphically. 

When an embedded board array object is selected, it is distinguished by a solid white 
boundary. The images illustrate this for both an un-referenced board array and a 2 x 2 
array that references a single PCB design. 

Click anywhere within the boundary of the array and drag to 
reposition it. The array is automatically 'grabbed' by its lower-left 
corner. The embedded board array can be rotated or flipped while 
dragging: 
• press the SPACEBAR to rotate the embedded board array. 

Rotation is anti-clockwise and in steps of 90° 
• press the L key to flip the embedded board array to the other side 

of the board. 
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Notes 
The embedded board array(s) used to create a representation of the manufacturing panel should be placed on a separate PCB 
document within the existing or alternate PCB project. This document should be considered as the manufacturing 'hub' for other 
PCB documents that contain the actual designs. 

 

You can place additional objects to support panel manufacturing (for example free pads as tooling holes), but it is not advisable 
to place any other objects that would represent the actual physical design, within the same document as the embedded board 
array(s). 

 

As the embedded board array object references a PCB design file, rather than containing a pasted copy of it, the source PCB 
design may be modified at any time. Once the reference file is saved, refresh the view of the panel document in order to bring 
the panel up-to-date. 

 

If you are building a panel consisting of different PCB boards, it is important that you ensure the layer stackup for each board is 
compatible. 

 

Gerber, NC Drill, ODB++ and printed output can be generated from a panel of embedded board arrays. 

 

If you attempt to graphically modify an embedded board array object that has its Locked property enabled, a dialog will appear 
asking for confirmation to proceed with the edit. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Fill 

 

Description 
A fill is a primitive design object. It is a rectangular object that can be placed on any layer. When placed on a signal layer, a fill 
becomes an area of solid copper that can be used to provide shielding or to carry large currents. Fills of varying size can be 
combined to cover irregularly shaped areas and can also be combined with track or arc segments and be connected to a net. 

Fills can also be placed on non-electrical layers. For example, place a fill on the Keep-Out layer to designate a 'no-go' area for 
both autorouting and autoplacement. Place a fill on a Power Plane, Solder Mask, or Paste Mask layer, to create a void on that 
layer. 

In the PCB Library Editor, fills can be used to define component footprints. 

Availability 
Fills are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Fill [shortcut: P, F] from the PCB Editor main menus 

• click the  button on the Wiring toolbar. 

PCB Library Editor 
• select Place » Fill [shortcut: P, F] from the PCB Library Editor main menus 

• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » Fill from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter fill placement mode. Placement is made 
by performing the following sequence of actions: 
• click or press ENTER to anchor the first corner of the fill 

• move the cursor to adjust the size of the fill, then click or press ENTER to anchor the diagonally-opposite corner and thereby 
complete placement of the fill. 

Continue placing further fills, or right-click or press ESC to exit placement mode. 

Editing 
The properties of a fill object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a fill 
object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right 
of the dialog and then click over a field or option to pop-up information specific 
to that field or option. This dialog feature a units toggle control  in the top-
left corner that will change the units of measurement currently used in the 
dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

The Fill dialog can be accessed prior to entering placement mode, from the 
PCB Editor - Defaults page of the Preferences dialog (Tools » Preferences). 
This allows you to change the default properties for the fill object, which will be 
applied when placing subsequent fills. 
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During placement, the Fill dialog can be accessed by pressing the TAB key. 

After placement, the Fill dialog can be accessed in the following ways: 

• double-clicking on the placed fill object 
• selecting the fill object and choosing Properties from the right-click pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed fill object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed fill object directly in the workspace and change its size, shape or location, 
graphically. 

When a fill object is selected, the following editing handles are available: 

Click & drag A to resize the fill in the vertical and horizontal directions separately. 

Click & drag B to resize the fill in the vertical and horizontal directions simultaneously. 

Click & drag C to rotate the fill about its center point. 

Click anywhere on the fill - away from editing handles - and drag to reposition it. The fill can be 
rotated or flipped while dragging: 

• press the SPACEBAR to rotate the fill anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 
accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the fill along the X-axis or Y-axis respectively. 

Notes 
A fill will 'adopt' a net name if the first corner is placed on an object which has a net name. 

 

If you attempt to graphically modify a fill object that has its Locked property enabled, a dialog will appear asking for confirmation 
to proceed with the edit. 

 

Fills can be placed as layer-specific keepout objects to act, for example, as routing barriers. A keepout fill is simply a fill object 
with its Keepout property enabled. You can therefore either place a standard fill and then enable this property, or use the 
predefined keepout fill placement command, available from the Place » Keepout sub-menu. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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User-Defined From To 

 

Description 
User-defined From Tos allow you to create specific net topologies within a design, giving you total control over the arrangement, 
or pattern, of pin-to-pin connections in a net. They are different to system-generated From Tos, added and arranged by the PCB 
Editor to give the shortest overall connection length in each case - a net topology referred to as Shortest. 

Displayed in the workspace as pin-to-pin connection lines, From Tos are collectively referred to as the 'ratsnest'. 

Availability & Placement 
User-defined From Tos can be added for part or all of a net using the From-To Editor, 
available from the PCB panel. 

For more information on panels, press F1 when the cursor is over the panel. 

Editing 
A user-defined From To object cannot be edited with respect to properties in the usual 
manner - it cannot be selected in the workspace, has no corresponding properties 
dialog and cannot be edited graphically. 

The layer upon which user-defined From To lines are displayed can be 
enabled/disabled with respect to its visibility using the corresponding Show checkbox 
for Connections and From Tos in the System Colors region, Board Layers And 
Colors page of the View Configurations dialog (Design » Board Layers & Colors). 

 

Define the display color by clicking on the color swatch to bring up the 2D System 
Colors dialog, from where you can choose from a range of predefined colors, or 
create your own custom color. 

The display of user-defined From Tos is controlled from the From To Display Settings 
dialog, accessed via the From To Settings button on the Show/Hide page of the 
View Configurations dialog. You can save view configurations for use in other 
projects. 

 

By default, display of user-defined 
From Tos is set to Automatic. In this 
mode, the From Tos can only be 
viewed when the PCB panel is 
configured in From-To Editor mode. 
To be able to see user-defined From 
Tos when browsing nets or 
components in the design (PCB panel 
in Nets or Components modes), set 
the display mode to Always. 
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Notes 
A system-generated From To does not appear in the workspace as a separate entity - only the associated pin-to-pin connection 
line for the From To is displayed, which is used for interactive routing/Autorouting guidance. 

 

A user-defined From To appears in the workspace as a dotted line, separate and distinct from the pin-to-pin connection line that 
is also displayed when the From To is added. The user-defined From To line controls where the associated pin-to-pin 
connection line starts and finishes. This is best demonstrated by example. Consider a user-defined From To added between the 
logically connected pins of two components. A connection line is also added and displayed (PCB panel configured in Nets 
mode; From To display set to Always): 

 

The pin-to-pin connection line - used for routing purposes - conceals the presence of the distinctly separate user-defined From 
To line. However, as you start to route the connection, you can see the distinct and separate nature of the two lines: 

 

If the routing is now suspended, the Connectivity Analyzer adds a connection line so as to maintain the required topology which 
is shown as a dotted line (called a Broken Net Marker), indicating that the net should be routed between these two points to 
maintain the topology determined by the user through the addition of the user-defined From To: 

 

If you specify user-defined From Tos for only part of a net, the PCB Editor will set the remaining pin-to-pin connections (system-
generated From Tos) to the Shortest topology. 

 

The type of From To determines how the Connectivity Analyzer treats the connection line in the workspace when, for example, 
a net object is moved or part of a net is manually routed: 
• System-generated From To - the connection line can be moved as required as part of the Connectivity Analyzer's re-

optimization to keep the default topology of the net (i.e. Shortest) 
• User-defined From To - if the From To is not the result of selecting a predefined topology, the connection line is not 

considered as part of the Connectivity Analyzer's re-optimization process. If the From To is part of a predefined net topology 
(other than Shortest), the Connectivity Analyzer can include it in re-optimization, so long as the chosen topology is kept. 
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Pad 

 

Description 
A pad is a primitive design object. It is used to create an interconnection point from a component pin to the routing on the board. 
Pads can be used individually as free pads in a design or, more typically, they are used in the PCB Library Editor, where they 
are incorporated with other primitives into component footprints. 

Availability 
Pads are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Pad [shortcut: P, P] from the PCB Editor main menus 

• click the  button on the Wiring toolbar. 

PCB Library Editor 
• select Place » Pad [shortcut: P, P] from the PCB Library Editor main menus 

• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » Pad from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter pad placement mode. Position the cursor 
and click or press ENTER to place a pad. 

Continue placing further pads, or right-click or press ESC to exit placement mode. 

When placing SMD or single layer pads, use the * key (on the numeric keypad) to toggle enabled signal layers. Use the + or - 
keys (on the numeric keypad) to toggle up and down through all enabled layers. 

Editing 
The properties of a pad object can be modified before, 
during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify 
the properties of a pad object: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then 
click over a field or option to pop-up information specific to 
that field or option. This dialog feature a units toggle control 

 in the top-left corner that will change the units of 
measurement currently used in the dialog between metric 
and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

The Pad properties dialog has a viewer which allows you to 
inspect the pad shapes on the defined layers including 
shapes on internal plane layers. You will be able to define 
oval (slotted) or square holes in pads and their plated 
properties (plated or unplated holes) and all the work 
needed to support thermal reliefs generation, clearances 
calculation, output to Gerber, ODB++ and NC Drill etc will be 
automatically handled. Separate drill files (NC Drill Excellon 
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format 2) are generated for each hole kind (round, square, slotted), as well as for plated and non-plated (up to six different drill 
files). 
Hole Information – when you are editing a hole shape for the pad, there are three hole types to choose from: 

• Round – Round holes are the default hole shapes and you can define their hole sizes. 

• Square – Square holes has an extra property, rotation in degrees along with their hole size values. 

• Slot –Slot holes are actually rounded slot holes with Length and Rotation properties. 

Size and Shape – allows you to define the pad size and shape for each of the affected layers in the pad stack, on a layer-by-
layer basis. Editing of the full pad stack is carried out in the Pad Layer Editor dialog, accessed by clicking the Edit Full Pad 
Layer Definition button.  

When editing pad size and shape, three layering options are available: 
• Simple – specify a size and shape which is used for the pad on each affected layer in the pad stack 

• Top-Middle-Bottom – specify a different size and shape for the pad on the top, mid and bottom layers of the pad stack 
respectively 

• Full Stack – allows you to define the pad size and shape for each of the affected layers in the pad stack, on a layer-by-layer 
basis. Editing of the full pad stack is carried out in the Pad Layer Editor dialog, accessed by clicking the Edit Full Pad Layer 
Definition button: 

 

• Shape – the following pad shapes can be defined and previewed. Only one shape (Rounded Rectangle) can have a 
definable Corner Radius. This setting allows you to specify the corner radius for the Rounded Rectangle pad shape and it 
defaults to 50%. For all other shapes this control appears grayed because the value for Corner Radius for a Rounded 
Rectangle pad shape is based on the height and width calculations of an oblong-defined object (see Notes below for specific 
formula).  
Rounded Rectangle – an oblong pad shape as shown Round – a circular pad shape as shown 

 

 

 

Rectangular – as shown Octagonal – as shown 
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Dialog Access 
The Pad dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the Preferences 
dialog (Tools » Preferences). This allows you to change the default properties for the pad object, which will be applied when 
placing subsequent pads. 
During placement, the Pad dialog can be accessed by pressing the TAB key. 

After placement, the Pad dialog can be accessed in the following ways: 

• double-clicking on the placed pad object 
• selecting the pad object and choosing Properties from the right-click pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed pad object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed pad object directly in the workspace and change its location graphically. 
The size and shape of a pad object cannot be changed graphically. As such, editing handles are not available when the pad 
object is selected: 

Click anywhere on the pad and drag to reposition it. The pad can be rotated or flipped while dragging: 

• press the SPACEBAR to rotate the pad anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. 
Rotation is in accordance with the value for the Rotation Step, defined on the PCB Editor - General page 
of the Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the pad along the X-axis or Y-axis respectively. 

Notes 
Pads can be multi-layer (appearing on all signal and plane layers), or single layer and can also be connected to a net. Multi-
layer pads can have a different shape defined on each layer and require a drill hole to connect the various layers. Single layer 
pads should not include a drill hole. 

 

The formula for calculating a Corner Radius for the Rounded Rectangle pad shape is: 

Corner Radius = [Minimum(PadXSize, PadYSize) / 2] * (Corner Radius [%] / 100.0) where Corner Radius [%] can be in the 
range [0 - 100] % 

When the Corner Radius is set to 0%, the pad shape appears as a Rectangular pad shape. When the Corner Radius is set to 
100%, the pad shape appears as a Round pad shape.  

 

Pad holes can be round holes, square holes or slotted holes 

 

Pads automatically connect to an internal power plane layer that is assigned the same net name. The pad will connect in 
accordance with the applicable Power Plane Connect Style design rule. If you do not want pads to connect to power planes, add 
another Power Plane Connect Style design rule targeting the specific pads required and with a connection style of No 
Connect. 
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Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 

 

Tenting 
Partial and complete tenting of pads can be achieved by defining an appropriate value for Solder Mask Expansion. This 
expansion constraint can either be defined on a pad-by-pad basis, in the associated Pad dialog, or by defining appropriate 
Solder Mask Expansion design rules: 

• to partially tent a pad - covering the land area only - set the Expansion to a negative value that will close the mask right up to 
the pad hole 

• to completely tent a pad - covering the land and hole - set the Expansion to a negative value equal to or greater than the pad 
radius 

• to tent all pads on a single layer, set the appropriate Expansion value and ensure that the scope (Full Query) of a Solder 
Mask Expansion rule targets all pads on the required layer 

• to completely tent all pads in a design, in which varying pad sizes are defined, set the Expansion to a negative value equal 
to or greater than the largest pad radius. 

When tenting an individual pad, options are available to follow the expansion defined in the applicable design rule, or to override 
the rule and apply a specified expansion directly to the individual pad in question. 

 

Pad Designators 
Pads can be labeled with a designator  (usually representing a component pin number) of up to 20 alphanumeric characters in 
length. Pad designators will auto-increment by 1 during placement if the initial pad has a designator ending with a numeric 
character. Change the designator of the first pad, prior to placement, from the Pad dialog (accessed during placement by 
pressing the TAB key). 

To achieve alpha or numeric designator increments other than 1, use the Paste Array feature. Controls for this feature are 
provided in the Setup Paste Array dialog, accessed by pressing the Paste Array button in the Paste Special dialog (Edit » 
Paste Special). 

By setting the designator of the pad prior to copying it to the clipboard and setting 
the Text Increment field in the Setup Paste Array dialog, the following types of pad 
designator sequences can be placed: 

• numeric (eg. 1, 3, 5) 

• alphabetic (eg. A, B, C) 

• alphanumeric (eg. A1, A2; 1A, 1B; A1, B1; 1A, 2A, etc) 

To increment numerically set the Text Increment field to the amount you wish to 
increment by. To increment alphabetically, set the Text Increment field to the letter 

in the alphabet that represents the number of letters you wish to skip. For example, if the initial pad had a designator of 1A and 
the Text Increment field was set to C, the pads placed would have the designators 1A, 1D, 1G and so on. 

 

Jumper Connections 
Jumper connections define electrical connections between component pads that are not physically routed with primitives on the 

PCB. These are especially useful on single layer boards, where a wire is used to jump over 
tracks on the one physical layer, or even as complex as designing with a ‘crossover’ 
switch. The Design Rules Checker will not report jumper connections as unrouted nets. 
Pads within a component can be labeled with a Jumper ID value from within the Pad 
dialog. Pads that share the same Jumper ID and electrical net tell the system that there is a 
legitimate, although physically unconnected, connection between them. 

Jumper connections are shown as curved connection lines in the PCB Editor. 
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Polygon Pour 

 

Description 
A polygon pour is a group design object. It creates a solid, hatch-filled (lattice) or outline-only area on the selected PCB layer. 
Also referred to as copper pours, they are similar to area fills, except that they can fill irregularly shaped areas of a board and 
can connect to a specified net as they are poured. 

On a signal layer, you might place a solid polygon pour to define an area for carrying large power supply currents, or as a 
ground-connected area for providing electro-magnetic shielding. Hatched polygon pours are commonly used for ground 
purposes in analog designs. 

On a non-signal layer, you might use solid or outline-only polygon pours to distinguish between specific functional areas of a 
board. 

Availability 
Polygon Pours are available for placement/creation in the PCB Editor only. You can place them directly or create them from 
selected primitives. 

Use one of the following methods to access the placement command: 
• select Place » Polygon Pour [shortcut: P, G] from the main menus 

• click the  button on the Wiring toolbar 

After selecting the primitive objects to create the polygon region from, use the following methods to access the convert selected 
primitives or objects commands: 
• select Tools » Convert » Create Polygon from Selected Primitives [shortcut: T, V, G] from the main menus 

• select Tools » Polygon Pours » Define from selected objects [shortcut: T, D, G] from the main menus 

Placement 
After launching the command, the Polygon Pour dialog will appear: 

You can choose to place a polygon pour using one of three fill 
modes: 

• Solid (Copper Regions) - this mode fills the inside of the 
polygon boundary with one or more solid copper regions. 
The number of copper regions used depends on the number 
of individual areas created inside the polygon by existing net 
objects, such as tracks and pads 

• Hatched (Tracks/Arcs) - this mode fills the inside of the 
polygon boundary using tracks, arranged horizontally, 
vertically, or in a hatched/lattice fashion (45º or 90º). Pads 
within the boundary can be surrounded using arcs (arranged 
in circular fashion) or tracks (arranged in octagonal fashion) 

• None (Outlines Only) - this mode leaves only the outline 
track of a placed polygon pour displayed. The interior of the 
pour is not filled. This is a useful mode during the design 
phase, as system performance is not degraded by having to 
wait for polygons to be repoured. Prior to generation of 

manufacturing output, you can then repour polygons with the desired fill type. 
As you change the Fill Mode, the dialog will dynamically update to show a graphical example of pouring with that mode and the 
options applicable to that mode. The image above shows the dialog when the Solid fill mode is enabled. This is the default 
mode when placing a polygon pour for the first time. The images below illustrate the appearance of the dialog when the fill mode 
is set to Hatched (left) and None (right) respectively. 
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Use the dialog's 'What's This Help' feature to obtain detailed information about each of the options available. Click on the 
question mark button at the top right of the dialog and then click over a field or option to pop-up information specific to that field 
or option. This dialog feature a units toggle control  in the top-left corner that will change the units of measurement currently 
used in the dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of measurement is displayed in the dialog 
title area. 
After defining pour options as required, click OK. The cursor will change to a crosshair and you will enter polygon pour 
placement mode. Placement is made by performing the following sequence of actions: 

• position the cursor and click to anchor the starting point for the polygon pour 

• position the cursor and click to anchor a series of vertex points that define the polygonal shape of the pour 
• after placing the final vertex point, right-click or press ESC to complete placement of the polygon pour. There is no need to 

"close" the polygon as the software will automatically complete the shape by connecting the start point to the final point 
placed. 

While defining the shape of the polygon pour, use SHIFT + SPACEBAR to cycle through various corner modes. Modes 
available are: any angle, 45°, 45° with arc, 90° and 90° with arc. Arcs can be increased or decreased in radius using SHIFT + . 
(period or full stop) or SHIFT + , (comma) respectively. Use SPACEBAR to toggle the direction of the corner. 

Use the BACKSPACE key while in placement mode, to remove the last placed vertex point. Repeatedly use this key to 'unwind' 
the outline for the polygon, right back to the initial starting point. 

Creating from Selected Primitives  
You can create polygon objects in the form of polygon pours, regions, polygon cutouts or board cutouts using a closed boundary 
made up of selected track and/or arc objects using the Create Polygon From Selected Primitives command. You can also create 
a polygon pour from selected objects using the Define From Selected Objects command. 
Note: The resulting polygon pour differs in size between these methods in that the Create Polygon From Selected Primitives 
command uses the center-line of each object to represent the outline of the polygon, whereas the Define From Selected Objects 
command uses the internal edges of the primitives to represent the outline. 

Select the track or arc objects first (all on the same layer), then use the required command.  
Note: If you change layer before calling the command, the resulting polygon will be placed on the currently selected layer. 

The selected track/arc primitives should form a closed boundary for 
the commands to work correctly. If you use these commands on 
unclosed shapes, a dialog is shown informing you of this that also 
offers an alternative to create the polygon from the external edges 
of the objects. Using the edges has the effect of  creating a closed 
polygon of the outline. The following diagram shows the difference, 
with a polygon created from a closed outline on the left and one 
created from an open outline on the right. 

Once the polygon pour has been created like this it can be edited as per any polygon pour object. 

Editing 
The properties of a polygon pour object can be modified before, during and after placement. Editing itself falls into two 
categories - graphical and non-graphical. 
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The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the Polygon Pour dialog to modify the properties of a polygon pour object. 
The Polygon Pour dialog can be accessed prior to entering placement mode, from the PCB Editor - Defaults page of the 
Preferences dialog (Tools » Preferences). This allows you to change the default properties for the polygon pour object, which 
will be applied when placing subsequent polygon pours. 
During placement, the Polygon Pour dialog can be accessed by pressing the TAB key. 

After placement, the Polygon Pour dialog can be accessed in the following ways: 

• double-clicking on the placed polygon pour object 
• right-clicking the polygon pour object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed polygon pour object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed polygon pour object directly in the workspace and change its size, shape, 
location or orientation, graphically. 

Changing Polygon Pour Size and Location 
When a polygon pour object is selected, the following editing handles are available, irrespective of the fill mode chosen: 

Dragging corner handles (B) will scale the polygon horizontally and vertically simultaneously. 
Dragging an edge handle (A) scales the object in that direction (either horizontally or vertically). 

The polygon can be rotated or flipped while dragging: 
• press the SPACEBAR to rotate the object anti-clockwise or SHIFT + SPACEBAR for 

clockwise rotation. Rotation is in accordance with the value for the Rotation Step, defined on 
the PCB Editor - General page of the Preferences dialog (Tools » Preferences) 

• press the X or Y keys to flip the object along the X-axis or Y-axis respectively. 

After resizing, moving, rotating or flipping, a confirmation dialog will appear asking if you want to rebuild the polygon - essentially 
repouring it within the newly-sized/repositioned boundary. Clicking Yes will effect the modification. 

Multiple polygon pours can be moved simultaneously. SHIFT + Click on all pours that you wish to include in the move, then click 
and drag on one pour in the selection to move the entire selection. 

Changing Polygon Pour Shape 
To graphically modify the boundary shape of a polygon pour, you will need to launch the Edit » Move » Polygon Vertices 
command. After launching the command, click inside the polygon pour to be modified. Filtering will be applied to the document, 

resulting in the chosen polygon pour object remaining visible and all other objects becoming 
dimmed. 

When a polygon pour object is selected for moving vertices, editing handles are displayed at 
each vertex: 
Click A then move the cursor to move the vertex. Click again at the new location to position 
the vertex there.  
Click B then move the cursor to add more vertices to that edge as well as move B. Click 
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again at the new location to position the vertex there. In effect, the moved B vertice becomes an A and a new B vertex is added 
between it and the original A vertices. 

Click over an object edge (in between handles) then move the cursor to move that edge. 
Continue modifying the shape of the polygon pour as required or right-click or press ESC to stop. A confirmation dialog will 
appear asking if you want to rebuild the polygon - essentially repouring it within the new boundary. Click Yes to effect the 
changes you have made. 

Slicing Polygon Pours 
A placed polygon pour object can be graphically 'sliced' into two or more separate 
polygon pours. The command needed to perform the slice is available by: 
• selecting Place » Slice Polygon Pour from the PCB Editor main menus 

• right-clicking a polygon pour object and selecting Polygon Actions » Slice Polygon 
Pour from the pop-up menu. 

After launching the command, filtering will be applied to the document, resulting in all 
polygon pour objects on the current layer remaining visible and all other objects 
becoming dimmed. The cursor will change to a crosshair and you will be prompted to 
choose a start point for the slice. Move the cursor to the required point with respect to 
the polygon pour you wish to slice and click or press ENTER. 

You are now in slice mode (which is essentially line placement mode). Move the cursor and click or press ENTER to anchor a 
series of vertex points that define the shape of the slice. 

• position the cursor and click to anchor the starting point for the slice 

• position the cursor and click to anchor a series of vertex points that define the shape of the slice 
• after placing the final vertex point, right-click or press ESC to complete placement of the slice.  

When you have finished defining the slice, right-click or press ESC. 

Continue defining further slices, or right-click or press ESC to exit slice mode. A confirmation dialog will appear, which states 
how many polygon pours the original polygon pour will be turned into. Click Yes to commit the slice(s) or No to discard. 

Having committed the slicing, a confirmation dialog will appear asking if you want to rebuild the n polygons - essentially 
repouring each newly created polygon. Clicking Yes will effect the modification and the 
resulting new polygon pour objects will be repoured accordingly. 
While defining the splice shape, use SHIFT + SPACEBAR to cycle through various 
corner modes. Modes available are: any angle, 45°, 45° with arc, 90° and 90° with arc. 
Use SPACEBAR to toggle the direction of the corner. Each placement mode, except any 
angle, requires a start and end point. 
Use the BACKSPACE key while in slice mode to remove the last placed vertex point. 
Repeatedly use this key to 'unwind' the slice shape, right back to the initial starting point. 

Converting Hatched Polygon Pours 
Multiple hatched polygon pours may be converted to solid polygon pours, 
simultaneously, using the Tools » Polygon Pours » Convert Hatched 
Polygons To Solid command from the PCB Editor's main menus. 

After launching the command, the Polygon Pour Conversion dialog will 
appear: 

You can choose to convert all hatched polygon pours in the design, or 
specifically those that you have selected prior to launching the 
command. Define conversion options as required and click OK to effect 
the conversion. 
Note: A converted pour can easily be turned back to its original hatched 
format by changing the Fill Mode and respective properties, in the 
Polygon Pour dialog. 

Shelving Polygon Pours 
If a design has numerous polygon pours, especially of the larger, hatch-filled variety, the repouring phase can be quite slow. To 
alleviate this, you could temporarily change the Fill Mode of all such pours to None - meaning that only the outline tracks will be 
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displayed. Alternatively, a more convenient method of reducing the impact of repouring on system performance during the 
design phase is to temporarily hide all polygon pours in the design - a feature known as Shelving. 
To shelve all polygons in the current design, select the Tools » Polygon Pours » Shelve n Polygon(s) command from the 
PCB Editor's main menus (where n is the number of polygon pours that have been detected in the design). 
To reinstate all polygons that have previously been shelved, select the Tools » Polygon Pours » Restore n Shelved 
Polygon(s) command from the PCB Editor's main menus (where n is the number of polygon pours that are currently shelved). 

Note you can use the Polygon Pour Manager dialog to help you manipulate polygons more quickly such renaming, shelving and 
repouring polygons on the PCB document in one go. 

Using the Polygon Pour Manager 
The Polygon Pour Manager dialog provides a high-level view of all polygons on the entire board. This manager also enables 
you to name and rename each polygon, set the pour order of polygons, perform repouring or shelving actions on selected 
polygons, and add/scope design rules for selected polygons as well.  

You also have the ability to re-arrange the pour order of polygons and view the pour order from this dialog. You can lock, shelve 
or re-pour selected or all polygons and create or scope design rules for polygons, speeding the polygon editing process.  

Repours are performed immediately, note that you will be prompted to first apply any pending edits before the pour can take 
place. 

Shelving, Locking and Ignore DRC Violations status change buttons can be used on all, violating or selected polygons. The 
Apply button then applies the selected actions to the PCB document without closing the dialog. The OK button executes the 
actions and then closes the dialog. 
A polygon connection style rule or a polygon clearance rule can be created, targeting the selected polygons, using the Create 
Connect Style Rule or Create Clearance Rule buttons. As well, a polygon class can be created based on the selected 
polygons with the Create Polygon Class button.  

Use the What’s This help button for more information on each control in the Polygon Pour Manager dialog. 
The Polygon Pour Manager dialog is launched from the Tools » Polygon Pours submenu.  

 

Notes 
Polygon pours can be poured on any layer: 

• when placed in occupied board space on a signal layer, polygon pours will automatically pour copper around any existing 
electrical objects (tracks, pads, vias, fills, etc) belonging to one or more different nets, while maintaining the clearances 
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specified in pertinent design rules. The Net Options region of the Polygon Pour dialog provides a drop-down field with 
options that determine pour behavior when poured over net objects belonging to the same net as the copper pour: 
Pour Over All Same Net Objects - select this option if you want a polygon pour to automatically connect to all objects on 
the same net as the pour 
Pour Over Same Net Polygons Only - select this option (default) if you want the polygon pour to automatically connect to 
only polygon pour objects inside its boundary, and which are associated to the same net 
Don't Pour Over Same Net Objects - select this option if you specifically do not wish the polygon pour to connect to any 
other net objects - either belonging to the same or different parent net as itself. 
If either of the first two options are chosen and the polygon pour is assigned to No Net, it will pour around all objects 
regardless of their net assignments. 

• if a polygon is placed on a non-signal layer it will not be poured around existing objects, as these objects are not assigned to 
a net and therefore do not belong to anything. 

 

The positive copper region object is the backbone of a polygon pour object whose Fill Mode is set to 
Solid. Each continuous area of copper within a solid polygon pour is defined as a copper region. 
When generating manufacturing files, these regions are output using Gerber polygon primitives 
When a positive copper region's Cutout property is enabled, it becomes a polygon pour cutout object - 
essentially a negative copper region object that cannot be associated to a net or used as a keepout. 
As such, it can be moved inside the boundary of a solid polygon pour object - providing a void area 
within that pour (once the solid polygon has been repoured). 
You can directly place a polygon pour cutout object (region object with its Cutout property already 
enabled) inside a solid polygon pour using the Place » Polygon Pour Cutout command. 

 

You can place a Hatched polygon pour and make it solid-filled, by ensuring the Track Width is slightly larger than the Grid Size 
in the associated Polygon Pour dialog. This will cause adjacent tracks that make up the polygon hatching to overlap, creating a 
solid fill. Alternatively, convert it directly to a solid polygon pour using the Tools » Polygon Pours » Convert Hatched 
Polygons To Solid command. 

 

When a hatched polygon pour is poured around component pads, you can choose 
whether such pads are surrounded by arcs or octagons (from the Polygon Pour 
dialog): 

Octagons give smaller Gerber files and faster photoplotting. 

 

 

 

 

Dead copper is the term used to define an area of a polygon pour that does not connect to the specified net - due to objects 
belonging to different nets (tracks, pads and vias) preventing the polygon from pouring as one continuous area. If a pour does 
not enclose any pads on the selected net, it is viewed as being entirely dead copper. 
When filtering, use a query of IsPoly to return all polygon pours in the design. From the PCB List panel, you can view the 
constituent primitive objects for a pour by right-clicking on the entry for that pour and choosing Show Polygon Children from 
the pop-up menu. 

 

To control how a polygon pour connects to component pads when the Connect to Net option is used, include a Polygon 
Connect Style design rule. 

 

Via connections to both hatched and solid signal layer polygons are controlled by the Polygon Connect style design rule. 
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Commands to move, repour, slice and explode a polygon pour are also available 
from the Polygon Actions sub-menu, accessed by right-clicking over a placed 
polygon pour. 

 

 

 

 

 

 

 

 

 

When defining a clearance rule for a polygon, it is the primitives of the polygon that the rule is actually applied to, rather than the 
polygon itself. The keyword entry InPolygon (or InPoly) should be included in the Full Query in this case, instead of 
IsPolygon (or IsPoly). The specific polygon clearance rule must also be given a higher priority than any general clearance 
rule, if it is to have any effect. 

 

Polygon pours are group objects made up of a series of primitive objects - copper regions for Solid polygon pours; tracks and 
arcs for Hatched polygon pours. They can be converted to their set of primitive objects by choosing Tools » Convert » Explode 
Polygon to Free Primitives from the main menus. Once exploded, a polygon pour object can no longer be manipulated as a 
group object. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 

 

Polygon pours created from the Create Polygon From Selected Primitives and Define From Selected Objects commands differ 
in size in that the first command uses the center-line of each object to represent the outline of the polygon, whereas the second 
uses the internal edges of the primitives to represent the outline. 

 

If you change layer before calling the Create Polygon From Selected Primitives or Define From Selected Objects command, the 
resulting polygon will be placed on the currently selected layer. 
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Region 

 

Description 
A region is a primitive, polygon-type object that can be placed on any layer. It can be configured to be positive (placed as a 
copper region) or negative (placed as a polygon pour cutout) or be multi-layer (placed as a board cutout). 

When using it as a positive region, it is similar in nature to its rectangular-based fill counterpart. When placed on a signal layer a 
positive region becomes an area of solid copper that can be used to provide shielding or to carry large currents. Positive regions 
can be combined with track or arc segments and be connected to a net. 

Positive regions can also be placed on non-electrical layers. For example, place a region on the Keep-Out layer to designate a 
'no-go' area for both autorouting and autoplacement. Place a region on a Power Plane, Solder Mask, or Paste Mask layer, to 
create a void on that layer. 

In the PCB Library Editor, positive regions can be used to create polygonal-shaped fills for use in defining component footprints. 

When used as a negative copper region (polygon pour cutout) it provides a polygonal void area for use within solid polygon 
pours. Such a region/cutout will not be filled with copper when the pour is flooded. 

When used as a board cutout it defines areas that are actual holes through the PCB and are independent of board layers. Board 
cutout regions are transferred to Gerber and ODB++ files for manufacturing purposes. Regardless of which layer you are on 
when creating a board cutout, it will remain multi-layer. 

Availability 
Regions are available for placement in both PCB and PCB Library Editors.  

PCB Editor 
In the PCB Editor you can place regions directly or create them from selected primitives. 

Use one of the following methods to access the placement command: 
• select Place » Solid Region [shortcut: P, R] from the main menus, to place a positive copper region in the workspace 

• select Place » Polygon Pour Cutout from the main menus, to place a negative copper region (cutout) in the workspace 

• select Design » Board Shape » Define Board Cutout [shortcut: D, S, C] from the main menus, to place a board cutout 
(aperture) in the board. 

After selecting the primitive objects to create the region from, use the following method to access the convert selected primitives 
command: 
• select Tools » Convert » Create Region from Selected Primitives [shortcut: T, V, R] from the main menus 

PCB Library Editor 
Only positive copper region objects may be placed directly in the PCB Library Editor's workspace, by selecting Place » Solid 
Region [shortcut: P, R] from the main menus. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter region placement mode. Placement is 
made by performing the following sequence of actions: 

• position the cursor and click to anchor the starting point for the region 

• position the cursor and click to anchor a series of vertex points that define the polygonal shape of the region 
• after placing the final vertex point, right-click or press ESC to complete placement of the region. There is no need to "close" 

the polygon as the software will automatically complete the shape by connecting the start point to the final point placed. 
Continue placing further regions, or right-click or press ESC to exit placement mode. 

While defining the region shape, use SHIFT + SPACEBAR to cycle through various corner modes. Modes available are: any 
angle, 45°, 45° with arc, 90° and 90° with arc. Arcs can be increased or decreased in radius using SHIFT + . (period or full stop) 
or SHIFT + , (comma) respectively. Use SPACEBAR to toggle the direction of the corner. 
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Use the BACKSPACE key while in placement mode, to remove the last placed vertex point. Repeatedly use this key to 'unwind' 
the outline for the polygon, right back to the initial starting point. 

Creating from Selected Primitives  
You can create polygon objects in the form of polygon pours, regions, polygon cutouts or board cutouts using a closed boundary 
made up of selected track and/or arc objects using the Create Region From Selected Primitives command. 

Select the track or arc objects first (all on the same layer), then use the command.  
Note: If you change layer before calling the command, the resulting region will be placed on the currently selected layer. 

The selected track/arc primitives should form a closed boundary 
for the command to work correctly. If you use this command on 
unclosed shapes, a dialog is shown informing you of this that also 
offers an alternative to create the region from the external edges of 
the objects. Using the edges has the effect of  creating a closed 
polygon of the outline. The following diagram shows the difference, 
with a polygon created from a closed outline on the left and one 
created from an open outline on the right. 

Once the region has been created like this it can be edited as per any region object. 

Editing 
The properties of a region object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a region object: 

Use the dialog's 'What's This Help' feature to obtain detailed information 
about each of the options available. Click on the question mark button at the 
top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. 
Note: The Polygon Cutout property distinguishes a positive copper region 
(disabled) from a negative copper region (enabled). 

The Region dialog can be accessed prior to entering placement mode, from 
the PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the region 
object, which will be applied when placing subsequent regions. 
During placement, the Region dialog can be accessed by pressing the TAB 
key. 

After placement, the Region dialog can be accessed in the following ways: 

• double-clicking on the placed region object 
• right-clicking the region object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed region object. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 
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Graphical Editing 
This method of editing allows you to select a placed region object directly in the workspace and change its size, shape, location 
or orientation, graphically. 

When a region object is selected, editing handles are displayed at each vertex: 

When the cursor changes to  over a handle, click and drag to move the vertex. When this 
cursor appears over the middle of an object edge, click & drag to add a vertex to that edge 
and move it.  

When the cursor changes to  over an object edge, click & drag to move that edge of the 
region. 

When the cursor changes to  over the object, click and drag to move the region. The region can be rotated or flipped while 
dragging: 
• press the SPACEBAR to rotate the region anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the region along the X-axis or Y-axis respectively. 

Notes 
Unlike a fill, a positive copper region will not automatically 'adopt' the net name of a net-object it connects to. You must 
specifically connect it to a net through its associated properties dialog. 

 

If you attempt to graphically modify a region object that has its Locked property enabled, a dialog will appear asking for 
confirmation to proceed with the edit. 

 

Positive copper regions can be placed as layer-specific keepout objects to act, for example, as routing barriers. A keepout 
region is simply a region object with its Keepout property enabled. You can therefore either place a standard region and then 
enable this property, or use the predefined keepout region placement command, available from the Place » Keepout sub-
menu. 

 

When a positive copper region's Cutout property is enabled, it becomes a polygon pour cutout object - 
essentially a negative copper region object that cannot be associated to a net or used as a keepout. As 
such, it can be moved inside the boundary of a solid polygon pour object - providing a void area within 
that pour (once the solid polygon has been repoured). 
You can directly place a polygon pour cutout object (region object with its Cutout property already 
enabled) inside a solid polygon pour using the Place » Polygon Pour Cutout command. 

 

The positive copper region object is the backbone of a polygon pour object, whose Fill Mode is set to Solid. Each continuous 
area of copper within a solid polygon pour is defined as a copper region. When generating manufacturing files, these regions 
are output using Gerber polygon primitives. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 

 

If you change layer before calling the Create Region From Selected Primitives command, the resulting region will be placed on 
the currently selected layer. 
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Room 

 

Description 
A room is a primitive design object. It is a region that assists in the placement of components. Rectangular or polygon-type 
rooms can be placed on either the top or bottom layer of the board and can either be placed empty - associating components at 
a later stage - or placed around components in the design, automatically associating them to the room. Alternatively, orthogonal, 
non-orthogonal and rectangular shaped rooms may be created automatically based on selected components in the workspace. 

Availability 
Rooms are available for placement/creation in the PCB Editor only. You can place them directly or create them from selected 
components. 

Use one of the following methods to access the placement commands: 
• select Design » Rooms » Place Rectangular Room [shortcut: D, M, R] 
• select Design » Rooms » Place Polygonal Room [shortcut: D, M, M] 
s sub-menu and the Utilities toolbar. They can also be placed/created using Altium Designer’s standard menu shortcut keys, 
for example D, M, R will launch the Design » Rooms » Place Rectangular Room command. 

You can also create a new room object by adding a new Room Definition design rule. 

Placement 
The procedure involved to obtain a room on the PCB document depends on whether you are placing or creating the room and 
which particular method of placement/creation you have chosen to use. 

Placement Using Menu or Toolbar Command 
Rectangular or polygonal shaped rooms can be placed on the top or bottom layer of the design. 

Rectangular Room 
After launching the command, the cursor will change to a crosshair and you will enter room 
placement mode. Placement is made by performing the following sequence of actions: 
• click or press ENTER to anchor the first corner of the room 

• move the cursor to adjust the size of the room, then click or press ENTER to anchor the 
diagonally-opposite corner and thereby complete placement of the room. 

Continue placing further rooms, or right-click or press ESC to exit placement mode. 

Polygonal Room 
After launching the command, the cursor will change to a crosshair and you will 
enter room placement mode. Placement is made by performing the following 
sequence of actions: 

• position the cursor and click to anchor the starting point for the room 

• position the cursor and click to anchor a series of vertex points that define the 
polygonal shape of the room 

• after placing the final vertex point, right-click or press ESC to complete 
placement of the room. There is no need to "close" the polygon as the software will automatically complete the shape by 
connecting the start point to the final point placed. 

Continue placing further polygonal rooms, or right-click or press ESC to exit placement mode. 

While defining the region shape, use SHIFT + SPACEBAR to cycle through various corner modes. Modes available are: any 
angle, 45°, 45° with arc, 90° and 90° with arc. Arcs can be increased or decreased in radius using SHIFT + . (period or full stop) 
or SHIFT + , (comma) respectively. Use SPACEBAR to toggle the direction of the corner. 
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Use the BACKSPACE key while in placement mode, to remove the last placed vertex point. Repeatedly use this key to 'unwind' 
the outline for the polygon, right back to the initial starting point. 

Auto-Component Association 
By placing a room - rectangular or polygonal - around one or more components, so that they fall completely within its 
boundaries, the components will automatically be associated to the room. The scope or query created for the room's definition 
rule depends on whether all components are part of an existing component class or not. If they are, then this component class 
will be used. If not, a new component class is created, with these components as its members. It is therefore possible to have 
multiple rooms, each with a scope that targets a particular component class, and have one or more mutual component members 
between those classes. 

Manual Component Association 
When an empty room is placed in the design, components required to be placed in the room should be grouped together by the 
use of a specific component class. A Room Definition rule will automatically be created and assigned to the room, with an initial 
scope (Full Query) of All. Edit this query to target the specific component class previously defined. The components can then 
be moved to the room by the use of the Tools » Component Placement » Arrange Within Room command. 

Creation Using Menu or Toolbar Command 
Non-orthogonal, orthogonal and rectangular shaped rooms can be created automatically based on selected components in the 
workspace. In each case, the method of creation is the same: 

• first, ensure that all components that you wish to create the room for, are selected in the main design window 

• launch the relevant creation command 

• a component class is automatically defined to include the selection 

• the chosen room type is then created, the definition of which is defined to associate the created component class 

• the room will be sized accordingly, in order to fit all components in the selection, as defined by the limits of their bounding 
rectangles. 

The following sections illustrate, by example, each of the three room types created from the three selected components in the 
image. 

In each case, there are two images - the first showing the result of running the associated room creation command and the 
second showing just the created room, which has been filtered in the workspace for clarity. 

Non-orthogonal Room Orthogonal Room Rectangular Room 

   

Creation by Adding a Room Definition Design Rule 
For each room that is placed or created an associated Room Definition design rule is also created. Conversely, you may add a 
new rule of this type and a corresponding room object will appear in the design workspace. 
Add a new Room Definition rule by right-clicking on the Room Definition entry, which can be found under the Placement 
category in the PCB Rules and Constraints Editor dialog, and select New Rule from the subsequent pop-up menu. The new rule 
will be added to the folder-tree on the left hand side of the dialog and will appear in the summary list for that rule type, in the 
main editing window of the dialog. 
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Clicking on the entry for the newly-created rule 
in the folder-tree pane (or, alternatively, 
double-clicking on the rule entry in the 
summary list) will allow you to edit/define the 
scope and constraint attributes for the rule. 
Use the Define button to access the 
workspace and determine the location, shape 
and size of the required room - either 
polygonal or rectangular. After defining the 
boundaries of the room you will return to the 
dialog. 

After defining all constraints for the rule as 
required, click OK to exit the dialog. The 

corresponding room object will appear in the design 
workspace, in accordance with the definition of the rule. 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then 
click over a field or option to pop-up information specific to 
that field or option. This dialog feature a units toggle control 

 in the top-left corner that will change the units of 
measurement currently used in the dialog between metric and 
imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

Editing 
The properties of a room object can be modified during and 
after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

Non-graphical editing targets the associated Room Definition rule for a room object, allowing you to change the room's scope 
and related constraints such as upon which layer the room is placed and whether it exists to keep objects inside or outside its 
boundaries. The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the constraints of a room's associated Room Definition rule: 

Use the dialog's 'What's This Help' feature to obtain detailed 
information about each of the options available. Click on the 
question mark button at the top right of the dialog and then 
click over a field or option to pop-up information specific to 
that field or option. This dialog feature a units toggle control 

 in the top-left corner that will change the units of 
measurement currently used in the dialog between metric 
and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

During placement, the Edit Room Definition dialog can be 
accessed by pressing the TAB key. 

After placement, the Edit Room Definition dialog can be 
accessed in the following ways: 

• double-clicking on the placed room object 
• right-clicking the room object and selecting Properties 

from the pop-up menu 
• selecting the Edit » Change command, then clicking 

once over the placed room object. 
The constraints for a Room Definition rule can also be edited directly in the PCB Rules and Constraints Editor dialog (Design » 
Rules). 
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Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed room object directly in the workspace and change its size, shape, location 
or orientation, graphically. 

Changing Room Size and Location 
When a room object is selected the following editing handles are available, irrespective of whether it is was originally placed as 
a rectangular or polygonal room: 

      

Dragging corner handles (A) will scale the room horizontally and vertically simultaneously. Dragging an edge handle (B) scales 
the object in that direction (either horizontally or vertically). 

The room can be rotated or flipped while dragging: 
• press the SPACEBAR to rotate the object anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the object along the X-axis or Y-axis respectively. 

A room object can also be moved using the Design » Rooms » Move Room command. 

Changing Room Shape 
To graphically modify the boundary shape of a room, you will need to launch the 
Design » Rooms » Edit Polygonal Room Vertices command [shortcut: D, M, E]. 
Although the command name suggests it is for use with polygonal rooms only, it is in 
fact for use with all rooms, since a rectangular room is itself a polygon. 

After launching the command, click inside the room to be modified. The boundary 
track editing handles for the room's polygonal boundary shape will be displayed: 
Click A then move the cursor to move the vertex. Click again at the new location to 
position the vertex there.  
Click B then move the cursor to add more vertices to that edge as well as move B. Click again at the new location to position 
the vertex there. In effect, the moved B vertice becomes an A and a new B vertex is added between it and the original A 
vertices. 

Click over an object edge (in between handles) then move the cursor to move that edge. 
Continue modifying the shape of the room as required or right-click or press ESC to stop. The display of the room will update in 
accordance with the new boundary shape. 

Slicing Rooms 
Commands are available that allow you to graphically 'slice' a placed room object into two or more separate rooms. These 
commands offer two levels of 'slice', which can be summarized as follows: 
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Standard Slice 
Allows you to slice an existing room object into multiple rooms. If the original room was associated to, and contained, 
components that were members of a component class, a newly generated room that inherits one or more of these components 
will not have a new component class created and assigned to it. Therefore, the components in the new room will still be 
members of the original component class. 

The corresponding command for this level of slice is available by: 
• selecting Design » Rooms » Slice Room from the PCB Editor main menus 

• clicking the  button on the Place Room drop-down of the Utilities toolbar 

• right-clicking a room object and selecting Room Actions » Slice Room from the pop-up menu. 

Smart Slice 
Also allows you to slice an existing room object into multiple rooms. If the 
members of the original room were part of a component class and slicing 
results in members residing in the newly-generated rooms, then each new 
room will have a component class created and associated to it. The 
component class membership will be updated accordingly, so that each 
component in a new room will be added to the class for that room and 
removed from the original room class. 

Any room that is created that does not inherit a member component of the 
original room will have no component class created and assigned to it. 

The corresponding command for this level of slice is available by right-
clicking over a room object and choosing Room Actions » Slice and 
Create Classes from the subsequent pop-up menu. 

The Slicing Process 
After launching either command, filtering will be applied to the document, resulting in all room objects remaining visible and all 
other objects becoming dimmed. The cursor will change to a crosshair and you will be prompted to select a start point for the 
slice. Move the cursor to the required point with respect to the room you wish to slice and click or press ENTER. 

You are now in slice mode (which is essentially line placement mode). Move the cursor and click or press ENTER to anchor a 
series of vertex points that define the shape of the slice. 

• position the cursor and click to anchor the starting point for the slice 

• position the cursor and click to anchor a series of vertex points that define the shape of the slice 
• after placing the final vertex point, right-click or press ESC to complete placement of the slice. 

When you have finished defining the slice, right-click or press ESC. 

Continue defining further slices, or right-click or press ESC to exit slice 
mode. A confirmation dialog will appear, which states how many rooms 
the original room will be turned into. Click Yes to commit the slice(s) you 
have made or No to discard. The resulting new room object(s) will be 
updated accordingly and the relevant Room Definition rule created and 
associated. 
While defining the splice shape, use SHIFT + SPACEBAR to cycle 
through various corner modes. Modes available are: any angle, 45° and 
90°. Use SPACEBAR to toggle the direction of the corner. Each 
placement mode, except any angle, requires a start and end point. 
Use the BACKSPACE key while in slice mode to remove the last placed 
slice segment. 

Room Wrapping 
The following commands are available that allow you to quickly change the shape of existing room objects within a design: 

• Wrap Non-Orthogonal Room Around Components 

• Wrap Orthogonal Room Around Components 

• Wrap Rectangular Room Around Components 
Each of the commands can be accessed from either the main Design » Rooms submenu or from the Room Actions sub-
menu, when right-clicking over a room in the workspace. 
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In each case, after launching the 
command the cursor will change to a 
crosshair and you will be prompted to 
select a room to modify. Position the 
cursor over the required room and 
click or press ENTER. The room will 
change to the required shape (if not 
already) and will resize in order to fit 
its member components, as defined 
by the limits of their bounding 
rectangles. 

Continue modifying further rooms or 
right-click or press ESC to exit. 

 

 

 

 

Notes 
Once component(s) have been assigned to a room they move when the room is moved. To move a room without moving the 
components, temporarily disable the associated Room Definition rule - either in the PCB Rules and Constraints Editor dialog or 
in the PCB Inspector panel (with the room in question selected in the workspace). 

 

A room can be locked to prevent accidentally moving it. To lock a room, double-click on it and enable the Room Locked option 
in the Edit Room Definition dialog. 

 

When using any of the Wrap-based commands, if the current room is already the shape that you are trying to change it to and 
was created based on its member components, it will already be optimally sized (wrapped) around the components and using 
the command will have no effect. 

 

When using either the PCB Inspector or PCB List panels to edit the properties of a room's associated Room Definition rule, the 
selected room object will appear as the Object Kind: Confinement Constraint Rule. 

 

As well as being a design rule in its own right (Room Definition), a room can also be used as an object when defining the scope 
of another rule, such as Clearance or Height. As the room is to be used as an object rather than a rule, you can disable the rule. 
The following two queries can be used when using a room object in another rules' scope definition: 
• TouchesRoom(RoomName) - use to find objects that are completely or partially within the room 

• WithinRoom(RoomName) - use to find objects that are completely within the room. 

 

The context-sensitive right-click menu - accessed when the cursor is over a room object - also provides commands for selecting 
the connections in the room, routing the connections in the room using the Situs Autorouter and unrouting the room. 

 

The Design » Rooms » Copy Room Formats command is used to copy the formatting of a selected source room to 
destination rooms that contain an identical set of components. The command is particularly useful when you need to copy the 
placement and routing of a particular channel, to all other channels in a multi-channel design. 
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String 

 

Description 
A string is a primitive design object. It places text on the selected layer in a variety of display styles and formats, including 
popular barcoding standards. As well as user-defined text, “special strings” can be used to place board or system information on 
the PCB. 

Availability 
Strings are available for placement in both PCB and PCB Library documents. 

PCB Documents 
• select Place » String [shortcut: P, S] from the PCB Editor main menus 

• click the  button on the PCB Placement toolbar. 

PCB Library Documents 
• select Place » String [shortcut: P, S] from the PCB Library Editor main menus 

• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » String from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter string placement mode. The last placed 
string, if applicable, will also appear alongside the cursor by default. Position the cursor and click or press ENTER to place a 
string. 
Continue placing further strings, or right-click or press ESC to exit placement mode. 

The string object can be rotated or mirrored while in placement mode: 
• press the SPACEBAR to rotate the string anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to mirror the string along the X-axis or Y-axis respectively. 

Special Strings 
A defined set of special strings are available that act as placeholders for PCB design or system-based information, such as 
layer names, hole counts, legends and the like. 

To use a special string on a PCB, place a string object and set its text to be one of the special string names. Special string 
names begin with the period or full stop character ‘.’. 

The following lists the defined set of special PCB strings: 
• .Application_BuildNumber – the version of Altium Designer that the PCB is currently loaded in. When generating 

Gerber output, this string will record the software build that the design was created on 
• .Arc_Count - the number of arcs on the PCB 

• .Comment - the comment string for a component (used in designing component footprints) 

• .Component_Count - the number of components on the PCB 

• .ComputerName - The name of the machine that the PCB is currently loaded in 

• .Designator - the designator string for a component (used in designing component footprints) 

• .Fill_Count - the number of fills on the PCB 

• .Hole_Count - the number of drill holes on the PCB 

• .Layer_Name - the name of the layer the string is placed on 

• .Legend - a symbol legend for mechanical drill plots. This string is only valid when placed on the Drill Drawing layer 

• .Net_Count - the total number of different nets on the PCB 
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• .Net_Names_On_Layer - the names of all nets on the specific layer. This string is only valid when placed on an internal 
plane layer 

• .Pad_Count - the number of pads on the PCB 

• .Pattern - the names of the component footprints used on the PCB 

• .Pcb_File_Name - the path and file name of the PCB document 

• .Pcb_File_Name_No_Path - the file name of the PCB document 

• .Plot_File_Name - When generating Gerber output, this string identifies the file name of the Gerber plot file. When 
generating printed output, this string identifies the layer depicted within the output. When generating ODB++ output, this 
string identifies the name of the parent folder in which the files are stored 

• .Poly_Count - the number of polygons on the PCB (consisting of polygon pours, internal planes and split planes) 

• .Print_Date - the date of printing/plotting 

• .Print_Scale - the printing/plot scale factor 

• .Print_Time - the time of printing/plotting 

• .Printout_Name - the name of the printout 

• .SlotHole_Count - the number of slotted holes on the PCB 

• .SquareHole_Count - the number of square holes on the PCB 

• .String_Count - the number of strings on the PCB 

• .Track_Count - the number of tracks on the PCB 

• .VersionControl_RevNumber - the current revision number of the document. Version control must be used for this string 
to contain any information 

• .Via_Count - the number of vias on the PCB. 

Editing 
The properties of a string object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a string object: 

Use the dialog's 'What's This Help' feature to obtain detailed information about 
each of the options available. Click on the question mark button at the top right 
of the dialog and then click over a field or option to pop-up information specific 
to that field or option. This dialog feature a units toggle control  in the top-left 
corner that will change the units of measurement currently used in the dialog 
between metric and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 
The Text field allows you to define the textual content of the string. Type the 
required text directly into the field. If you want to place a special string, select 
the required entry from the field drop-down list. 
Dialog Access 
The String dialog can be accessed prior to entering placement mode, from the 
PCB Editor - Defaults page of the Preferences dialog (Tools » Preferences). 
This allows you to change the default properties for string objects, which will be 
applied when placing subsequent strings. 
During placement, the String dialog can be accessed by pressing the TAB key. 

After placement, the String dialog can be accessed in the following ways: 

• double-clicking on the placed string object 
• right-clicking the string object and selecting Properties from the pop-up 

menu 
• selecting the Edit » Change command, then clicking once over the placed string object. This method allows consecutive 

editing for multiple objects. 
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Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

 For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

 For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed string object directly in the workspace and change its location, rotation, 
orientation or, in the case of inverted strings, size. 

When a non-inverted string object is selected, the following editing handle is available: 
Click and drag B to rotate the string about A. 

When an inverted string object with an editable bounding rectangle is selected, the following editing 
handles are available: 

When the cursor changes to  over a handle, click and drag to move 
the handle. Dragging corner handles (C) will scale the string 
horizontally and vertically simultaneously. Dragging an edge handle (E 
or D) scales the object in that direction (either horizontally or vertically). 

Click and drag B to rotate the string about A. 

Click anywhere on the string - away from any editing handles - and 
drag to reposition it. The string will be held by point A and can be 

rotated or mirrored while dragging. 

Notes 
Text is rendered using Stroke or TrueType fonts, or in Barcode format. Three Stroke-based fonts are available - Default is a 
simple vector font which supports pen plotting and vector photoplotting; Sans Serif and Serif fonts are more complex and will 
slow down vector output generation, such as Gerber. The Stroke fonts are built into the software and cannot be changed. The 
Stroke fonts have the full IBM extended ASCII character set that supports English and other European languages. 
Change to another Stroke-based font or enable the TrueType or BarCode options in the String dialog as required. In the latter 
cases, font and/or formatting options will become available. 

   

Using TrueType Fonts 
Select the font you wish to use from the Font Name list. TrueType and OpenType fonts are found in the \Windows\Fonts 
folder (OpenType being a superset of TrueType). Note that the list will only include entries for detected (and uniquely named) 
root fonts. For example, Arial and Arial Black will be listed but Arial Bold, Arial Bold Italic, etc will not. Use the Bold and Italic 
options to add emphasis to the text. The feature also offers full Unicode support. 
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This barcode is inverted and is showing the 
text string in Times font. 

You can also have the text displayed as inverted, with control over the size of the border around the text. Furthermore, enabling 
the Use Inverted Rectangle checkbox will give you control over the bounding rectangle for the text, including justification and 
margins. 

   
Normal (non-inverted) text Inverted text (with 20 mil 

inverted border) 
Inverted rectangle text (with 

specified rectangle size, bold/italic 
text emphasis, bottom right 
justification and text offset) 

Use the available save/load options on the PCB Editor – TrueType Fonts page of the Preferences dialog to enable embedding 
of TrueType fonts when saving a design, and for nominating a substitution TrueType font for files using TrueType fonts that are 
not available installed locally. 
Using BarCode Format 
Select the barcode ISO coding you wish to use – Code 39 is US Dept of Defense standard, Code 128 is the global trade 
identification standard. Use the other controls to specify the height and width of the barcode using either a desired overall width 
or a minimum barcode element width to control sizing. Be sure to use sizing that will render the barcode readable to the 
appropriate scanners. 
You can also display that actual text string that the barcode is derived from by enabling the Show Text checkbox. If you show 
text, you can select the TrueType font and set a height for it. Inverting the barcode allows you to set a distance between the 
barcode (or barcode and text) and the border. 

 

 

The .Designator and .Comment special strings are added to the component in the library. Use these if you need to control 
the location of these attributes on a component. They can be placed on any layer. The standard designator and comment can 
be hidden if desired. 

 

Use the .Legend string on the Drill Drawing layer. It will be replaced by a drill table when the output is generated. 

 

The values of most special strings can be viewed on-screen by enabling the Convert Special Strings option on the View 
Options page of the View Configurations dialog (Design » Board Layers & Colors). The following special strings cannot be 
converted for on-screen viewing. Instead, they will be converted upon generation of the output. 
• .Legend 

• .Pattern 

• .Plot_File_Name 

• .Printout_Name 

If the Convert Special Strings option is currently enabled, these three strings will display as: 
SpecialStringName is not interpreted until output 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Track 

 

Description 
A track is a primitive design object. It is a straight solid-filled line with a defined width. Use tracks wherever you need to define a 
straight line in the PCB workspace. 

Tracks are generally placed on a signal layer, while using the Interactive Routing tool, to form the electrical interconnection 
between component pads on a PCB. 

On non-electrical layers, tracks are used as general-purpose line drawing elements to create board outlines, component 
outlines, polygon planes, keepout boundaries, etc. 

Availability 
Tracks are available for placement in both PCB and PCB Library Editors. 

PCB Editor 
In the PCB Editor, there are different commands available for placing tracks, depending on whether you wish to route 
connections manually on a signal layer using the Interactive Routing tool, or place straight lines on a non-electrical layer. 

Lines are the same track object that is placed during interactive routing, the difference is that lines are not "net-aware". Lines do 
not adopt a net name if you click on a pad or existing routing when you commence placing a line and their placement is not 
regulated by design rules. 

To place track objects using the Interactive Routing tool: 
• select Place » Interactive Routing [shortcut: P, T] from the main menus 

• click the  button on the Wiring toolbar 

• right-click in the PCB design workspace and select Interactive Routing from the pop-up menu. 

To place line objects (track that is net-unaware): 
• select Place » Line [shortcut: P, L] from the main menus 

• click the  button on the Utility Tools drop-down of the Utilities toolbar 

PCB Library Editor 
To place line objects (track that is net-unaware): 
• select Place » Line [shortcut: P, L] from the main menus 

• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » Line from the pop-up menu. 

Placement 
Irrespective of the command used, the basic procedure for track placement is the same. After launching the command, the 
cursor will change to a crosshair and you will enter track placement mode. Placement is made by performing the following 
sequence of actions: 
• click or press ENTER to anchor the starting point for the first track segment 

• move the cursor to size the track and click or press ENTER to anchor the end point for this first segment, which is also the 
start point for the next connected segment 

• position the cursor and click or press ENTER to anchor a series of vertex points that define the series of connected track 
segments 

• right-click or press ESC to end the current series of connected track segments. 

While placing tracks, use SHIFT + SPACEBAR to cycle through various corner modes. Modes available are: any angle, 45°, 
45° with arc, 90° and 90° with arc. Use SPACEBAR to toggle the direction of the corner. Each placement mode, except any 
angle, requires a start and end point. 
Continue placing further tracks, or right-click or press ESC to exit placement mode. 

Use the BACKSPACE key while in placement mode, to remove the last placed track segment. 

The active layer can be changed while placing track: 



Legacy documentation 
refer to the Altium Wiki for current information

PCB Editor and Object Reference 

TR0112 (v2.5) May 22, 2008 95 

• press the * key (the asterisk key on the numeric keypad) to cycle through the available signal layers 

• press the + and - keys (on the numeric keypad) to cycle forward and backward through all visible layers in the design 
respectively. 

In each case, the active layer will have its layer tab highlighted and the color of the current track segment will be drawn in the 
current layer color. 

Editing 
The properties of a track object can be modified during and after placement. Editing itself falls into two categories - graphical 
and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
The specific controls available for editing a track object depends on 
the command used to place the track and whether you are editing 
during or after placement. 

Editing During Track Placement Using the Place » Interactive 
Routing Command 
While interactively routing, the track width and routing via 
parameters can be changed on-the-fly by pressing the TAB key. 
This pops up the Interactive Routing dialog, where you can change 
the trace width, layer, the via diameter and the via hole size. 

If the values are changed to be outside the current maximum and 
minimum settings of the applicable rule - as summarized in the 
Design Rule Constraints region of the dialog - they are automatically clipped. 

When performing impedance-controlled routing, that is, when the 
associated Routing Width design rule is configured in the 
Characteristic Impedance Driven Width mode, the Interactive 
Routing dialog appears as follows: 

In this mode, the routing width required on each layer is calculated 
based on the specified impedance, using the appropriate equation 
(microstrip or stripline) and the physical parameters of the layer stack. 

The impedance equations used for calculating the impedance and 
trace width are accessed from the Layer Stack Manager dialog, by 
pressing the Impedance Calculation button. The subsequent dialog 
that appears - the Impedance Formula Editor dialog - contains 
impedance calculators for both microstrip and stripline impedance 
calculations. 

 

Default equations are in place to calculate the 
impedance and the required track width in order 
to satisfy that impedance when routing. Clicking 
the Helper button associated with an equation 
will open the Query Helper dialog, from where 
you can edit the equation if required. 
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Editing During Track Placement Using the Place » Line command 
While placing net-unaware track using the Place » Line command, the track width and 
current layer can be changed on-the-fly using the Line Constraints dialog, accessed by 
pressing the TAB key. 

Post-placement Editing 
After placement, track properties are edited using the Track dialog: 

Use the dialog's 'What's This Help' feature to obtain detailed information about each of the 
options available. Click on the question mark button at the top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. This dialog feature a units toggle control  in the top-left corner that will change the 
units of measurement currently used in the dialog between metric and imperial [shortcut: CTRL + Q]. The current unit of 
measurement is displayed in the dialog title area. 

The Track dialog can be accessed in the following ways: 

• double-clicking on the placed track object 
• right-clicking the track object and selecting Properties from the pop-up 

menu 
• selecting the Edit » Change command, then clicking once over the 

placed track object. 

The Track dialog can also be accessed prior to entering placement mode, 
from the PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the track 
object, which will be applied when placing subsequent tracks using the 
Place » Line command. 

Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed track object directly in the workspace and change its size, shape, location 
or orientation, graphically. 

When a track object is selected, the following editing handles are available: 
Click & drag A to move the end points of the track. 

Click & drag B to "break" the track into two segments, effectively adding a new vertex. The 
original track end points will stay anchored at their original positions 

Click anywhere on the track - away from editing handles - and drag to reposition it. The track can be rotated or flipped while 
dragging: 
• press the SPACEBAR to rotate the track anti-clockwise or SHIFT + SPACEBAR for clockwise rotation. Rotation is in 

accordance with the value for the Rotation Step, defined on the PCB Editor - General page of the Preferences dialog 
(Tools » Preferences) 

• press the X or Y keys to flip the track along the X-axis or Y-axis respectively 

• press the L key to flip the track to the other side of the board. 
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Notes 
The PCB and PCB Library Editors incorporate a sophisticated "look-ahead" feature that operates as you place tracks (applicable 
in all modes except Any Angle). The track segment that is connected to the cursor is called a look-ahead segment and is shown 
in outline/draft mode as you move the cursor. The segment between this look-ahead segment and the last-placed segment is 
the current track that you are placing (shown in final mode). 

 

Use the look-ahead segment to work out where you intend to place the next segment and to determine where you wish to 
terminate the current segment. When you click to place the current segment, its end point will be positioned exactly where you 
need to commence the next segment. This feature allows you to quickly and accurately place tracks around existing objects and 
plan where the next track segment can be placed. 

 

If you require greater control over how a track segment is broken into two individually connected segments - rather than using 
the central editing handle to break the track in the center - use the Edit » Move » Break Track command. This allows you to 
'break' the track segment anywhere along its length. 

 

Any changes made to track properties during placement using the Place » Line command will cause the default properties for 
the track object to be updated, unless the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is 
enabled. When this option is enabled, changes made will affect only the object being placed and subsequent objects placed 
during the same placement session. 
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Via 

 

Description 
A via is a primitive design object. It is used to form an electrical connection between two signal layers of a PCB. Vias are like 
round pads, which are drilled and usually through-plated when the board is fabricated. 

Availability 
Vias are available for placement in both PCB and PCB Library Editors: 

PCB Editor 
• select Place » Via [shortcut: P, V] from the PCB Editor main menus 

• click the  button on the Wiring toolbar. 

PCB Library Editor 
• select Place » Via [shortcut: P, V] from the PCB Library Editor main menus 

• click the  button on the PCB Lib Placement toolbar 

• right-click in the workspace and select Place » Via from the pop-up menu. 

Placement 
After launching the command, the cursor will change to a crosshair and you will enter via placement mode. Position the cursor 
and click or press ENTER to place a via. 

Continue placing further vias, or right-click or press ESC to exit placement mode. 

When placing free vias, use the * key (on the numeric keypad) to toggle enabled signal layers. Use the + or - keys (on the 
numeric keypad) to toggle up and down through all enabled layers. 

Editing 
The properties of a via object can be modified before, during and after placement. Editing itself falls into two categories - 
graphical and non-graphical. 

The following methods of non-graphical editing are available: 

Editing via an Associated Properties Dialog 
This method of editing uses the following dialog to modify the properties of a via object: 

Use the dialog's 'What's This Help' feature to obtain detailed information 
about each of the options available. Click on the question mark button at 
the top right of the dialog and then click over a field or option to pop-up 
information specific to that field or option. This dialog feature a units toggle 
control  in the top-left corner that will change the units of measurement 
currently used in the dialog between metric and imperial [shortcut: CTRL + 
Q]. The current unit of measurement is displayed in the dialog title area. 

The Via dialog can be accessed prior to entering placement mode, from 
the PCB Editor - Defaults page of the Preferences dialog (Tools » 
Preferences). This allows you to change the default properties for the via 
object, which will be applied when placing subsequent vias. 
During placement, the Via dialog can be accessed by pressing the TAB 
key. 

After placement, the Via dialog can be accessed in the following ways: 

• double-clicking on the placed via object 
• right-clicking the via object and selecting Properties from the pop-up menu 

• selecting the Edit » Change command, then clicking once over the placed via object. 
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Editing via the PCB Inspector Panel 
The PCB Inspector panel enables you to interrogate and edit the properties of one or more design objects in the active 
document. Used in conjunction with appropriate filtering, the panel can be used to make changes to multiple objects of the same 
kind, from one convenient location. 

For more information on a specific panel, press F1 when the cursor is over the panel. 

Editing via the PCB List Panel 
The PCB List panel allows you to display design objects in tabular format, enabling you to quickly inspect and modify object 
attributes. When used in conjunction with the PCB Filter panel, it enables you to display just those objects falling under the 
scope of the active filter - allowing you to target and edit multiple design objects with greater accuracy and efficiency. 

For more information on a specific panel, press F1 when the cursor is over a panel. 

Graphical Editing 
This method of editing allows you to select a placed via object directly in the workspace and change its location graphically. The 
size of a via object cannot be changed graphically. As such, editing handles are not available when the via object is selected: 

  Click anywhere on the via and drag to reposition it. 

Notes 
Use the Paste Array feature to paste an array of free vias. Controls for this feature are provided in the Setup Paste Array dialog, 
accessed by pressing the Paste Array button in the Paste Special dialog (Edit » Paste Special). 

 

Vias can be one of the following types: 
• multi-layer (Thru-Hole) - this type of via passes from the Top layer to the Bottom layer and allows connections to all internal 

signal layers 
• blind - this type of via connects from the surface of the board to an internal signal layer 

• buried - this type of via connects from one internal signal layer to another internal signal layer. 

 

Vias use layer colors to indicate which layers are connecting. 

 

When you change layers while interactively routing, using the * key, a via is automatically inserted to preserve the electrical 
conductivity. The via will be placed in accordance with the applicable Routing Via Style design rule and the drill pair definitions. 

 

When routing the design using the Situs Autorouter, vias will be placed as necessary and in accordance with the defined (and 
applicable) Routing Via Style design rules. 

 

Vias automatically connect to an internal power plane layer that is assigned the same net name. The via will connect in 
accordance with the applicable Power Plane Connect Style design rule. If you do not want vias to connect to power planes, add 
another Power Plane Connect Style design rule targeting the specific vias required and with a connection style of No Connect. 

 

Any changes made to object properties during placement will cause the default properties for the object to be updated, unless 
the Permanent option - on the PCB Editor - Defaults page of the Preferences dialog - is enabled. When this option is enabled, 
changes made will affect only the object being placed and subsequent objects placed during the same placement session. 
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Tenting 
Partial and complete tenting of vias can be achieved by defining an appropriate value for Solder Mask Expansion. This 
expansion constraint can either be defined on a via-by-via basis, in the associated Via dialog, or by defining appropriate Solder 
Mask Expansion design rules: 

• to partially tent a via - covering the land area only - set the Expansion to a negative value that will close the mask right up to 
the via hole 

• to completely tent a via - covering the land and hole - set the Expansion to a negative value equal to or greater than the via 
radius 

• to tent all vias on a single layer, set the appropriate Expansion value and ensure that the scope (Full Query) of a Solder 
Mask Expansion rule targets all vias on the required layer 

• to completely tent all vias in a design, in which varying via sizes are defined, set the Expansion to a negative value equal to 
or greater than the largest via radius. 

When tenting an individual via, options are available to follow the expansion defined in the applicable design rule, or to override 
the rule and apply a specified expansion directly to the individual via in question. 

 

Blind and Buried Vias 
Before using blind or buried vias it is important to establish the level of support provided by the manufacturer. Most 
manufacturers support blind and buried vias between what are termed 'layer pairs'. Using this technology, a multi-layer board is 
fabricated as a set of thin double-sided boards which are then 'sandwiched' together. This allows blind and buried vias to 

connect between the surfaces of 
these thin double-sided boards, 
which become the layer pairs. 

The layer pairs are defined by the 
layer stack you configure in the 
Layer Stack Manager dialog 
(Design » Layer Stack Manager). 
It is important to note that the layer 
pairs are dependent on the layer 
stack-up style. Make sure you 
contact your manufacturer to ensure 
you select the correct stack-up style 
before you start designing with blind 
and buried vias. 

Once you have established the correct stack-up style, you should define the valid drill 
pairs. Drill pairs are set up in the Drill-Pair Manager dialog, accessed by clicking on the 
Configure Drill Pairs button in the Layer Stack Manager dialog. 

If you define a drill pair for each layer pair in your design, the PCB Editor will 
automatically insert the correct via type (thru-hole, blind or buried) as you toggle layers 
while interactively routing. 

In order to control the size of blind and buried vias when interactively routing or using 
the Situs Autorouter, individual Routing Via Style design rules can be set up targeting 
the different layer pairs. For example, to control the via size for blind vias between the 
top layer and mid layer 1, the following scope (Full Query) can be used: 
(StartLayer = 'TopLayer') and (StopLayer = 'MidLayer1') 

to control the via size for buried vias between mid layer 2 and mid layer 3, the 
following scope would be used: 
(StartLayer = 'MidLayer2') and (StopLayer = 'MidLayer3') 

Alternatively, instead of creating individual rules, you can expand the one rule query 
using ORs: 
((StartLayer = 'TopLayer') and (StopLayer = 'MidLayer1')) or 
((StartLayer = ' MidLayer2') and (StopLayer = 'MidLayer3')) 
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Violation 

 

Description 
A violation object marks an instance in the design where a particular design rule is currently being violated by one or more 
design objects. The violation itself is highlighted in the workspace through the use of a DRC Error Marker. 

Availability & Placement 
This type of object is placed automatically by the Design Rule Checking features - both Online and Batch. As such, it is not a 
design object that can be accessed and placed by the user. 

Editing 
A violation object cannot be edited with respect to properties in the usual manner - it cannot be selected in the workspace, has 
no corresponding properties dialog and cannot be edited graphically. 

The layer upon which the associated DRC Error Markers are displayed can be enabled/disabled with respect to its visibility 
using the corresponding Show checkbox for DRC Error Markers, in the System Colors region, Board Layers And Colors 
page of the View Configurations dialog (Design » Board Layers & Colors). 

 

Define the display color by clicking on the color swatch to bring up the 2D System Colors dialog, from where you can choose 
from a range of predefined colors, or create your own custom color. You can save any view configurations for use in other 
projects. 
DRC Error Markers currently displayed in the workspace can be cleared using the Tools » Reset Error Markers command. 
Running the command will also clear the violation objects from the 
workspace and their corresponding listings in the PCB panel. 

Violation objects can be shown or hidden in the workspace by 
enabling/disabling the corresponding design rules respectively. This 
can be done either from the PCB Rules and Constraints Editor dialog 
(Design » Rules) using the Enabled option for a rule, or by using the 
On field for a rule, in the Rules region of the PCB panel, when 
configured in Rules mode. 

Disabling a rule takes it out of testing with respect to DRC and therefore no violations of it will be listed in the panel or added to 
the workspace. 

Notes 
 

Details of a violation object can be accessed either by double-clicking on the relevant 
violation entry in the PCB panel, or by right-clicking on an error marker in the 
workspace and choosing a command from the Violations sub-menu. In either case, 
the Violation Details dialog will appear, providing details about the particular design 
rule that is being violated and the offending object(s). 

From this dialog you can highlight the offending object (causing it to flash in the 
workspace) and jump to it, effectively providing zoom and center. 
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All current violations in the PCB document can also be seen and navigated in the PCB panel - with the mode of the panel set to 
Rules: 

 

 

Using the Reset Error Markers command just clears the error markers and the presence of violation objects in the workspace 
and on the PCB panel, it does not fix the violations. If you run a batch mode Design Rule Check (DRC) again, all violation 
objects will reappear on the PCB panel and in the workspace, along with the error markers. 

 

Clearing the error markers clears the violations reported in the PCB panel only. The violation messages that appear in the 
Messages panel after running a batch mode DRC, will remain. 
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04-Nov-2005 1.4 Updated for Altium Designer 6 

8-Jun-2006 1.5 Updated for Altium Designer 6.3 

08-Jul-2006 1.6 Arc object information updated. 
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