查看: 1331  |  回复: 4
【请教】BL9342 5V输入时输出异常
Beancurd2
2
主题
5
回复
发表于2022-11-22 12:42:10 | 只看该作者
1# 电梯直达

最近想做个USB电流表,复刻立创2022暑期训练营,顺便加个诱骗模块,所以DC电源就选电压高一点的,也是选择官方训练营案例的——BL9342。

但是输出有问题——输出类似三角波

 


使用的是立创试验板,脚位适用,元器件一个不少。

立创试验板——

https://oshwhub.com/li-chuang-zhi-neng-ying-jian-bu/sot-23-6-feng-zhuangdc-dc-xin-pian-fang-an-yan-zheng-ban


找了一圈:

    发现当输入电压升高到6.2V以上就没有了,输出很平稳,但是手册标称是4.2-40V输入,我也是降压到3.3V,USB也都是默认5V,应该不会5V都不行,就很奇怪啊!?


原理图:

    手册案例:

  

    我画的(照着画的):

     


元器件:

    DC电源IC:

        U6:BL9342——https://item.szlcsc.com/94371.html

   输入电容:

        C10:4.7uF/50V 0805——https://item.szlcsc.com/99401.html

    输出电容:

        C10:10uF/16v 0603——https://item.szlcsc.com/93680.html

    旁路电容:

        C9:100nF/16V 0603——https://item.szlcsc.com/268639.html

    反馈电阻:

        R5:124kΩ/100mW 0603——https://item.szlcsc.com/104477.html

          R6:40.2kΩ/100mW 0603——https://item.szlcsc.com/104833.html

          C12:NC, 之前贴了33pF,后面出问题拆了,也没变化——https://item.szlcsc.com/545469.html

    输出电感:

        L1:2.2uH/2A 120mΩ——https://item.szlcsc.com/403480.html

    肖基特二极管:

        D2:B5817W——https://item.szlcsc.com/192602.html

               还用过 SS34A——https://item.szlcsc.com/212750.html,并没有什么变化。

     其他:

            R7:使能端降压电阻,100k,项目最开始测得 5V输入有4V,20V输入有7.5V,好像十几V的时候就稳定7.5V了,看手册引脚耐压是5V,我还怕坏了,但好像还是正常的,后面就发现输出有问题了;

            D3:稳压二极管,想配合R7做稳压管稳压,但是功耗会很大,就NC了。

            最开始调试我还加了个36uF的输入电容,没什么变化(也感觉不会有),但还是加了,增加输出电容,在10uF再并一个22uF的电容,情况还是一样,但是频率会降低。


这输入电压能和什么有关啊?有哪位情况和我一样或者有发现问题的,麻烦指教一下,感谢!!!

Beancurd2
2
主题
5
回复
发表于2022-11-22 14:24:35   |  只看该作者
2#

 


看了一遍又一遍手册,发现这个细节,输出3.3V要求输入6V以上....行吧!

那我想要5V能正常工作,这个电路该做哪些改进呢?

Beancurd2
2
主题
5
回复
发表于2022-11-22 22:55:09   |  只看该作者
3#

将L1(电感)加大,我试了10uH,在5V时输出正常,再大就没试过了(也没更大的电感),能用就行

Beancurd2
2
主题
5
回复
发表于2022-12-03 23:35:43   |  只看该作者
4#
Beancurd2 发表于2022-11-22 22:55:09  3# 将L1(电感)加大,我试了10uH,在5V时输出正常,再大就没试过了(也没更大的电感),能用就行
空载输出还是有问题,还要带负载
XinLau
0
主题
1
回复
发表于2024-06-27 11:28:22   |  ip属地:重庆  |  只看该作者
5#
我现在也遇到一个问题:同样的参数,电路板改版,BL9342原理图没有变,虽是器件布局有一点变化;之前的电源工作正常;新的板子回来,VFB一直是0.66V,达不到0.794V,输出电压也是2.6几伏。搞的怀疑人生了。不知道问题出现在哪里。有知道的老师指点一下。  

主题

回复
  • 温馨提示: 标题不合格、重复发帖、发布广告贴,将会被删除帖子或禁止发言。 详情请参考: 社区发帖规则
  • 您当前输入了 0 个文字。还可以输入 8000 个文字。 已添加复制上传图片功能,该功能目前仅支持chrome和火狐

禁言/删除

X
请选择禁言时长:
是否清除头像:
禁言/删除备注:
昵 称:
 
温馨提示:昵称只能设置一次,设置后无法修改。
只支持中文、英文和数字。

举报

X
请选择举报类型:
请输入详细内容:

顶部